Job fails with bookmark table missing message

While running an InfoSphere® DataStage® job, the job fails if the InfoSphere CDC for InfoSphere DataStage server cannot write bookmark information to the bookmark table.

Symptoms

The CDC Transaction stage fails with a message that indicates that the bookmark table is missing.

Causes

The InfoSphere CDC for InfoSphere DataStage server cannot write bookmark information to the bookmark table because the table does not exist. The table might have been deleted after the subscription started.

Resolving the problem

Create the bookmark table on the target database, and then restart the subscription and job.