If you can see events in the Situation Events dashboard
but not the event details when you open the situation event results
dashboard, you might have limited permissions.
- Problem
- You are able to see events listed in the Situation Events dashboard
and other dashboards with event views. However, when you click the
link in the Situation Name column to open the event results, you get
the following error, but only if the associated error displays charted
data.
KFWITM621E The requested resource is currently
unavailable, does not exist or authorization is denied.
- Diagnosis
- Permissions controlled by the Authorization Policy Server
- You have not been assigned permission to view monitoring data
using authorization policies.
- Permissions controlled by the Tivoli® Enterprise Portal Server
- Your Tivoli Enterprise Portal user
ID does not have permission to view events or does not have permission
to see the same managed system type that you are attempting to view
the situation event results from.
- Resolution
- Permissions controlled by the Authorization Policy Server
- You can use the tivcmd listroles command to
view what roles the user is assigned to and what permissions are assigned
to that role:
tivcmd listroles -u uid=annette,cn=itm,o=tivoli
-p
Sample output:NTEventOnly
Permissions:
Domain: any
Resource Type: managedsystemgroup
Resource: *NT_SYSTEM
Object Type: event
Granted Operations: {view}
- If you determine that the role should have view operation for
the event object type, use the tivcmd
grant command to add this capability:
tivcmd
grant -n NTDataOnly -t managedsystemgroup -r *NT_SYSTEM --objecttype
event --operations view
- Enter tivcmd listroles command to view the
newly added capability:
tivcmd listroles -u
uid=jim,cn=itm,o=tivoli -p
Sample
output:NTEventOnly
Permissions:
Domain: any
Resource Type: managedsystemgroup
Resource: *NT_SYSTEM
Object Type: attributegroup
Granted Operations: {view}
- Permissions controlled by the Tivoli Enterprise Portal Server
- Edit your user ID to add Events - View permission and, if applicable,
the managed system type included in Allowed Applications.
For details, see "Using Tivoli Enterprise Portal user authorization" in
the IBM Tivoli Monitoring Administrator's
Guide.