If you get a CTJSD201E - Unable to establish communications
with the data provider server message when opening a dashboard,
review the diagnosis and resolution.
Diagnosis
The CTJSD201E - Unable to establish communications with
the data provider server message indicates that the dashboard
cannot communicate with the IBM® Tivoli® Monitoringdashboard data provider.
You can open the Dashboard Health Checks to run a health check
of your infrastructure management dashboard components and report
their status: Click System Status and Health > Dashboard Health Checks. The
connection to the dashboard data provider on
the Tivoli Enterprise Portal Server is
checked and the results are shown in the Tivoli Monitoring table.
Also, confirm the following settings and condition:
In the Dashboard
Application Services Hub,
click Console Settings > Connections and check that the provider ID for the IBM Tivoli Monitoringdashboard data provider is set to ITMSD.
Confirm that the Tivoli Enterprise Portal ServerKfwServices process
is running.
Confirm that the dashboard data provider is enabled
in the portal server configuration: In Manage Tivoli Enterprise Monitoring Services,
right-click the portal server and click Reconfigure.
The Enable the dashboard data provider check
box should be selected.
If you have not found the problem, investigate connectivity issues
between the portal server and the Dashboard
Application Services Hub.
Solution
After taking any required actions to ensure that the dashboard data provider ID is set
to ITMSD, the portal server is running, it has
been set to enabled the dashboard data provider, and that
communications with the Dashboard
Application Services Hub is working,
close the dashboard open it again to clear the error message.