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TestConnection fails with AWSITA122E java exception

Troubleshooting


Problem

AWSJCS011E, AWKJDE142E, and AWSITA122E java exception errors are received configuring an Oracle database job and testing the connection.

Symptom

Error displayed in the Tivoli Dynamic Workload Console:

AWSJCS011E An internal error has occurred. The error is the
following: "AWKJDE142E The get execution log could not be requested from
the address "https://<MDMhost>:31114/ita/JobManager"
The following error occurred: "AWSITA122E A Java exception occurred
while calling the command "TestConnection". " ".

JobManager_message.log on the dynamic agent:

10:03:56.261+08:00|ERROR|JobManager|18446744073525914512|10142|Sagent.co
m|AWSITA122E A Java exception occurred while calling the command
"TestConnection". java.lang.NoClassDefFoundError:
oracle.dms.console.DMSConsole
at oracle.jdbc.driver.DMSFactory.<clinit>(DMSFactory.java:50)
...

Cause

Before specifying the correct information for the job, whiling testing, there could be incorrect data cached in the JavaExt cache.

Diagnosing The Problem

Ensure the "JDBC Jar Class Path" is configured correctly. Refer to the link in the "Related information" section below.

Resolving The Problem

1. Clean the JavaExt cache on the agent:

- Stop the agent:
/<agt_install_dir>/TWS/ShutdownLwa

- Remove the content of the following directory (files and directories), except for the config.ini file:
/<agt_install_dir>/TWS/JavaExt/eclipse/configuration

- Restart the agent:
/<agt_install_dir>/TWS/StartUpLwa

2. Retry the Test Connection scenario.

Related Information

[{"Product":{"code":"SSGSPN","label":"IBM Workload Scheduler"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF025","label":"Platform Independent"}],"Version":"8.6","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

Maestro;TWS;TWA

Document Information

Modified date:
14 December 2018

UID

swg21631386