SE56021: RDI 9.0: LOCAL HELP UPDATER NOT WORKING DUE TO MISSING JETTY PLUGIN

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

  • When trying to use the local help updater feature without the
    'Web Developer tools' installable feature installed, it will
    fail with a pop up that says:
    'A connection to the Local Help Updater cannot be established.
    Save all your work, restart the application, and then retry to
    update your help content'
    
    When this problem occurs, the workspace/.metadata/.log file
    will have an error:
    '!MESSAGE Jetty plugins are unavailable, could not start local
    server'
    
    This occurs because the plugin org.eclipse.jetty.webapp
    required for the local help updater was not installed.
    
    This problem does not occur if the 'Web Developer tools'
    installable feature is installed.  The Modify wizard in IBM
    Installation Manager can be used to add or remove installed
    features.
    
    There is another workaround for this problem in a technote
    written for a different product that can be used:
    
    http://www-01.ibm.com/support/docview.wss?uid=swg21641599
    
    Note: once the issue is resolved in the product, this
    workaround would need to be removed.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED: Those using the local help updater without   *
    *                 the 'Web Developer tools' feature installed  *
    ****************************************************************
    * PROBLEM DESCRIPTION: Local Help Updater not working due to   *
    *                      missing jetty plugin                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    When trying to use the local help updater feature without the
    'Web Developer tools' installable feature installed, it will
    fail with a pop up that says:
    'A connection to the Local Help Updater cannot be established.
    Save all your work, restart the application, and then retry to
    update your help content'
    
    When this problem occurs, the workspace/.metadata/.log file
    will have an error:
    '!MESSAGE Jetty plugins are unavailable, could not start local
    server'
    
    This occurs because the plugin org.eclipse.jetty.webapp
    required for the local help updater was not installed.
    
    This problem does not occur if the 'Web Developer tools'
    installable feature is installed.
    

Problem conclusion

  • This problem is fixed in the RDi 9.0.0.1 update.
    

Temporary fix

Comments

APAR Information

  • APAR number

    SE56021

  • Reported component name

    RATL DEV FOR I

  • Reported component ID

    5724Y99DI

  • Reported release

    900

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2013-07-09

  • Closed date

    2013-08-12

  • Last modified date

    2013-08-12

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    RATL DEV FOR I

  • Fixed component ID

    5724Y99DI

Applicable component levels

  • R900 PSY

       UP



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Developer for i

Software version:

9.0

Reference #:

SE56021

Modified date:

2013-08-12

Translate my page

Machine Translation

Content navigation