IBM Support

Local download of the documentation does not work

Troubleshooting


Problem

When trying to download the Rational Software Architect RealTime Edition v9.0 documentation by means of the local installation option, the operation cannot be completed. The information center contents are not downloaded and installed locally on the user's system. Only a partial table of contents (for example, the "Installing" book is missing), is displayed.

Cause

The Jetty Server is not running. This is because the org.eclipse.jetty.webapp plugin is missing from the installed offering.

Diagnosing The Problem

Check the .log file in your workspace/.metadata/folder for the text: !MESSAGE Jetty plugins are unavailable, could not start local server.

Resolving The Problem

To enable the local download/install functionality, download and install the missing org.eclipse.jetty.webapp plugin and restart the product.

    1. In your product installation folder (by default, <install_dir>/SDP), create a new folder called dropins.
    2. Download the attached org.eclipse.jetty.webapp plugin.
    3. Extract the contents. Copy the Eclipse folder and paste it into the dropins folder.
    4. Restart RSARTE.
Assuming the Help Content preference is set to Local, the help will download automatically and display correctly when invoked.

[{"Product":{"code":"SS5JSH","label":"Rational Software Architect RealTime Edition"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Eclipse","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.0","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21641599