IBM Support

IT21140: SECURITY: ESCALATION TO ROOT VULNERABILITY IN DB2.

Subscribe

You can track all active APARs for this component.

APAR status

  • Closed as program error.

Error description

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * ALL                                                          *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See Error Description                                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Upgrade to Db2 11.1 Mod 2 Fix Pack 2 iFix001 or higher       *
    ****************************************************************
    

Problem conclusion

  • First fixed in Db2 11.1 Mod 2 Fix Pack 2 iFix001
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT21140

  • Reported component name

    DB2 FOR LUW

  • Reported component ID

    DB2FORLUW

  • Reported release

    B10

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2017-06-22

  • Closed date

    2017-10-11

  • Last modified date

    2017-10-11

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    IT21143 IT21163 IT21164

Fix information

  • Fixed component name

    DB2 FOR LUW

  • Fixed component ID

    DB2FORLUW

Applicable component levels

  • RB10 PSN

       UP



Document information

More support for: DB2 for Linux, UNIX and Windows

Software version: B10

Reference #: IT21140

Modified date: 11 October 2017