Fix pack version errors during IBM InfoSphere Information Server installation

When you pre-install IBM® WebSphere® Application Server separately before you install InfoSphere® Information Server, the installation program halts with an error if fix packs later than 7.0.0.11 are installed. The problem also occurs if you have installed Fix Pack 7.0.0.11 and iFix IFPM20596. You can ignore these errors and continue the installation.

Symptoms

The Prerequisites Check page displays messages like the following lines. The messages also appear in the installation log file:

WARNING: com.ibm.is.install.check.WebSphereVersionChecker No iFixes found in the WebSphere Application Server installation.

INFO: FAILED: CDIPR2118I: Ensure that the WebSphere Application Server version has the fix packs 6.1.0.29:IFPK96868, 6.1.0.29:MultiOS-IFPK99266, 6.1.0.29:IFPK99560, 7.0.0.11:IFPK96868, 7.0.0.11:IFPM20596, 7.0.0.11:IFPM21207. Detected fix packs for version 7.0.0.11. Resolution: Follow WebSphere Application Server Fix Pack installation instructions to install the Java SDK and Fix Packs to the required level.

Causes

The Java software development kit (SDK) that is installed with these fix packs is a higher version than the installation program expects. However, InfoSphere Information Server supports this version.

Environment

All environments

Resolving the problem

Restart the installation program with the -force option on the command line. This option enables a check box within the Prerequisites Check page that allows you to continue even if the prerequisites check returns warnings or errors.

Use the -force option with caution. Be sure to resolve any other warnings or errors that appear during the prerequisites check. Continuing an installation with unresolved warnings or errors might result in a non-operational InfoSphere Information Server instance.