Resolving problems logging in to the WebSphere Application Server administrative console

Use this troubleshooting information when you are running a stand-alone installation of IBM® WebSphere® Application Server Network Deployment with IBM InfoSphere® Information Server and you cannot log in to the WebSphere Application Server administrative console.

Symptoms

You cannot log in to the WebSphere Application Server administrative console of an WebSphere Application Server installation that is running InfoSphere Information Server.

Causes

There are multiple reasons why the login fails.

Environment

This advice applies to all environments that are supported by InfoSphere Information Server.

Diagnosing the problem

Ensure that you are using the default IBM WebSphere Application Server administrator user name and password. If you are not sure of the WebSphere Application Server administrator user name, you can view the WebSphere Application Server security.xml file.
Attention: Do not modify this file.

The security.xml file is in the following directory:

Operating system Directory
AIX® Solaris /opt/IBM/WebSphere/AppServer/profiles/profile_name/config/cells/cell
Linux /opt/IBM/WebSphere/AppServer/profiles/profile_name/config/cells/cell
Windows \IBM\WebSphere\AppServer\profiles\profile_name\config\cells\cell

profile_name is the name of the WebSphere Application Server profile being used (the default name is InfoSphere). cell is the name of the WebSphere Application Server cell.

The user name is specified by the serverId attribute in the userRegistries element of the active user registry. Ensure that you are looking at the serverId of the active user registry. To find the active user registry in the security.xml file, look for the activeUserRegistry string in the file. The file contains an entry that is similar to activeUserRegistry=UserRegistry, where the UserRegistry value depends on your configuration. Search the remainder of the security.xml file for this value, which determines the current active user registry. Ensure that you can access the registry. For example, if you are using an LDAP user registry, ensure that the LDAP server is running and that you can connect to it. If you are using the InfoSphere Information Server internal registry, ensure that the database server that is used by InfoSphere Information Server is running and that you can access it.

Resolving the problem

If the user name or password is invalid or unknown:
  1. Change the password.
    • If your installation is configured to use the InfoSphere Information Server internal user registry, enter the following DirectoryAdmin command to change the password:
      Operating system Command
      AIX Solaris install_home/ASBServer/bin/DirectoryAdmin.sh -user -userid wasadmin_username -password wasadmin_password
      Linux install_home/ASBServer/bin/DirectoryAdmin.sh -user -userid wasadmin_username -password wasadmin_password
      Windows install_home\ASBServer\bin\DirectoryAdmin -user -userid wasadmin_username -password wasadmin_password
    • If your installation is configured to use an external user registry (such as a local operating system user registry or an LDAP user registry), use operating system or LDAP utilities to change the password.
  2. Enter the following AppServerAdmin command to update the WebSphere Application Server and InfoSphere Information Server configurations:
    Operating system Command
    AIX Solaris install_home/ASBServer/bin/AppServerAdmin.sh -was -user username -password password
    Linux install_home/ASBServer/bin/AppServerAdmin.sh -was -user username -password password
    Windows install_home\ASBServer\bin\AppServerAdmin -was -user username -password password