Connection problems after IBM WebSphere Application Server cluster members are removed

You might experience connection problems with the WebSphere® Application Server administrative console or IBM® InfoSphere® DataStage® clients if you remove all members of a WebSphere Application Server cluster.

Symptoms

You cannot access the WebSphere Application Server administrative console, or log in to InfoSphere DataStage clients. You recently removed all members of the WebSphere Application Server cluster and then added members again.

Causes

When all cluster members are removed from the cluster, the cluster template is removed. New cluster members are set up with the default cluster template. The default template is not compatible with IBM InfoSphere Information Server.

Environment

All environments.

Resolving the problem

  1. Rebuild the cluster as described in Adding a new cluster member. Do not start the cluster yet.
  2. On the computer that hosts the Deployment Manager, run the following command:
    Operating system Command
    AIX® Solaris installdir/ASBServer/bin/reconfigure_was_cluster.sh -user wasadmin_user -password wasadmin_password
    Linux installdir/ASBServer/bin/reconfigure_was_cluster.sh -user wasadmin_user -password wasadmin_password
    Windows installdir\ASBServer\bin\reconfigure_was_cluster.bat -user wasadmin_user -password wasadmin_password

    wasadmin_user and wasadmin_password are the user name and password of the WebSphere Application Server administrator.

  3. Start the cluster as described in Restarting application server processes.