Installation errors on a WebSphere application server 8.5 dynamic cluster

The InfoSphere Information Server, Version 11.3.1.2 installation fails on a WebSphere Application Server 8.5 if it is a dynamic cluster and not in manual mode or if the installation target is not in the host aliases.

Symptoms

You will see an exception indicating that a requested-URI was not found, or an exception in the InfoSphere Information Server installation log, after restarting the cluster.

Causes

As part of an InfoSphere Information Server installation process, the WebSphere Application Server cluster is stopped and started multiple times. This is required because InfoSphere Information Server performs certain tasks which require the WebSphere Application Server cluster to be stopped. However, in case of a WebSphere Application Server dynamic cluster, if the operational mode is set to Automatic, it will start up automatically, whenever it is stopped. This could cause a problem to the InfoSphere Information Server install, if the WebSphere Application Server cluster comes up automatically, after the Installation Code issues a stopCluster command and before issuing a startCluster command.

In addition, if the port number of the installation target (either the web server or the cluster member) is not in the WebSphere Application Server host-aliases configuration, the installation can fail when it tries to communicate to the services after restarting the cluster.

Resolving the problem

You must check for exceptions in the installation logs that indicate that a requested-URI was not found, while executing the command: UpdateSignerCerts.sh, or exceptions seen in the InfoSphere Information Server install log, after a restart of the cluster.

The following configuration steps are required before installing InfoSphere Information Server 11.3.1.2 on a WebSphere Application Server 8.5 dynamic cluster:
  1. Ensure that the operational mode of the dynamic cluster is set to Manual. When the operational mode is set to automatic, the cluster may start up even when the InfoSphere Information Server installer wants it to be stopped.
  2. In the installation wizard, you must choose to install against one of the cluster members or to the front end HTTP server or load balancer. Check the host name and the port number (for example, 9443 or 9444) of your choice and ensure that they are defined in "Host-aliases" in the WebSphere Application Server Administration console. This can be done by executing the following steps:
    1. Log in to the WebSphere Application Server Administration console and go to "Environment --> Virtual Hosts --> default_host --> Host_aliases". If the required host or port number is not present in the "host-aliases-list", then click New, and specify the required port number and the host name (specify "*" for hostname to accept any hostname/host-alias/IP-address.
    2. After adding the port number and host name (or *) click Update global Web server plug-in configuration under Environment in the WebSphere Application Server Administration console.

After performing these steps, launch the installation of InfoSphere Information Server, Version 11.3.1.2.