IBM Support

IBM z Systems Batch Network Analyzer (zBNA) Tool

Product documentation

Abstract
zBNA is a PC-based productivity tool designed to provide a means of estimating the elapsed time for batch jobs solely based on the differences in CPU speeds for a base processor and a target processor, the number of engines on each system, and system capacities; data sharing is not considered. zBNA provides powerful, graphic demonstration of the z/OS batch window.


Product Name:
zBNA
Product Version:
1.6.6
Operating System:
Windows 7 64-bit only
Change Date:
September 30, 2015
Approximate Size:
133MB
Click on the icon to download the zBNA install package to include the required IBM Java
Click on the icon to view/download the user's guide

zBNA   requires  an independent version of the IBM CPS Java Runtime Environment v7  64-bit , which is packaged with the tool .

Obtain the CP3KEXTR program
CP3KEXTR runs on a System z processor under z/OS. It reads the SMF records to produce an Enterprise Data File (.edf) that contains the SMF Type 70's & 113 data and a (.dat) file, which contains the Type 14, 15, 30, 42 data as input to zBNA.

Access the CP3KEXTR materials .

Hide details for What's New What's New
V1.6.6 (09/30/2015)
  • GCP physical utilization graph implemented on the main Graph menu.
  • zBNA displays a warning message when CP3KEXTR is older than six months.

V1.6.5 (07/31/2015)
There are no function changes in the tool for this release, however, a mandatory update to some of the tool's packaging files was required.

V1.6.4 (06/30/2015)
  • Enhancements made to the load files process.
  • Improvement in recognizing invalid SMF 14 records on input to the zEDC function.
  • The tool now reports CPU delay data for a specific job.
  • Miscellaneous other enhancements and bug fixes.

V1.6.3 (03/27/2015)
  • An option, Create CSV File – All data , has been added on the File menu allowing all of the zEDC data sets to be saved.
  • In the EXTRZBNA member of the CP3KEXTR program, do not specify a DURATION less than 00:05 minutes.
  • Apply SMT defaults ( 25% for zIIP and IFL is 20% ) using Action , Apply IFL/Apply zIIP SMT Defaults . Manually input values in the SMT column on the zIIP and/or IFL rows. The % is automatically applied; press Enter while the cursor is in the input field.
  • Miscellaneous bug fixes.

V1.6.2 (03/2/2015)
  • Fixed problem with sorting in the columns on the zEDC Top Data Sets panel.
  • Added the Locale to the zBNA saved study file. This feature is supported for version 1.6.2 and future ones.
  • Added a new column, Delta DASD Space MB, to the zEDC table to estimate how many MBs won't be stored on disc as a result of converting the dataset to zEDC.
  • Miscellaneous bug fixes.

V1.6.1 (01/30/2015)
Miscellaneous enhancements and bug fixes.

V1.5.1 (12/12/2014)
  • Enhancements made to the “zEDC Top Data Sets” panel include;
  • New graph, Dataset Gigabytes per Hour, has been added.
  • Added a filter function, Graphing Options, to support what gets graphed.
  • A checkbox column has been added to the DSN table allowing data sets to be included or excluded from the graphs.
  • The status bar has been added at the bottom of the table to show how many DSNs (maximum is 1000) there are.
  • A total row has been added for each compression type in the zEDC report.
  • A file is created when zBNA detects an error. The default directory where the file is saved is C:\Users\IBM_ADMIN\AppData\Roaming\zBNA .

V1.5.0 (10/21/2014)
  • The Job Information panel (Step Details) was updated to look as the regular panels. The panel can now be resized.
  • Step Details will include a new Proc Step column containing the procedure step name. Note : The data must be extracted using the CP3KEXTR program dated 10/10/2014 or later .
  • Improvements in load processing to help handle large amounts of data.
  • Fixes to CSV and HTML generation for zEDC
  • Fix to the main table and filters (seconds added where needed)
  • The “zEDC Top Data Sets” panel now shows the estimated I/O Count, I/O time, and CPU Time deltas, if the candidate data set would be compressed with zEDC. For current PS and EF data sets this panel also allows the user to specify a compression ratio used for the estimate.
  • Added the following zEDC graphs: Projected zEDC CPU Savings , Projected zEDC I/O Count , and zEDC Dataset Analysis .
  • Reporting on selection detail of the SMF 14/15s used in the zEDC analysis has been added.

V1.4.6 (08/29/2014)
  • Added the IIP CP Time column on the zBNA main panel.
  • The "Load" function has been enhanced to allow loading different files without exiting the tool.
  • Updates to the zEDC graph; Generic, Tailored, and zEDC are now supported.
  • Support has been added to load in tersed .dat files.
  • The Find command is now case insensitive.
  • Added the ability to create a CSV file from the zEDC graph.
  • Regular maintenance.

V1.4.5 (05/30/2014)
  • zBNA now allows a job class that is greater than one character.
  • The CSV save function now includes overwrite, append, and cancel options.
  • The "Clear Data" function has been removed from the File menu on the main zBNA panel. Enhancements are being made, and the function will be available in 3Q2014.
  • The value in the "Comp Ratio" column in the table on the "zEDC Top Data Sets" graph panel now has one decimal place.

V1.4.3 and V1.4.4 (05/01/2014)
  • On entry to the zEDC Compression function, the “zEDC Top Data Sets” panel now displays first. Access the graph using the Action menu.
  • Add the RW Ratio and Comp Ratio columns to the table on the “zEDC Top Data Sets” panel.
  • Ad the Compression Type , RW Ratio , and Comp Ratio table on the zEDC graph panel.
  • Add the Block Size column to the table on both the “Job Dataset Report” and “Life of a Dataset” panels.
  • Add the IIP CP Time column to the table on the “Job Information” panel.
  • For a selected job on the graph, show the name of the alternate CPU in the tooltip.
  • Fixed a problem to correctly format the EXCP data on the zBNA main panel and in the CSV when the value is greater than 1,000.
  • Columns can now be sorted on the “Job Information” panel while keeping the blue highlighted line remains on the job.

V1.4.2 (03/17/2014)
  • Add Report to the Action menu on the “Job Dataset Report” panel.
  • Add Report to the Action menu on the “Life of a Dataset” panel.
  • Add Create CSV file to the File menu on the “zEDC Top Data Sets” panel.
  • The check boxes on the “zEDC Top Data Sets” and “zEDC Options” are interchangeable.
  • Corrected the problem with national language and the decimal point not saved correctly in the “ .zBNA ” file.
  • Corrected the problem with the filters not being identified correctly with the report generation.
  • Implemented the support to generate an error file, if zBNA crashes.

V1.4.1 (02/11/2014)
  • The zEDC Compression function has moved to the Action menu.
  • The routine that loads the SMF Type 14/15 records for the zEDC Compression function has been significantly improved to only read the input file one time!
  • A cover page has been added to the zBNA report.
  • The Find and Find Next are now available on the Edit menu on several of the zBNA panels that contain tables.
  • The ability to generate CSV output has also been added to the File menu on the “Job Dataset Report”, “Top 10 Data Sets”, and “Life of a Dataset” panels.
  • Updated the CSV output to contain periods for decimals even in countries where it is a comma so that the CSV can be parsed.

V1.3.0 (12/31/2013)
IBM zEnterprise Data Compression (zEDC) support is implemented. SMF Record Types 14 and 15 are required. Invoke the function using the zEDC: Compression menu on the main zBNA panel. Use the CP3KEXTR program dated 12/12/13 or later .

Hide details for Installation of zBNA on Windows Installation of zBNA on Windows
Note : While a new installation should install over a previous one, it is recommended to first perform an uninstall using Program and Features.

After downloading the package file for zBNA, execute it by:
  • selecting RUN under the Windows START button,
  • opening a MS-DOS command prompt window in the directory were the package file was saved and typing the filename or opening the folder where the file was saved; double click on the filename.
Hide details for Education Education
  1. Replay of the Customer Webcast that was held on June 20, 2013: http://ibmstg.adobeconnect.com/replaysyszbna06202013/
  2. zBNA Lab Exercise: zBNA Tool - Hands-On Lab.pdf zBNA Tool - Hands-On Lab.pdf
  3. zBNA Lab Exercise Test Files: zBNA Tool - Hands-on Lab Data Files.zip zBNA Tool - Hands-on Lab Data Files.zip
Hide details for Support and Contacts Support and Contacts
Please send questions/comments to zpcr@us.ibm.com.

    Other Information :
    Category : Performance
    Organization : Advanced Technical Sales

    Techdocs Technical Support Information

    Document information

    More support for: Unclassified - SW Type

    Operating system(s): z/OS

    Reference #: PRS5132

    Modified date: 02 October 2015


    Translate this page: