IBM Support

Security Bulletin: Authenticated Users Can Gain Privilege in IBM UrbanCode Deploy (CVE-2017-1493)

Security Bulletin


Summary

Previous releases of IBM UrbanCode Deploy allow authenticated users to view and edit information they do not have permission to.

Vulnerability Details

CVEID: CVE-2017-1493
DESCRIPTION: IBM UrbanCode Deploy (UCD) could allow an authenticated user to edit objects that they should not have access to due to improper access controls.
CVSS Base Score: 4.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/128691 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)

Affected Products and Versions

All fixpacks of IBM UrbanCode Deploy 6.1 - 6.1.3.6 and IBM UrbanCode Deploy 6.2 - 6.2.6.1 are affected.

Remediation/Fixes

Upgrade to IBM UrbanCode Deploy 6.2.7.0 or later. If it is not possible to upgrade to 6.2.7.0, upgrade to IBM UrbanCode Deploy 6.1.3.7.

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

Reference

Complete CVSS v2 Guide
On-line Calculator v2

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.


Cross reference information
Product Component Platform Version Edition
IBM UrbanCode Deploy Security Linux, Windows 6.1, 6.1.0.1, 6.1.0.2, 6.1.0.3, 6.1.0.4, 6.1.1, 6.1.1.1, 6.1.1.2, 6.1.1.3, 6.1.1.4, 6.1.1.5, 6.1.1.6, 6.1.1.7, 6.1.1.8, 6.1.2, 6.1.3, 6.1.3.1, 6.1.3.2, 6.2, 6.2.0.1, 6.2.0.2, 6.2.1, 6.2.1.1, 6.1.3.3, 6.2.1.2, 6.2.2, 6.2.2.1, 6.2.3.0, 6.2.3.1, 6.1.3.5, 6.1.3.4, 6.2.4, 6.2.4.1, 6.1.3.6, 6.2.4.2, 6.2.5, 6.2.5.1

Document information

More support for: IBM UrbanCode Deploy

Component: Security

Software version: 6.1, 6.1.0.1, 6.1.0.2, 6.1.0.3, 6.1.0.4, 6.1.1, 6.1.1.1, 6.1.1.2, 6.1.1.3, 6.1.1.4, 6.1.1.5, 6.1.1.6, 6.1.1.7, 6.1.1.8, 6.1.2, 6.1.3, 6.1.3.1, 6.1.3.2, 6.1.3.3, 6.1.3.4, 6.1.3.5, 6.1.3.6, 6.2, 6.2.0.1, 6.2.0.2, 6.2.1, 6.2.1.1, 6.2.1.2, 6.2.2, 6.2.2.1, 6.2.3.0, 6.2.3.1, 6.2.4, 6.2.4.1, 6.2.4.2, 6.2.5, 6.2.5.1

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: C1000367

Modified date: 15 November 2018