IBM Support

Readme for IBM WebSphere Application Server Liberty 17.0.0.2

Product readme


Abstract

Readme documentation for Fix Pack 17.0.0.2 of the WebSphere Application Server Liberty offerings, including installation-related instructions, prerequisites, highlights, and known issues.

Content


IBM WebSphere Application Server Liberty Core
IBM WebSphere Application Server Liberty
IBM WebSphere Application Server Liberty Network Deployment
IBM WebSphere Application Server Liberty for z/OS
IBM WebSphere Application Server Liberty ILAN
IBM Web Enablement Liberty for IBM i

Table of Contents



Compilation date: June 13, 2017


© Copyright International Business Machines Corporation 2017. All rights reserved.
US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

 
What's new

Support for using Java SE 6 with WebSphere Liberty ends in September 2017. See removal notice. After the end of support, the Liberty kernel will be recompiled and can no longer run with Java SE 6. If you continue to use Java SE 6 on earlier fix packs after the end of support date, you could expose your environment to security risks.

Java SE 8 is the recommended Java SDK because it provides the latest features and security updates.

Inspur K-UX support for WebSphere Application Server Liberty is removed from 17.0.0.1.

About Fix Pack 17.0.0.2

Fix Pack 16.0.0.2 introduced new fix pack numbering for common Liberty fix packs that apply to both Version 8.5 and Version 9.0 of WebSphere Application Server on all supported platforms. You can use files from the Fix Pack 17.0.0.2 download page to update Liberty for both WebSphere Application Server Version 8.5 and Version 9.0.

Support for using Java SE 6 with WebSphere Liberty ends in September 2017. After the end of support, the Liberty kernel will be recompiled and can no longer run with Java SE 6. If you continue to use Java SE 6 on earlier fix packs after the end of support date, you could expose your environment to security risks.

Java SE 8 is the recommended Java SDK because it provides the latest features and security updates.

Prerequisites

Before you install Liberty, verify that your system meets the relevant requirements listed on WebSphere Application Server detailed system requirements, IBM WebSphere SDK Java Technology Edition 7.1 Supporting Software and IBM WebSphere SDK Java Technology Edition 8 Supporting Software.


For installing this Liberty fix pack using Installation Manager, download and install Installation Manager 1.8.5 or later from the IBM Installation Manager download website. The Liberty fix pack for Installation Manager must be installed on top of an existing Liberty installation.

Space requirements

The amount of disk space required varies with the number of features or products installed. If you are installing the product using Installation Manager, the installation summary panel indicates the approximate amount of disk space required based on the features and products you have selected. For a fix pack, you need less than 500MB of free disk space.
Steps for installing Fix Pack 17.0.0.2

For instructions on installing fix packs, see the product documentation for your platform:



Known issues
See Database changes for Java Batch in 16.0.0.4

Change history

Date Change
June 13, 2017 Initial publication for Fix Pack 17.0.0.2

Additional information

You can find additional information about the product in the WebSphere Application Server Liberty product documentation.

For more information about available updates, refer to Recommended updates for WebSphere Application Server.
Trademarks and service marks

For trademark attribution, visit the IBM Terms of Use website.

Document information

More support for: WebSphere Application Server
General

Software version: 17.0.0.2

Operating system(s): AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS

Software edition: Base, Network Deployment

Reference #: 7049870

Modified date: 13 June 2017


Translate this page: