IBM Support

TPC 5.2.0 - 5.2.7 - Platform Support: Agents, Servers and Browsers

Product documentation


Abstract

What are the supported platforms for the various Tivoli Storage Productivity Center V5.2.x components? Where can I install it? What databases are supported? What operating systems are supported?

Content

Supported Platforms

Database Repository
Jazz for Service Management
Server, GUI, CLI
Agents
Hypervisor
Multipathing
Database Monitoring
Web Browsers
IBM Tivoli Monitoring Agent for Tivoli Storage Productivity Center

Click here for the platform support matrix for IBM Spectrum Control 5.2.8 and higher.


Database Repository

DB2 Enterprise Server Edition (64-bit) Last Updated: 2017-June-5
DB2 9.7
Fix Pack Level
Supported
Notes
Note: DB2 9.7 end of support (EOS) is September 30, 2017. For more information see the DB2 Distributed end of support dates:
http://www-01.ibm.com/support/docview.wss?uid=swg21168270
Installation requirements

Upgrade restrictions

Known AIX issues

Fix Packs
Fix Pack 3a or earlier
No
N/A
Fix Pack 4
Yes
DB2 9.7 fix pack 4 is not supported for Jazz for Service Management. Some users have also experienced stability issues because of a limit change on background tasks (APAR IC76118) when using this fix pack.
Fix Pack 5
No
N/A
Fix Pack 6
Yes
For Russian and Czech languages, DB2 9.7 fix pack 6 and higher fix packs should not be used as installation failures occurred with Tivoli Storage Productivity Center due to a JDBC driver issue. Use fix pack 4 or upgrade to DB2 10.5 for a fix to APAR IC87668.
Fix Pack 7
Yes
Fix Pack 8
Yes
Fix Pack 9 or 9a
Yes
Fix Pack 10
Yes
Higher Fix Packs
Yes
Higher DB2 fix pack levels can be used with Tivoli Storage Productivity Center. Any issues will be added to this listing as they are identified.
DB2 10.1
Fix Pack Level
Supported
Notes
Note: DB2 10.1 end of support (EOS) is September 30, 2017. For more information see the DB2 Distributed end of support dates:
http://www-01.ibm.com/support/docview.wss?uid=swg21168270
Installation requirements

Upgrade restrictions

Known AIX Issues

Fix Packs
Fix Pack 1 or earlier
No
N/A
Fix Pack 2
Yes
DB2 APAR IC86835 may be encountered and affect retrieving data from the Tivoli Storage Productivity Center database.
Fix Pack 3 or 3a
Yes
Fix Pack 4
Yes
db2profile must be sourced prior to starting the Tivoli Storage Productivity Center installation.
Fix Pack 5
No
Problems may occur with new installations and upgrades of Tivoli Storage Productivity Center when using DB2 10.1 fix pack 5 and higher. Use IBM Spectrum Control 5.2.8 or higher instead.
Higher Fix Packs
No
DB2 10.51
Fix Pack Level
Supported
Notes
Installation requirements

Upgrade restrictions

Known AIX Issues

Fix Packs
GA (Fix Pack 0)
Yes
During uninstallation of Tivoli Storage Productivity Center, the DB2 service may not stop as expected and cause a hang while Tivoli Storage Productivity Center waits for the service to stop. See the Limitations and Known Issues for 5.2.1 technote for workaround details.
Fix Pack 3 or 3a
Yes
Fix Pack 4
Yes
DB2 APAR IT04326 may be encountered and consume additional memory while running Tivoli Storage Productivity Center. It is resolved with DB2 10.5 FP5.
Fix Pack 5
Yes
Fix Pack 6 or Higher
No
Problems may occur with new installations and upgrades of Tivoli Storage Productivity Center when using DB2 10.5 fix pack 6 and higher. Use IBM Spectrum Control 5.2.8 or higher instead
DB2 Notes:
1 DB2 10.5 is supported starting with Tivoli Storage Productivity Center 5.2.1. Tivoli Storage Productivity Center 4.2.x should be upgraded to 5.2.1 or later before upgrading to DB2 10.5.

If a non-Administrator user account is going to do the DB2 installation, then the VS2010 runtime library must be installed before attempting to install the DB2 product. See the DB2 Information Center for more details regarding vcredist_x64.exe for 64-bit systems.


Jazz for Service Management
Last Updated: 2014-March-27
Version Operating Systems Components
1.1.0.13
  • Tivoli Common Reporting 3.1.0.1
  • Cognos 10.2
AIX4
Linux
Windows
Reporting Services1
Security Services2
1.1.0.3
  • Tivoli Common Reporting 3.1.0.2
  • Cognos 10.2.0.1
Jazz for Service Management Notes:
1 Install the Reporting Services component if you want to use Cognos BI reports.

2 Install the Security Services to configure supported IBM storage devices (DS8K and SVC family) with LDAP authentication and to enable single sign-on from Tivoli Storage Productivity Center to these supported devices.

3 Jazz for Service Management 1.1.0.1 is not supported beyond Tivoli Storage Productivity Center 5.2.0. An upgrade is required for use with Tivoli Storage Productivity Center 5.2.1 and later.

4 If you install Jazz for Service Management with Tivoli Storage Productivity Center on AIX 7.1TL3 (SP0-1), you must first apply the fix for AIX APAR IV52745. You can download the fix for APAR IV52745 at the following location: ftp://aix.software.ibm.com/aix/ifixes/iv52745/

For more information about the Jazz for Service Management hardware and software requirements, see the Information Center.


Server, GUI, CLI
Tivoli Storage Productivity Center is a 32-bit application that can run in compatibility mode on hosts with 64-bit processors.

By Platform:
AIX, Linux, VM on Hyper-V, VM on KVM, VM on VMware, Windows, z/OS
Platform
Last updated: 2017-June-5
AIX
Server
Stand-alone GUI & CLI
AIX 6.12
(64-bit)
-POWER5
-POWER6
-POWER7
-POWER7+
No
No
AIX 7.11
(64-bit)
-POWER5
-POWER6
-POWER7
-POWER7+
-POWER8 (TPC 5.2.3+)
Yes
Yes
AIX VIOS
No
No
AIX VIO Client
Yes
Yes
AIX Server Notes:
1 Minimum AIX levels:
  • For AIX 7.1, the minimum maintenance levels required are:
    Technology Level 7100-00 (excluding Service Pack 3)
    Technology Level 7100-01 Service Pack 2

Review whether AIX APAR IV22062 affects the levels in your environment and install the fix if needed. The Known Issues for DB2 on AIX document includes this and other APARs.

If you install Jazz for Service Management with Tivoli Storage Productivity Center on AIX 7.1TL3 (SP0-1), you must first apply the fix for AIX APAR IV52745. You can download the fix for APAR IV52745 at the following location: ftp://aix.software.ibm.com/aix/ifixes/iv52745/

Review whether AIX APAR IV22132 affects the levels in your environment and install the fix if needed. The Known Issues for DB2 on AIX document includes this and other APARs.

You can determine the Technology Level and Service Pack installed by running the oslevel -s command. Select any necessary fixes and download packages from Fix Central.

2 AIX 6.1 end of support (EOS) was April 30, 2017, therefore Tivoli Storage Productivity Center is removing support for this particular version of AIX. For more information see the AIX support lifecycle information:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1012517
Linux
Server
Stand-alone GUI & CLI
Red Hat Enterprise Linux 7
No
No
Red Hat Enterprise Linux Base Server and Advanced Platform 51
(x86-64)
No
No
Red Hat Enterprise Linux Base Server and Advanced Platform 6
(x86-64)
Yes
Yes
SuSE Linux Enterprise Server 11
(x86-64)
Yes
Yes
Linux Server Notes:
1 Red Hat has ended support for version 5 of Enterprise Linux product, therefore Tivoli Storage Productivity Center is removing support for this particular version of Linux. For more information see the Life-Cycle section on this web page:
https://access.redhat.com/support/policy/updates/errata/
VM on Hyper-V
Server
Stand-alone GUI & CLI
Microsoft Hyper-V
No
No
VM on KVM
Server
Stand-alone GUI & CLI
KVM 2.0
(x86-64)

Guest OS:

Linux

-RedHat Enterprise Linux 61 (TPC 5.2.1+)
-SUSE Linux Enterprise Server 11

Windows

-Windows 20081 (TPC 5.2.1+)
-Windows 2008 R21 (TPC 5.2.1+)
-Windows 20121 (TPC 5.2.1+)

Yes
See corresponding operating system row for hardware support.
Yes
See corresponding operating system row for hardware support.
VM on KVM Server Notes:
1 Support for certain guest operating systems requires a minimum version of Tivoli Storage Productivity Center as noted above.
VM on VMware
Server
Stand-alone GUI & CLI
VMware ESX and ESXi 3.5.x1, 4.0.x, 4.1.x, 5.0.x, 5.1.x, 5.5.x2

Guest OS:

Linux

-RedHat Enterprise Linux 6

Windows

-Windows 2008
-Windows 2008 R2
-Windows 2012
-Windows 2012 R2 (TPC 5.2.3+)

Yes 1, 2
See corresponding operating system row for hardware support.
Yes
See corresponding operating system row for hardware support.
VM on VMware Server Notes:
1 VMware ESX 3.5.x is no longer tested starting withTivoli Storage Productivity Center 5.2.1.

2 VMware ESXi 5.5.x support requires a minimum version of Tivoli Storage Productivity Center 5.2.1.
Windows
Server
Stand-alone GUI & CLI
Windows 2008
(x86-64)
-Standard Edition
-Enterprise Edition
Yes
Yes
Windows 2008 R23
(x86-64)
-Standard Edition
-Enterprise Edition
Yes
Yes
Windows 20121
(x86-64)
-Standard Edition
Yes 1
Yes
Windows 2012 R22
-Standard Edition
Yes 2
Yes
Windows 7
(x86, x86-64)
No
Yes
Windows Server Notes:
1 Windows 2012 support is available when using Jazz for Service Management 1.1.0.3, which can be found in the Tivoli Storage Productivity Center 5.2.1 and later packages. Use that instead of Jazz for Service Management 1.1.0.1, which came with Tivoli Storage Productivity Center 5.2.0, and you can avoid the multi-server installation procedure that was previously required for Windows 2012 support with Tivoli Storage Productivity Center 5.2.0. Jazz for Service Management 1.1.0.1 does not support Windows 2012. Refer to the Jazz for Service Management Information Center for more details regarding hardware and software requirements.

2 Windows 2012 R2 support is available with Tivoli Storage Productivity Center 5.2.3 and later. It requires a minimum version of DB2 10.1 FP4. Additionally, Windows 2012 R2 can be used with Tivoli Storage Productivity Center for Replication 5.2.1 at the standby server site only. The Jazz for Service Management 1.1.0.3 installation may present a system prerequisite warning with a failure for Windows 2012 R2 in the details. This can be ignored. Some users have reported that they needed to modify the ODP.cfg file to install on Windows 2012 R2.

3 Apply Microsoft KB2577795 to avoid kernel socket leaks with the Tivoli Storage Productivity Server on Windows 2008 R2. You can check whether it is installed using the following command: wmic qfe | find "KB2577795"
z/OS
Server
Stand-alone GUI & CLI
V1.12, V1.13
Yes
Replication Server only
No


Agents

The legacy Common Agent Services based agents from Tivoli Storage Productivity Center 3.x cannot be used with Tivoli Storage Productivity Center 5.2.

Tivoli Storage Productivity Center is a 32-bit application that can run in compatibility mode on hosts with 64-bit processors. Support for 32-bit and 64-bit will vary by platform and is designated below.

By Platform:
AIX, HP-UX, Linux, Solaris, VM on Hyper-V, VM on KVM, VM on VMware, Windows
Platform
Last Updated: 2017-June-5
AIX
Storage Resource Agent
Clustering
File Systems
Volume Managers
AIX 6.1
(64-bit)
-POWER4
-POWER5
-POWER6
-POWER7
-POWER7+
No
See corresponding operating system row above in Server section.
PowerHA for AIX3
-v6.1.x
JFS
JFS2
GPFS 3.3
GPFS 3.4
GPFS 3.5 (TPC 5.2.3+)
GPFS 4.1 (TPC 5.2.3+)
NFS
Veritas File System (VxFS) 4.x, 5.x2
Veritas Volume Manager (VxVM) 4.x, 5.x2
AIX 7.11
(64-bit)
-POWER5
-POWER6
-POWER7
-POWER7+
-POWER8 (TPC 5.2.3+)
Yes 1
AIX VIOS 2.1, 2.2
Yes
AIX VIO Client
Yes 4
AIX Agent Notes:
1 For AIX 7.1, the minimum maintenance levels required are:
  • Technology Level 7100-00 (excluding Service Pack 3)
  • Technology Level 7100-01 Service Pack 2

You can determine the Technology Level and Service Pack installed by running the oslevel -s command. Select any necessary fixes and download packages from Fix Central.

Even with these minimum levels, AIX has a 4K response buffer limitation that may affect the information returned by the fabric probe or zone control job and cause it to fail. It is recommended to use agents on other platforms in addition to the Storage Resource agent on AIX.

2 Support exists for file systems and volumes created through Veritas File System (VxFS) and Veritas Volume Manager (VxVM) release 4.x, 5.x, as long as those file systems and volumes conform to file systems and volumes created with version 3.x of VxFS and VxVM. Volumes and file systems with new features specifically introduced with VxFS and VxVM release 4.x, 5.x cannot be used.

3 APAR IV15087 for PowerHA 6 is required. Refer to the PowerHA for AIX version compatibility matrix for further details regarding PowerHA requirements.

4 The following limitations exist for a Storage Resource Agent installed on the AIX VIO client.:
  • LUN correlation will only work if the virtual device to storage volume relationship is a 1:1 mapping.
  • LUN correlation is only supported for the following storage devices: ESS, DS6000, DS8000, DS4000, DS5000, SVC, Storwize V7000. It is not supported for XIV or non-IBM storage.
  • Data Path Explorer does not work for virtual devices.
HP-UX
Storage Resource Agent
Clustering
File Systems
Volume Managers
HP-UX 11i v3 (B.11.31)
-Itanium 64-bit
Legacy mode only1
Yes
None HP_HFS
NFS
Veritas Files System (VxFS) 4.x, 5.x2
HP-UX Logical Volume Manager
Veritas Volume Manager (VxVM) 4.x and 5.x2
HP-UX Agent Notes:
1 HP-UX hosts must have legacy mode enabled to be used with the Storage Resource Agent. If it is not enabled, the Storage Resource Agent will fail to install. See HP documentation for further details.

2 Support exists for file systems and volumes created through Veritas File System (VxFS) and Veritas Volume Manager (VxVM) release 4.x, 5.x, as long as those file systems and volumes conform to file systems and volumes created with version 3.x of VxFS and VxVM. Volumes and file systems with new features specifically introduced with VxFS and VxVM release 4.x, 5.x cannot be used.
Linux
Storage Resource Agent
Clustering
File Systems
Volume Managers
Red Hat Enterprise Linux Base Server and Advanced Platform 5
No
See corresponding operating system row above in Server section.
None EXT2
EXT3
EXT4
GPFS 4.13 (TPC 5.2.3+)
NFS
TMPFS
Veritas File System (VxFS) 4.x, 5.x2
XFS
LVM2
Veritas Volume Manager (VxVM) 4.x and 5.x2
Red Hat Enterprise Linux Base Server and Advanced Platform 64
-x86, x86-64
-POWER5 (32-bit, 64-bit)
-POWER6 (32-bit, 64-bit)
-POWER7 (32-bit, 64-bit)
-POWER7+ (32-bit, 64-bit)
-POWER8 (32-bit, 64-bit) (TPC 5.2.3+)
-zSeries (31-bit, 64-bit)
Yes 1
Red Hat Enterprise Linux Server 74 (TPC 5.2.6+)
-x86-64
-POWER5 (64-bit)
-POWER6 (64-bit)
-POWER7 (64-bit)
-POWER7+ (64-bit)
-POWER8 (64-bit)
-zSeries (64-bit)
Yes 1
SuSE Linux Enterprise Server 11
-x86, x86-64
-POWER5 (32-bit, 64-bit)
-POWER6 (32-bit, 64-bit)
-POWER7 (32-bit, 64-bit)
-POWER7+ (32-bit, 64-bit)
-POWER8 (32-bit, 64-bit) (TPC 5.2.3+)
-zSeries (31-bit, 64-bit)
Yes 1
None EXT2
EXT3
EXT4
GPFS 4.13 (TPC 5.2.3+)
NFS
REISERFS
TMPFS
Veritas File System (VxFS) 4.x, 5.x2
LVM2
Veritas Volume Manager (VxVM) 4.x and 5.x2
Linux Agent Notes:
1 The Storage Resource Agent will not allow zone configuration changes or report HBA, fabric topology or zoning information for fabrics connected to hosts running Linux on pSeries or zSeries hardware. These limitations also apply to Storage Resource Agents on SLES 11 for x86_64 with Emulex HBAs, all platforms for RHEL 7, and all guest operating systems for VMware configurations.

2 Support exists for file systems and volumes created through Veritas File System (VxFS) and Veritas Volume Manager (VxVM) release 4.x, 5.x, as long as those file systems and volumes conform to file systems and volumes created with version 3.x of VxFS and VxVM. Volumes and file systems with new features specifically introduced with VxFS and VxVM release 4.x, 5.x cannot be used.

3 GPFS is not a supported file system for Storage Resource Agents running on Linux on zSeries.

4 The Storage Resource agent requires the 32-bit compat-libstdc++-33.i686 RPM on Linux.
Solaris
Storage Resource Agent
Clustering
File Systems
Volume Managers
Oracle Solaris 9
(32-bit, 64-bit)
-SPARC
No 1
None NFS
TMPFS
UFS
Veritas File System (VxFS) 4.x, 5.x3
Veritas Volume Manager (VxVM) 4.x and 5.x3
Oracle Solaris 10
(32-bit, 64-bit)
-SPARC
Yes 2, 4
Oracle Solaris 11
(32-bit, 64-bit)
-SPARC
Yes 2, 4
Solaris Agent Notes:
1 Oracle has ended support for Solaris 9 Operating System, therefore Tivoli Storage Productivity Center is removing support for this particular version of Solaris. For more information see this web page: http://www.oracle.com/technetwork/server-storage/solaris10/overview/index-138972.html.

2 For Solaris 10 and Solaris 11, only Global Zone is supported for the Storage Resource agents. The Non-Global (or local) zones are NOT supported.

If you upgrade from Solaris 9 to Solaris 10, all agents need to be reinstalled completely.

3 Support exists for file systems and volumes created through Veritas File System (VxFS) and Veritas Volume Manager (VxVM) release 4.x, 5.x, as long as those file systems and volumes conform to file systems and volumes created with version 3.x of VxFS and VxVM. Volumes and file systems with new features specifically introduced with VxFS and VxVM release 4.x, 5.x cannot be used.

4 Solaris ZFS is not supported for the Storage Resource agents.
VM on Hyper-V
Storage Resource Agent
Clustering
File Systems
Volume Managers
Microsoft Hyper-V

Guest OS:
-Any
No
N/A N/A N/A
VM on KVM
Storage Resource Agent
Clustering
File System
Volume Managers
KVM 2.0
(x86-64)

Guest OS:

Linux

-RedHat Enterprise Linux 63 (TPC 5.2.1+)
-Red Hat Enterprise Linux Server 7 (TPC 5.2.6+)
-SUSE Linux Enterprise Server 11

Windows

-Windows 20083 (TPC 5.2.1+)
-Windows 2008 R23 (TPC 5.2.1+)
-Windows 20123 (TPC 5.2.1+)

Yes 1, 2
See corresponding operating system.
VM on KVM Agent Notes:
1 Fabric functionality is not available with the Storage Resource Agent for any guest operating systems. The Storage Resource Agent will not allow zone configuration changes or report HBA, fabric topology or zoning information for fabrics. Use another supported operating system or agent to collect this information.

2 Total Disk Space and Available Disk Space cannot be determined with the Storage Resource Agents for any guest operating systems.

3 Support for certain guest operating systems requires a minimum version of Tivoli Storage Productivity Center as noted above.
VM on VMware
Storage Resource Agent
Clustering
File Systems
Volume Managers
VMware ESX and ESXi 3.5.x2, 4.0.x, 4.1.x, 5.0.x, 5.1.x, 5.5.x3

Guest OS :

Linux

-RedHat Enterprise Linux 6
-RedHat Enterprise Linux 7
-SuSE Linux Enterprise Server 11

Windows4

-Windows 2008
-Windows 2008 R2
-Windows 2012
-Windows 2012 R2 (TPC 5.2.1+)

Yes 1, 2, 3

See corresponding operating system row for hardware support.
See corresponding operating system.
VM on VMware Agent Notes:
1 Fabric functionality is not available with the Storage Resource Agent for any guest operating systems. The Storage Resource Agent will not allow zone configuration changes or report HBA, fabric topology or zoning information for fabrics. removUse another supported operating system or agent to collect this information.

2 VMware ESX 3.5.x is no longer tested starting withTivoli Storage Productivity Center 5.2.1.

3 VMware ESXi 5.5.x support requires a minimum version of Tivoli Storage Productivity Center 5.2.1.

4 Microsoft has ended support for Windows Server 2003 and Windows Server 2003 R2, therefore Tivoli Storage Productivity Center is removing support for these particular versions of Windows Server.
VMware VI & VSphere
Storage Resource Agent
Clustering
File Systems
Volume Managers
VI 3.5.x, vSphere 4.0.x, 4.1.x, 5.0.x, 5.1.x, 5.5.x
ESX and ESXi 3.5.x, 4.0.x, 4.1.x, 5.0.x, 5.1.x, 5.5.x
Virtual Center 2.5.x
vCenter 4.0.x, 4.1.x, 5.0.x, 5.1.x, 5.5.x
N/A N/A N/A
Windows
Storage Resource Agent
Clustering
File Systems
Volume Managers
Windows 2008
(x86, x86-64)
-Datacenter Edition
-Enterprise Edition
-Standard Edition
Yes
Failover Clustering
MSCS Clustering
FAT
FAT32
NTFS
ReFS
None
Windows 2008 R2
(x86-64)
-Datacenter Edition
-Enterprise Edition
-Standard Edition
Yes
Windows 2012
(x86-64)
-Datacenter Edition
-Standard Edition
Yes
Windows 2012 R2 (TPC 5.2.1+)
(x86-64)
-Datacenter Edition
-Standard Edition
Yes
Windows 7
(x86-64)
-Enterprise Edition
Yes
Windows Agent Notes:
Disks using GUID partition table (GPT) partition style are supported.


Hypervisor monitoring support
Last updated: 2014-March-27
Vendor
Supported Platform
Supported Function
Supported Storage Systems
VMWare ESXi Server 5.53 Monitoring
LUN Correlation
VASA and Web Client extensions2
3PAR
EMC CLARiiON
EMC Symmetrix
HDS 9xxxx
HP EVA
IBM DS4000
IBM DS5000
IBM DS8000
IBM DS6000
IBM ESS
IBM N3000
IBM N5000
IBM N7000
IBM Storwize V7000
IBM Storwize V7000U
IBM SVC
IBM XIV
vCenter 5.53
ESXi Server 5.1
vCenter 5.1
ESXi Server 5.0
vCenter 5.0
ESX Server 4.1
ESXi Server 4.1
vCenter 4.1
ESX Server 4.0
ESXi Server 4.0
vCenter 4.0
ESX Server 3.51, 4
ESXi Server 3.51, 4
VirtualCenter 2.51, 4
Hypervisor Monitoring Notes:
1 ESX/ESXi 3.5 and vCenter 2.5 require a minimum level of U5.

2 VASA and Web Client extension support is available with vCenter 5.1 and later.

3 vCenter 5.5 and ESXi Server 5.5 support require a minimum of Tivoli Storage Productivity Center 5.2.1.

4 VMware ESX 3.5.x and VirtualCenter 2.5.x are no longer tested starting with Tivoli Storage Productivity Center 5.2.1


Multipathing
Last updated: 2015-March-13
Multipathing Product Platform Minimum Version1 Supported Features in TPC
SDDDSM Windows 2.1.3.0-1 for 32-bit machines
2.2.0.0-11 for 64-bit machines
Full support4
SDDPCM AIX 2.2.0.x Full support4
3.0.0.x
download
Full support + Open HyperSwap with TPC for Replication2
AIX Multipath I/O AIX 2.2.0.x Probe
Path Status
3.0.0.x
DM-Multipath Red Hat 6
AIX
device-mapper-1.02.47-1.el6
multipath-tools-0.4.9-19.el6
Full support3
SLES 11 device-mapper-1.02.27-8.6
multipath-tools-0.4.8-40.1
Full support3
EMC Powerpath AIX 4.x Probe
Linux 4.x Probe
Windows 4.x Probe
HP-UX Native Multipath HP-UX 11iV3 Planner
Microsoft Multipath I/O (MPclaim) Windows Any Probe
Path Status
Multipathing Notes:
Full support means Tivoli Storage Productivity Center will be able to:
  • Report on the disks accessed using the multipathing product. (Probe)
  • Display multiple paths in the Data manager asset tree. (Data Manager Asset Tree)
  • Report on the multiple paths in the data path explorer. (Data Path Explorer)
  • Configure paths as part of the SAN Configuration Planner. (Planner)
  • Monitor path status. (Path Status)

1 Additional information regarding version support for SDDDSM, SDDPCM, and DM-Multipath can be found on the System Storage Multipath Subsystem Device Driver support site.

2 The Open HyperSwap functionality for Tivoli Storage Productivity Center for Replication requires a minimum version of R5.1 with DS8700. The 3.0.0 driver is available for download separately from other SDDPCM drivers. The Open HyperSwap solution for Tivoli Productivity Center for Replication will be deprecated in a future release.

3 Path status monitoring with Linux MPIO drivers is available only for Linux x86 and x86-64.

4 IBM SDDDSM and SDDPCM do not support all devices, such as XIV. The Microsoft and AIX MPIO drivers do.


Database Monitoring
Last Updated: 2014-March-27
Database
32-bit
64-bit
DB2 v9.7 Yes1 Yes1
DB2 v10.1 Yes1 Yes1
DB2 v10.5 Yes Yes
MS SQL Server 2008 Yes Yes
MS SQL Server 2008 R2 No Yes
Sybase v15.7 Yes Yes
Oracle 10g Yes Yes
Oracle 11g Yes Yes
Database Monitoring Notes:
Databases installed on clustered servers or clustered database servers (e.g. MSCS, PowerHA for AIX, Oracle Real Application Cluster (RAC) or Veritas clusters) are not supported for monitoring.

Multiple database applications per server are supported as long as the database applications are of different types. Tivoli Storage Productivity Center does not support monitoring two databases of the same type. For example, you can monitor an Oracle database and a DB2 database installed on the same server but cannot monitor two separate DB2 databases on the same server.

Monitoring databases configured with LDAP/AD authentication is only supported for DB2 databases.

1 See note above in Database Repository section for upcoming end of support (EOS) dates.


Web Browsers 1
Last Updated: 2015-August-24
Browsers
All Components 2
Additional for
TPC-R Only
Google Chrome9
34 and higher 7
34 4
36 5
Mozilla Firefox
All ESR versions
17
24
27 3
31 5
Microsoft Internet Explorer
9
10 8
11 6, 8
11
Web Browser Notes:
1 Tivoli Storage Productivity Center support will support newer versions of the browsers as long as the vendors do not remove or disable functionality that Tivoli Storage Productivity Center relies upon. Customer support will accept usage-related and defect-related service requests. As with operating system and virtualization environments, if IBM support cannot recreate the issue in our lab, we may ask the client to recreate the problem on another browser version in order to determine if a product defect exists. Defects will not be accepted for cosmetic differences between browsers or browser versions that do not affect the functional behavior of the product. If a problem is identified in Tivoli Storage Productivity Center, defects will be accepted. If a problem is identified with the browser, IBM may investigate potential solutions or work-arounds that the client may implement until a permanent solution becomes available.

2 Jazz for Service Management and the Tivoli Common Reporting component, including Cognos, are included in the certified listing for All Components. If you'd like to look up the browser support for the included components, such as for Cognos, it is available in the Hardware and Software Requirements section of the Jazz for Service Management Information Center.

3 Tested and certified with Tivoli Storage Productivity Center 5.2.1 and later.

4 Tested and certified with Tivoli Storage Productivity Center 5.2.2 and later.

5 Tested and certified with Tivoli Storage Productivity Center 5.2.3 and later.

6 Tested and certified with Tivoli Storage Productivity Center 5.2.4 and later.

7 Tested and certified with Tivoli Storage Productivity Center 5.2.5 and later.

8 To create and work with Cognos reports using Internet Explorer version 10 or 11, you must turn on Compatibility View in the browser. If Compatibility View is off, you will see error CM-REQ-4158.

9 Data in the resource tables for Servers, Storage, Fabrics or Hypervisors pages will not load in the Chrome web browser when zoomed to levels of 110%, 90%, 67% or 33%. All other zoom levels work properly. This also affects information under Home (Performance Monitors, Alerts, Tasks) and Groups (Applications/Departments).

If your web browser is configured to block pop-up windows, Tivoli Storage Productivity Center might not be able to start the GUIs for some storage systems.

A minimum screen resolution of 1280 x 1024 pixels is recommended on desktop computers for all browser versions.


IBM Tivoli Monitoring Agent for Tivoli Storage Productivity Center
Last Updated: 2017-June-5
AIX HP-UX Linux Solaris Windows
7.1 Not supported RHEL 6
-x86, PPC, zSeries
SLES 11
-x86, x86-64, zSeries
Not supported 7
2008
2008 R2
2012
IBM Tivoli Monitoring Agent for Tivoli Storage Productivity Center Notes:
Before using the IBM Tivoli Monitoring Agent for Tivoli Storage Productivity Center, you must have IBM Tivoli Enterprise Monitoring Server installed. For information about the IBM Tivoli Enterprise Monitoring Server, see the Information Center for 6.3.

Related information

Support Matrix Home - Find Links
5.2.x - Hardware Support

Original publication date

2014/11/14

Cross reference information
Segment Product Component Platform Version Edition
Storage Management Tivoli Storage Productivity Center Select Edition AIX, HP-UX, Linux, Solaris, Windows, z/OS 5.2, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5, 5.2.6, 5.2.7
Storage Management Tivoli Storage Productivity Center Advanced AIX, HP-UX, Linux, Solaris, Windows 5.2, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5, 5.2.6, 5.2.7

Document information

More support for: Tivoli Storage Productivity Center

Software version: 5.2, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5, 5.2.6, 5.2.7

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows, z/OS

Reference #: 7039833

Modified date: 06 June 2017