IBM Support

IBM i2 iBase Release Notes

Release notes


Abstract

IBM i2 iBase is available.

Content

These release notes apply to IBM i2 iBase 8.9.11 and earlier. From IBM i2 Base 8.9.12, the release notes are available from the IBM Knowledge Center. To find a specific version of this document, access the Release Material section of the IBM Knowledge Center, and ensure that you select the correct version at the top of the page.

Description

IBM® i2® iBase is a database for investigations. It provides capabilities to configure a data store, and capture and analyze data, all in a controlled environment. In addition, it integrates fully with IBM i2 Analyst's Notebook®.

iBase 8.9.11 can be installed on its own or as part of IBM i2 Analyst's Workstation 8.9.11.
Important: IBM i2 Intelligence Analysis software at version 8.9 is not compatible with earlier versions of i2 software. Upgrading directly is not supported. To install IBM i2 software at version 8.9, you must first uninstall all of your existing i2 software, then install the new versions.

Release contents

The following chargeable components are compatible and available for use with IBM i2 iBase 8.9.11:

Program Feature Purpose
IBM i2 iBase Designer 8.9.11 Design and administer iBase databases and security files.
IBM i2 iBase Database Replication 8.9.11 Use SQL Server merge replication to enable distributed use of iBase.
IBM i2 iBase Geographic Information Systems Interfaces 8.9.11 Interface with Geographic Information Systems products (excluding Google Earth, which is provided by a plug-in to Analyst's Notebook).
IBM i2 iBase Plate Analysis 8.9.11 Manage and analyze ALPR (Automatic License Plate Recognition) data that is stored in an iBase database
IBM i2 iBase Geographic Information System Interfaces comprises interfaces to the following Geographic Information System products:

GIS product Supported versions
Esri ArcView 3 3.2.3
Esri ArcGIS for Desktop 9.0, 9.1, 9.2, 9.3, 10, 10.1, 10.2.0, 10.2.1, 10.2.2, 10.3.1, 10.4.1*
Northgate Information Solutions blue 8 world 2.4
Northgate Information Solutions blue 8 xd 1.2.9 build 12
Pitney Bowes MapInfo Professional 7.8, 8.0, 8.5, 9.5, 10, 10.5, 11, 11.5, 12, 12.5 (64-bit is not supported)
Microsoft MapPoint 2004, 2006, 2009, 2010, 2011, 2013 European and US Editions

Note: Microsoft discontinued Microsoft MapPoint at the end of 2014, and the maps that are supplied will no longer be updated.

* To use Esri ArcGIS 10.4.1, install iBase 8.9.11 Fix Pack 2. For more information, see the IBM i2 iBase 8.9.11 Fix Pack 2 Readme.
Note: iBase includes the optional Coordinate Extensions feature. The feature uses GEOTRANS v2.4, a product of the National Geospatial Intelligence Agency and U.S. Army Engineering Research and Development Center. Use of GEOTRANS with iBase does not indicate endorsement or approval of iBase by the Secretary of Defense or the National Geospatial Intelligence Agency.

Announcements

The IBM i2 Intelligence Analysis Product Portfolio announcement is available.

  • Detailed product description, including a description of new functionality
  • Product-positioning statement
  • Packaging and ordering details

Any future releases will not be supported on Microsoft Windows Vista.

Note: Microsoft withdraws extended support for Microsoft Server 2003 (all variants) in July 2015. Customers are encouraged to migrate to Microsoft Server 2012 or another suitable environment. Future releases of i2 Intelligence Analysis products will not be supported in this environment.

Release highlights

The following new and updated features are available in iBase 8.9.11:
Esri ArcGIS
iBase can now support Esri ArcGIS versions 10.2.1, 10.2.2, 10.3.1, and 10.4.1.
Microsoft products
SQL Server 2014, Office 2013, and Microsoft MapPoint 2013 are now supported.
Microsoft XML
iBase now uses Microsoft XML version 6.0, rather than 4.0.

Compatible companion products

The following versions of companion products work with iBase 8.9.11: IBM i2 Analyst's Notebook 8.9, IBM i2 iBase IntelliShare 8.9, and IBM i2 Text Chart 8.9.

System requirements

For information about hardware and software compatibility, see the detailed system requirements at http://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProductByComponent?deliverableId= FD3D9A3076F711E4A5D05AF6B8E6E27F.

Installing iBase 8.9.11

iBase Geographic Information Systems Interfaces are installed with iBase 8.9. If you intend to use a mapping application with iBase, then in most cases you must install the mapping application first.
  • Except for blue 8 xd, you must install the mapping application before you install iBase. For example, if you install the Microsoft MapPoint interface before you install the MapPoint application, you will see the "Component not correctly registered" warning after you complete the interface installation.
  • For blue 8 world, you must install the interface while you are logged on as the user who runs the interface. This user must be a local administrator.
Note: To install iBase, you must have administrator privileges.

To install iBase:

  1. Extract the product files from your downloaded distribution.
  2. Using Windows Explorer, browse to the root of the distribution and run setup.exe. The Installation Manager opens.
  3. Click Install in the left menu to start the installation steps.
    Typical Installs iBase User along with its documentation
    Complete Installs:
    • iBase User and iBase Designer
    • All tools apart from the iBase Index Service Configuration tool and iBase Database Replication.
    • All of the documentation, including the Administration Center.
    Custom You can select which parts of iBase you require.
  4. Follow the prompts to complete the installation.

    Note: If you installed the Coordinate Extensions option as part of a custom installation, then iBase might display the following message when you first start it:
    An application plug-in failed to load: i2 iBase Bulk Coordinate Converter.
    This message indicates that a required environment variable does not exist. To resolve this problem, either log off from Windows, or restart the computer.

Additional configuration information for iBase Geographic Information System Interfaces

If you used iBase Geographic Information System Interfaces 2 with MapInfo, ArcView 3, or ArcGIS, your mapping configuration files will be copied to the new Mapping folder when you install iBase GIS Interfaces 8.9.

You might need to modify the configuration file that specifies the background maps and other mapping session features.

Note: You must have the iBase database role Database Administrator to perform the operation. The user "SYSADMIN" in each default security file has this role.
  1. To initialize, open the database in iBase (not in iBase Designer) and select Tools > Initialize Database for Mapping. The necessary additional entries are made to the database to store the mapping configuration information.
  2. To configure an interface, select Format > Mapping > Configurations > New.

iBase Geographic Information System Interfaces installs a default mapping application configuration file as one of i2_default.apr, i2_default.mxd, or i2_default.wor, and then copies it to i2.apr, i2.mxd, or i2.wor. If you need to make any changes, then make them to i2.apr (for example) and not to i2_default.apr.

The configuration files that are used by the application are stored in CSIDL_COMMON_APPDATA\i2\i2 iBase 8\<language>\Mapping.

For more information about CSIDL values, see: https://msdn.microsoft.com/en-us/library/bb762494%28v=VS.85%29.aspx

blue 8 xd

When iBase GIS Interfaces is installed, you need to install the blue 8 xd mapping application. Then, arrange for a consultant from either Northgate Information Solutions or IBM to copy the blue 8 xd interface component to the correct folder for access by iBase GIS Interfaces.

ArcGIS
If you are upgrading to ArcGIS 10, then you need to update the version 9 configuration files by using either i2_default_10.mxd or i2_meters_10.mxd as a template). The files must be updated with any changes that you made to the configuration files for earlier releases of iBase Geographic Information System Interfaces. Then, save the configuration file as i2.mxd.
Note: The default configuration file, i2_default_10.mxd, handles data in any units. The i2_meters_10.mxd configuration file uses meters to handle data.
ArcView 3

The default project file, i2_default.apr, expects the standard sample data to be located in a standard ESRI data location and uses an environment variable to locate it. You do not normally need to take any action if the example map files are loaded at the standard location from the CD. If they are located elsewhere, use the information in the IBM i2 iBase GIS Interfaces Guide to revise the i2.apr file.

MapInfo

To allow MapInfo users who log on as ordinary users rather than as Administrators to plot data, you must give them write access to the file i2.wor.

The default workspace file, i2_default.wor, expects the data to be in degrees. The product also includes i2_meters.wor. You need to copy the file to i2.wor to use it with data in meters.

You must start MapInfo once for each user of the PC before you use iBase GIS Interfaces, because MapInfo initializes only user-specific information. User-specific information includes the custom symbols location the first time a user uses the product.

If you do not follow these steps and then use the iBase GIS Interfaces, you see an error that the application is not responding. MapInfo will then initialize and future operation of iBase GIS Interfaces works normally.

Additional configuration information for iBase Plate Analysis

Information about setting up your installation is available in the IBM i2 iBase Plate Analysis help, which is installed with the product. (See the topic called About Configuring Plate Analysis.) If you are using Plate Analysis with iBase Database Replication, then you need to complete these additional steps:
  1. Configure Plate Analysis at the Publisher as described in the IBM i2 iBase Plate Analysis help.
  2. At each Subscriber, configure Plate Analysis:
    • On the Configure page of the Plate Analysis Task Manager, click Optimize.

Multicultural support

iBase is developed in US English. IBM supports this product in the English language on the following regional versions of the supported operating systems:
Language group/language Language collection Supported values
Arabic Complex script Supported
Armenian Complex script Unsupported
Baltic Basic Supported
Central Europe Basic Supported
Cyrillic Basic Supported
Dhivehi Complex script Unsupported
Galician Basic Unsupported
Georgian Complex script Unsupported
Greek Basic Unsupported
Gujarati Complex script Unsupported
Hebrew Complex script Unsupported
Iridic Complex script Unsupported
Japanese East Asian Supported
Kannada Complex script Unsupported
Korean East Asian Supported
Kyrgyz Basic Unsupported
Mongolian (Cyrillic) Basic Unsupported
Punjabi Complex script Unsupported
Simplified Chinese East Asian Supported
Syriac Complex script Unsupported
Telugu Complex script Unsupported
Thai Complex script Unsupported
Traditional Chinese East Asian Supported
Turkic Basic Supported
Vietnamese Complex script Unsupported
Western Europe and US Basic Supported
Note: You cannot open a non-Unicode iBase database that was created in a different language environment from your own environment's language.
If you are using a regional version of iBase, you must ensure that the Windows account that is used to run the Scheduler service is set up to run using the correct locale information. The following exceptions apply:
  • iBase Database Replication is supported only in English versions of the supported operating systems.
  • iBase GIS Interfaces is supported only on Western Europe and USA, and Japanese regional versions of the supported operating systems.
  • iBase Plate Analysis is supported only on Western Europe and USA versions of the supported operating systems.
  • For Cyber IP DNS Resolution to work, geo-coding data must be stored in a location that does not include Unicode characters in the path name.

Virtualization support

iBase is supported on hardware virtualization environments that run any of the operating systems that are listed in the detailed system requirements. When you run in a virtual environment, any issues that can be replicated by IBM in a supported operating system are addressed by using the standard IBM support policy.

Known problems

At the time of publication, the following problems were known:
Database Explorer display might be affected by changing the display scaling options
Changing the display options to something other than 100% might cause black lines to appear in the Database Explorer window. When you set the display scaling back to 100%, the display returns to normal.
SCC control codes and Case Control
SCC control codes and Case Control cannot contain quotation marks.
Mixed language settings
Mixed language settings between IBM i2 Analyst's Notebook and IBM i2 iBase are not supported.
Additional languages that are supported by IBM i2 Analyst's Notebook are not supported when IBM i2 Analyst's Notebook is used with IBM i2 iBase.
User permissions to run the Search 360 Indexer
To run the Search 360 Indexer, you must have permission to run the CmdExec subsystem. To be able to run the CmdExec subsystem, you must either be an administrator with permission, or you must use a proxy account that references a user (via a credential) with suitable permissions.
You can use the proxy account in SQL Management Studio. You need to be granted access to this Proxy for SQL Login.
You can set up access within the Principals tab of the Proxy dialog in SQL Management Studio, with the following database role:
  • "SQLAgentOperatorRole" database role on the msdb database.
Setting up access allows you to specify the proxy within the Configure Database dialog.
The proxy can then be specified in the Run As field of the Configure Database dialog.
Search 360
There are some limitations on how Search 360 performs in non-English language regions.
  • Western European Script - Exact and spelled-like matching produces successful results. Sounds-like matching returns less useful results; however, the degree of matching must be evaluated by the user to determine whether these results are usable.
  • Central and Eastern European Script - Exact and spelled-like matching produces successful results. Sounds-like matching is unsupported in these language groups.
  • Arabic Script - Exact matching produces successful results. Spelled-like matching returns less useful results; however, the degree of matching must be evaluated by the user to determine whether these results are usable. Sounds-like matching is unsupported for these language groups.
  • East Asian Scripts - Exact matching produces mixed results. The indexing process that is employed by Search 360 is heavily reliant on word boundaries (for example a space). As these scripts do not reflect the same word boundaries as western scripting, the exact matching gives weak or no results. Exact matching works, however, in whole character sequences, for example the equivalent to English sentences.
Full text search
After an iBase repository is converted to Unicode, iBase users might see the following error message when they try to rebuild the Full Text Search index:
File 'sysft_i2Catalog' cannot be reused until after the next 
BACKUP LOG operation.
To solve this problem, run a SQL Server Transaction log back up. After you perform the backup, the Full Text Search index rebuilds.
Indexing unrecognized document types
If a document submitted for indexing is of a type that the indexer does not recognize the index is completed but the unrecognized document is skipped.
Microsoft Office 64-bit compatibility issues
If you are using Microsoft Office, Microsoft recommends that you use 32-bit Office on 64-bit machines for compatibility with other products. If you install 64-bit Microsoft Office, the following actions are prohibited:
  • Import from Microsoft Excel workbooks or Microsoft Access databases
  • Report to Microsoft Access databases
However, the following actions are possible:
  • Export to Microsoft Excel workbooks
  • Report to Microsoft Word documents
On a 64-bit machine without Microsoft Office installed, you can install the 32-bit Microsoft Access Database engine. Installing the 32-bit Microsoft Access Database engine can help you import from Microsoft Excel workbooks and import/report with Microsoft Access databases. You might find the functionality useful for importing on servers.
Note: You cannot install the 32-bit engine if 64-bit Microsoft Office is installed.
Citrix dialog captions (11665)
When you run iBase on Citrix, some dialog captions appear with white boxes or spurious characters between the characters in the title. If you are using tabbed mode in iBase, only the first character is displayed in the tab title.
To fix the problem, set the following registry setting to "1":
HKEY_LOCAL_MACHINE\Software\i2\iBase\8\SystemSettings\CitrixCaption
Note: The captions do not appear in bold as for other dialogs, and do not include the spurious characters.
Focus when you run iBase on Citrix in Seamless Mode (11218)
When you run iBase on Citrix in Seamless Mode, some dialogs display message boxes that take the focus from iBase. iBase cannot regain focus properly, and does not respond to mouse clicks or the keyboard until you click the main title bar.
To fix the problem, set the following registry setting to "1":
HKEY_LOCAL_MACHINE\Software\i2\iBase\8\SystemSettings\CitrixMessageBox
iBase will then respond to a mouse click in the dialog after the message box is closed.
Note: You can use the fix only with Citrix in Seamless mode. With other settings, the registry entry might result in iBase losing focus when the message box is closed, with the result that another application comes to the front.
Custom Icon support
Custom icons are only supported from the custom images location, which is CSIDL_MYDOCUMENTS\i2\i2 Shared\Custom Images.
Here, CSIDL_MYDOCUMENTS is the file system directory that is used to store a user's documents. A typical path is C:\Documents and Settings\username\My Documents.
For more information about CSIDL values, see: http://msdn.microsoft.com/en-us/library/bb762494(v=VS.85).aspx
To add a custom icon:
  1. Copy your image file to the custom images folder, adding copies to both of these locations:
    • CSIDL_MYDOCUMENTS\i2\i2 Shared\Custom Images\Screen\Icons
    • CSIDL_MYDOCUMENTS\i2\i2 Shared\Custom Images\Printer\Icons
  2. Update the configuration file in use with a new line that includes the icon name, a tab-separator, and the file name.
For example:
Title    filename
For more information about custom icon support, see the iBase Designer help.
Alerting

When performing large imports, alerting jobs should be disabled to improve performance. This includes large automated imports including import specifications, batch import specifications, bulk imports, and the use of iBase Scheduler. Alerting jobs should be stopped before the import starts, and started again when the import has completed.

Alerting should also be disabled when backing up your database.

You can control the scheduling of alerting jobs in the Alerting Configuration dialog (in iBase Designer). More advanced scheduling options are available in SQL Server Management Studio. You can also manually disable alerting jobs in the Alerting Configuration dialog by clicking Schedule and turning off the Enable check box.

Warning: Do not click Suspend Alerting, as this will remove your alerting jobs.

Moving an iBase 5 repository requires that you upgrade it
If you move an iBase 5 repository, you will need to open it in iBase 8 Designer in order to associate the security file with the repository file. This action will require you to upgrade the repository.
Dialog Performance with large numbers of Sets and Queries
If your repository has several hundred sets and queries, the following dialogs can experience delays in opening:
  • Export Wizard
  • Report Wizard
  • Batch Edit
  • Batch Delete
  • Export to Excel
  • Browse
  • Field Calculator
  • Assign Icons
  • Duplicate Checker
SQL Server Express
There is no default facility in SQL Server Express edition to manage the scheduling of alerting or Search 360. If you would like to use alerting or Search 360, contact your support representative for more information.
Unicode support
In the Report Wizard, the Standard Report format does not support Unicode characters. If you would like to view reports that contain Unicode characters, you can select the Rich Text Format option.
Bulk Import with blank records
The bulk importer does not import data from files that contain blank rows. To import the data present in these files, delete the blank rows before you resubmit the file.
PDF documents cannot be indexed by iBase in the presence of Adobe Reader X or later.
Due to a limitation with Microsoft Desktop Search, the Adobe PDF iFilter shell extension is not included with Adobe Reader X or later. iBase Search 360 uses this iFilter to extract the contents of PDF documents in the database so that they can be searched. In the presence of Adobe Reader X or later, PDF documents are not searchable in iBase.
Do not upgrade to Adobe Reader X or later on the machine that is used to index your iBase database, because it results in any existing Adobe PDF iFilters being uninstalled. If Adobe Reader X or later is already installed on that machine, contact your supplier for advice.
Cyber IP DNS Resolution limitations
  • Automatically updating records

    The Cyber IP DNS Resolution Configuration Auto-Update options allow you to set the type of information that will be added to records when entering information about cyber entities. This currently only updates records that have been entered manually using iBase or Analyst's Notebook. Records that have been imported, sent from Text Chart, or entered using iBase IntelliShare should be updated using the Cyber IP DNS Resolution Bulk Update.

  • Blacklisting

    When using Cyber DNS Resolution, depending on the size of your blacklist, there may be a delay when first using the spam lookup function.

  • GeoLite City

    Cyber IP DNS Resolution only supports the MaxMind GeoIP City data set directly. If you would like to use the MaxMind GeoLite City data set, you will need to rename GeoLiteCity.dat to GeoIPCity.dat in the place you manage your MaxMind data.

Plate Analysis limitations
  • Case Control

    Plate Analysis cannot be used with case-enabled iBase databases.

  • SQL Server Databases

    Plate Analysis will only work with SQL Server databases.

All Geographic Information System applications
  • Density Grid and Spatial Query tools

    The Density Grid and Spatial Query tools are sensitive to the current map units. That is, if the data is sent to the map in decimal degrees but the map is in meters, then both of these tools will fail.

  • Plotting data from multiple databases
    When plotting to the same mapping application, you may get unexpected results in the following situations:
    • When you plot data from different databases and then use iBase menu commands:
      • For Show and Add to Set, the wrong database might be presented, and consequently no data is displayed or saved in a set.
      • For Add to Chart and Expand, only data from one database can be displayed on the chart.
    • When you plot data from databases with the same name:
      • When the databases have the same structures but different data, incorrect information is retrieved for records mapped from a database that is not currently open. Alternatively, the user may be informed that the record has been deleted from the database.
      • When the databases have different structures and data, the user will see a permissions error message if an entity or link type with the same three-letter identifier does not exist in the open database. If the three-letter record identifier does exist, then a record for the incorrect entity or link type might be displayed. Alternatively, if there is no record with that record number, the user might be informed that the record has been deleted.
      • Running a query to find all entities or links in the vicinity of an entity or link on the map might return records on an unrelated area of the map.
      • Deleting an entity or a link through the Show dialog deletes it from the currently open database, which might not be the same database from which it was mapped.
      • To prevent this unexpected behavior, only map from iBase databases with unique names.
ArcGIS Interface Blank menu
Following an upgrade from iBase 5, users of the iBase ArcGIS Interfaces might find a blank menu that is labeled iBase 5. The options that were available under this menu are now found in the File menu, and the menu can be removed by updating the i2.mxd file.
ArcGIS 10.2 to 10.4
If the ArcGIS application is not already open when you send items to be plotted on a map from iBase, the items might not be visible. Therefore, ensure that ArcGIS is already open before you send items from iBase.
blue 8 xd
blue 8 xd does not support the Select on Map command if you make multiple selections.
MapInfo
The main toolbar must be set up as a floating toolbar.
Microsoft MapPoint
  • Microsoft MapPoint 2009 restricts the range of symbols and colors available. For example, regardless of the symbol you select in the configuration file, all symbols are plotted as pins. Red, green, and blue are plotted as expected, black is plotted as blue, and all other colors are plotted as red. This restriction was removed in Microsoft MapPoint 2010.
  • All versions of Microsoft MapPoint:
    • Microsoft MapPoint has European and US Editions. If you have both installed, data is sent to the most recently opened version.
    • When you send data to Microsoft MapPoint, the Adding Labels dialog indicates that you can press Escape to cancel the process. Pressing Escape does not cancel the process.

More information

For more information, see the following resources:


Document information

More support for: i2 iBase

Software version: 8.9.11

Operating system(s): Windows

Reference #: 7038010

Modified date: 21 June 2018