IBM Support

Security Bulletin: IBM Maximo Asset Management installs with a default administrator account that a remote intruder could use to gain administrator access to the system.(CVE-2018-1524)

Security Bulletin


Summary

IBM Maximo Asset Management installs with a default administrator account that a remote intruder could use to gain administrator access to the system. This vulnerability is due to an incomplete fix for CVE-2015-4966.

Vulnerability Details

CVEID: CVE-2018-1524
DESCRIPTION: IBM Maximo Asset Management installs with a default administrator account that a remote intruder could use to gain administrator access to the system. This vulnerability is due to an incomplete fix for CVE-2015-4966.
CVSS Base Score: 8.8
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/142116 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

This vulnerability affects the following versions of the IBM Maximo Asset Management core product, and all other IBM Maximo Industry Solution and IBM Control Desk products, regardless of their own version, if they are currently installed on top of an affected IBM Maximo Asset Management. *


Maximo Asset Management core product affected versions:
Maximo Asset Management 7.6

Industry Solutions products affected if using an affected core version:
Maximo for Aviation
Maximo for Government
Maximo for Life Sciences
Maximo for Nuclear Power
Maximo for Oil and Gas
Maximo for Transportation
Maximo for Utilities

IBM Control Desk products affected if using an affected core version:
SmartCloud Control Desk
IBM Control Desk
Tivoli Integration Composer

* To determine the core product version, log in and view System Information. The core product version is the "Tivoli's process automation engine" version. Please consult the Product Coexistence Matrix for a list of supported product combinations.

Remediation/Fixes

The recommended solution is to download the appropriate Interim Fix or Fix Pack from Fix Central (What is Fix Central?) and apply for each affected product as soon as possible. Please see below for information on the fixes available for each product, version, and release. Follow the installation instructions in the ‘readme’ documentation provided with each fix pack or interim fix.

For Maximo Asset Management 7.6:

VRM Fix Pack, Feature Pack, or Interim Fix Download
7.6.1.0 Maximo Asset Management 7.6.1.0 Fix Pack:
7.6.1.0-TIV-MAMKCNL-FP0001 or latest Interim Fix available
FixCentral

Workarounds and Mitigations

Additional Configuration for Existing Installations

Additional configuration is necessary for full protection on existing installations, even after application of Fix Pack or Interim Fix. Application of the Fix Pack or Interim Fix will allow simplified configuration of this security setting via a new property, mxe.int.allowdefaultlogin. On new installations, this property will already exist, and have the secure value of 0. However, administrators on existing installations must manually add the property and set the secure value after the application of the Fix Pack or Interim Fix. Manually adding the new property via these instructions without applying a Fix Pack or Interim Fix is also not sufficient for protection.

To manually add the mxe.int.allowdefaultlogin property to an existing installation after applying the appropriate Fix Pack or Interim Fix, please complete the following steps:

1. Log in as a user with access to the System Properties application.

2. From the System Properties application, click New Row to add a row to the Global Properties Table.

3. Use the following values to populate the new row. Leave other fields with their default values.

  • Property Name: mxe.int.allowdefaultlogin 
    Description: Allow default login for MIF 
    Global Value: 0 
    Maximo Default: 0


4. Click Save. Then, check the checkbox for the row in the table containing the new property, and click Live Refresh. Click OK on the Live Refresh dialog.

 

Installation of the Fix Pack or Interim Fix above is the recommended remediation for this vulnerability for both new and existing installations. Application of the Fix Pack or Interim Fix will allow simplified configuration of this security setting via a new property, mxe.int.allowdefaultlogin.

However, new and existing installations with version levels earlier than the Fix Pack and Interim Fix levels specified above may manually apply an alternative fix. This alternative fix provides the same protection as application of the Fix Pack or Interim Fix, but will not allow simplified configuration of the security setting via the new property. If the fix in the Remediation/Fixes section has been applied and the mxe.int.allowdefaultlogin property is in use, the following manual configuration will have no effect.

To apply protection for this vulnerability without applying a Fix Pack or Interim Fix, please complete the following steps:

1. Navigate to the following file location: <maximo_root>\applications\maximo\mboejb\ejbmodule\META-INF

2. Open the ejb-jar.xml file.

3. Find all four instances of the following text. (You may Ctrl+F find "<env-entry-name>ALLOWDFLTLOGIN</env-entry-name>".)

    • <env-entry>
  • <env-entry-name>ALLOWDFLTLOGIN</env-entry-name> 
    <env-entry-type>java.lang.String</env-entry-type> 
    <env-entry-value>1</env-entry-value>
    • </env-entry>


4. In all four text blocks, change the <env-entry-value> from 1 to 0: <env-entry-value>0</env-entry-value> 

5. Save the document. Delete the Maximo ear files, delete browser and app server caches, rebuild the maximo ear files, and redeploy.

 

Previous Bulletin Link CVE-2015-4966 

Get Notified about Future Security Bulletins

Reference

Complete CVSS v3 Guide
On-line Calculator v3

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Change History

30 July 2018: Original version published

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.


Cross reference information
Product Component Platform Version Edition
Control Desk 7.6.0, 7.6.0.1
Maximo for Life Sciences 7.6
Maximo for Nuclear Power 7.6.0
Maximo for Oil and Gas 7.6.0
Maximo for Transportation 7.6.1, 7.6.2, 7.6.2.1, 7.6.2.2, 7.6.2.3, 7.6.2.4
Maximo for Utilities 7.6
IBM Maximo for Aviation 7.6, 7.6.1, 7.6.2, 7.6.2.1, 7.6.3

Document information

More support for: Maximo Asset Management

Component: --, ">More...

Software version: 7.6, 7.6.0, 7.6.0.1, 7.6.1, 7.6.2, 7.6.2.1, 7.6.2.2, 7.6.2.3, 7.6.2.4, 7.6.3

Operating system(s): Platform Independent

Reference #: 2017452

Modified date: 31 July 2018


Translate this page: