IBM Support

Hardware and Software Requirements: Data Protection for VMware V8.1.6

Preventive Service Planning


Abstract

This document details the hardware and software requirements for IBM® Spectrum Protect™ for Virtual Environments: Data Protection for VMware V8.1.6.

Content

The Data Protection for VMware requirements vary by high level functional component. Data Protection for VMware has the following high level functional components:

- Data Protection for VMware vSphere GUI
- Data mover
- Mount proxy
- Recovery agent

Note: All Data Protection for VMware functional components must be at the same fix pack level. Within a given fix pack level, the interim fix level can differ.
Examples:
- When upgrading the Data Protection for VMware vSphere GUI, all other functional components (data movers, recovery agents, and mount proxy nodes) must be also upgraded to the same fix pack level.
- When upgrading a data mover from 8.1.6.x to 8.1.6.y (where x<y), it is not required that all other functional components be upgraded to 8.1.6.y (but they all must be at the same fix pack level).
 

This document is divided into linked sections for ease of navigation. You may use the links to jump to the section of the document that you want.

Software requirements for Data Protection for VMware
- Supported VMware vSphere versions
- Data Protection for VMware vSphere GUI
- Data mover
- Mount proxy
- Recovery agent
- Operating systems support overview table
Additional software requirements
Support and limitations
Hardware requirements for Data Protection for VMware
Where to download IBM Spectrum Protect for Virtual Environments 8.1.6
Hardware and Software requirements for other releases of Data Protection for VMware

 


Software requirements for Data Protection for VMware

Supported VMware vSphere versions

The following VMware vSphere versions are supported:
- vSphere 6.0 and 6.0 update and patch levels (See "Important considerations for vSphere 6.0" below).
- vSphere 6.5 and 6.5 update and patch levels
- vSphere 6.7 and 6.7 update and patch levels (See "Important considerations for vSphere 6.7" below).

  • Important considerations for vSphere 6.0:
    To use VMware tagging for backup management, vCenter 6.0 update 1 or later update or patch levels are required.

  •  Important considerations for vSphere 6.7:
    If Data Protection plug-in is auto-turned off because of vSphere 6.7, follow the steps in the VMware KB article about it and how to revert the process: https://kb.vmware.com/s/article/54751

To view supported vSphere and ESXi host versions by VDDK version, check the release notes of VMware's Virtual Disk Development Kit.
In the following technote: "Tivoli Storage Manager for Virtual Environments: Data Protection for VMware Data Mover compatibility guide with VMware's Virtual Disk Development Kit" are listed all the releases notes of the used VDDK versions.

Attention: The support statements listed in this Hardware and Software Requirements Data Protection for VMware 8.1.6 technote supersede the supported vSphere versions listed in VDDK release notes. Use the this Hardware and Software Requirements technote as the definitive guide when determining hardware and software requirements for Data Protection for VMware 8.1.6.
 

Data Protection for VMware vSphere GUI

This functional component integrates the product with the VMware vSphere client in order to back up, restore, and manage virtual machines in the VMware vCenter and includes the Data Protection for VMware command-line interface.

Notes:
- To enable file restore capability, the Data Protection for VMware vSphere GUI must be installed on a Windows system.
- To enable file restore for a Linux® virtual machine, in addition to installing Data Protection for VMware on a Windows system, a Linux mount proxy system must also be configured.

Note: For the Data Protection for VMware vSphere GUI to function correctly with tagging support, ensure that at least one data mover is installed on the same system as the Data Protection for VMware vSphere GUI.

Attention: Connection to the vCenter Server is required to install the Data Protection for VMware vSphere GUI. If your vCenter Server uses an RSA key with an encryption length greater than 2048 bits, then before installing the Data Protection for VMware vSphere GUI, you must download and install the unrestricted JCE policy files. The instructions are in the technote Installing the Data Protection for VMware vSphere GUI: Download unrestricted SDK JCE files. You do not need to install these files if your RSA key encryption length is 2048 bits or less.

The supported operating systems by platform are listed in Operating systems support overview tables.
 

Data mover

The data mover enables:
- Off-host block level incremental backups
- Application protection for VM guests

The VMware Virtual Disk Development Kit (VDDK) version 6.7EP1 runtime files are used for backing up virtual machines by the data mover. The data mover supports the operating systems listed in section Operating systems support overview tables, as long as they are also supported by the VDDK version 6.7.0EP1. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.7EP1, see the VDDK release notes web page.

The data mover utilizes the VDDK APIs to open, close, read, and write virtual machine disk (VMDK) data. To determine the level of VDDK used in each level of Data Protection for VMware, as well as compatible ESX/ESXi builds supported by the VDDK level, please refer to the technote: "IBM Spectrum Protect™ for Virtual Environments: Data Protection for VMware data mover compatibility guide with VMware's Virtual Disk Development Kit"

For details about the supported applications and required licensed software programs to perform database or mailbox level restore operations with application protection for VM guests, see Support and limitations.

The supported operating systems by platform are listed in Operating systems support overview tables.
 

Mount proxy

A mount proxy represents the Linux or Windows system that provides access to virtual machine disks backup or persistent snapshots. Mount proxy systems are required when using the Data Protection for VMware vSphere GUI Mount wizard and when using the file restore portal.

When accessing a Windows virtual machine, a Windows mount proxy system is required. When accessing a Linux virtual machine, a Windows and Linux mount proxy pair is required.

For a Linux or Windows mount proxy system, IBM Spectrum Protect data mover Version 8.1.6 must be installed and configured. During installation select the following option from the installer:
- For a Linux mount proxy system: Custom \ Data Protection for VMware data mover
- For a Windows mount proxy system: Advanced Installation \ Install the data mover features only

Requirements for operations:

  • For file restore operations from persisted snapshots on the local hardware storage (local backups) on VMware Virtual Volumes VDDK is required on the mount proxy system and will be installed by default when choosing the install data mover option.

  • For mount or file restore operations from server backups iSCSI connection is required on the mount proxy system. For a Windows mount proxy system, IBM Spectrum Protect for Virtual Environments recovery agent Version 8.1.6 must be additional installed and configured.
    Note:
    -For a windows mount proxy, the iSCSI Initiator service must be running during the virtual machine disk mount operation and the file restore operation. By default, the iSCSI service is started manually. If the system where this service is running restarts, the iSCSI service must be restarted manually.
    -For a Linux mount proxy, the iSCSI service must be configured and running during the VMDK mount operation and the file restore operation. By default, the iSCSI service is started manually. If the system where this service is running restarts, the iSCSI service must be restarted manually.

The supported operating systems by platform are listed in Operating systems support overview tables.
 

Recovery agent

This service enables the mounting of any snapshot volume from the IBM Spectrum Protect server. You can use iSCSI protocol to access the snapshot from a remote computer.
Note: To view the snapshot locally with read-only access on the client system, to use IBM® Spectrum Protect™ for Virtual Environments: Data Protection for VMware V8.1.4 or earlier versions.

In addition, the recovery agent provides the instant restore function. A volume used in instant restore processing remains available while the restore process proceeds in the background.

The recovery agent is accessed with the recovery agent GUI or command-line interface.

The supported operating systems by platform are listed in Operating systems support overview tables.
 

Operating systems support overview tables

Operating systems support tables for all 8.1.6 Data Protection for VMware functional components:

Table 1: Operating system support on Linux x86_x64
Operating Systems
Data Mover & Mount Proxy*
GUI *
Recovery Agent
Red Hat Enterprise Linux (RHEL) 6 (E2)(SL1)(1)(3) (E1)
Red Hat Enterprise Linux (RHEL) 7 (E2)(SL2)(1)(3) (E1)
SUSE Enterprise Linux (SLES ) 11 (E3)(SL3)(2)(3) (E1)
SUSE Enterprise Linux (SLES ) 12 (E3)(SL4)(2)(3) (E1)

Notes:
* The operating systems listed in the functional component columns, are supported as long as they are also supported by the VDDK v6.7.0EP1. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.7.0EP1 see the VDDK release notes web page.
(1) To perform backups or restores of VMware virtual machines the libfuse.so2, libxml2.so, and libexpat.so, shared object libraries must be installed on Red Hat Enterprise Linux system. Install fuse-libs version 2 package. Some distributions may not have these installed.
(2) To perform backups or restores of VMware virtual machines the libfuse.so.2 shared object library must be installed on a SUSE Linux system. Install the libfuse version 2 package. Some distributions may not have these installed.
(3) In order to configure a data mover node smoothly, the environment should have:
      1.  A system wide JRE installed on the data mover host.
      2. The system wide PATH environment variable include the installed system wide JRE java path.
      see also https://www.ibm.com/support/knowledgecenter/SSERB6_8.1.6/ve.inst/t_ve_cfg_setdmnodes.html
     Note: The Java GUI and Data Mover requires Java: JRE 8

Editions & Support levels:
(E1) Server Edition only
(E2) Client and Server Editions
(E3) Desktop and Server Editions

(SL1) RHEL 6.7 and later maintenance levels and mod levels
(SL2) RHEL 7.2 and later maintenance levels and mod levels
(SL3) SLES 11SP4 and later maintenance levels and mod levels
(SL4)  SLES 12SP1 and later maintenance levels and mod levels

Indicates that the operating system version is not supported by this Data Protection for VMware functional component.
Indicates that the operating system version is supported by this Data Protection for VMware functional component.
       Later maintenance and modification levels to the operating system version are also supported.
 

Table 2: Operating system support on Windows x64
Operating Systems
Data Mover & Mount Proxy*
GUI *
Recovery Agent *
Windows Server 2012 (E4)    (E4)(1)    (E4)(1)
Windows Server 2012 R2 (E4) (E4) (E4)
Windows Server 2016** (E4) (E4) (E4)

Notes:
* The operating systems listed in the functional component columns, are supported as long as they are also supported by the VDDK v6.7.0EP1. For updates on supported operating systems and known issues and limitations regarding the VDDK 6.7.0EP1 see the VDDK release notes web page.
** only Long-Term Servicing Channel (LTSC) product's are supported
(1) This functional component provides support for Windows Storage Server 2012 for functionality that is also available and supported by this functional component on the Windows Server 2012 Editions.

Editions:
(E4) Essentials, Standard, and Datacenter Editions

Indicates that the operating system version is not supported by this Data Protection for VMware functional component.
Indicates that the operating system version is supported by this Data Protection for VMware functional component.
       Later maintenance and modification levels to the operating system version are also supported.


Additional software requirements

The following additional software is required to use Data Protection for VMware:

  • Tivoli Storage Manager (TSM) Server 7.1 and later interim fixes and fix packs

  • IBM Spectrum Protect Server 8.1 and later interim fixes and fix packs

Tip: TSM Client/API and Server compatibility information is located in the IBM Tivoli Storage Manager Server/Client Compatibility and Upgrade Considerations technote.
 


Support and limitations

Data Protection for VMware components support the following applications:

  • The following browsers are supported with Data Protection for VMware
    - Microsoft Internet Explorer version 11 on Windows
    - Google Chrome 50 or later on Windows and Linux
    - Mozilla Firefox 45 Extended Service Release or later on Windows and Linux

  • Application protection for VM guests

    Application protection supports the following 64-bit applications on the Windows x64 platform for granular restore:
    - Microsoft Exchange Server
    - Microsoft SQL Server

    Application protection backup is supported on the data mover for the following operating systems: See platforms listed for data mover in Operating systems support overview tables.
    Note: The data mover, which enables application protection backups, is only supported on Windows with 64-bit guest operating systems.

    Application protection requires beside Data Protection for Virtual Environment Recovery Agent and Data Mover at least one of the following separately licensed software programs in order to perform individual database or mailbox level restore operations:
    - For Microsoft Exchange Server: IBM Spectrum Protect for Mail
    - For Microsoft SQL Server: IBM Spectrum Protect for Database

    For more information see in Application Protection Requirements: Data Protection for VMware technote.

Data Protection for VMware limitation:

  • During installation the /tmp directory should have more than 2GB free space and should not be mounted with the option "noexec"
     


Hardware requirements for Data Protection for VMware

Hardware requirements vary and depend on the following items:
- Number of protected servers
- Number of protected volumes
- Data set sizes
- LAN and SAN connectivity

The following table describe the hardware requirements that are needed to install Data Protection for VMware.

Component Minimal requirement Preferred
System Intel Pentium D dual core Intel Pentium D eight core
Memory 4 GB RAM, 4 GB virtual address space 8 GB RAM, 8 GB virtual address space
Available hard disk 4.4 GB 9.0 GB
Network 1 GbE 10 GbE

For more information about data mover hardware specification see also technote 2007197
For any hardware limitations see also under section Support and limitations
 


Where to download IBM Spectrum Protect for Virtual Environments 8.1.6

The IBM Spectrum Protect for Virtual Environments download document provides information about how and where to obtain the IBM Spectrum Protect for Virtual Environments 8.1.6 package. The information is located at Download Information: Version 8.1.6 IBM Spectrum Protect™ for Virtual Environments technote
 


Hardware and Software requirements for other releases of Data Protection for VMware

The hardware and software requirements for other releases and fix packs for all IBM Spectrum Protect Data Protection for Virtual Environment components are located in the "IBM Spectrum Protect for Virtual Environments - All Requirements Doc"

 

Related information

IBM Spectrum Protect for Virtual Environments - All Requirements
Featured documents for IBM Spectrum Protect for VMware

Document information

More support for: IBM Spectrum Protect for Virtual Environments

Component: Data Protection for VMware

Software version: 8.1.6

Operating system(s): Linux, Windows

Reference #: 2017125

Modified date: 20 September 2018