IBM Support

DB2 backup/archive using TSM fails after Spectrum Protect Client upgrade

Troubleshooting


Problem

After the Spectrum Protect client and API are upgraded to version 7.1.8+ or version 8.1.2+, the DB2 backup or log archive fails.

Symptom

The db2diag.log shows the following errors :

2018-05-07-12.43.11.977084-420 E441221A866 LEVEL: Error
PID : 12582934 TID : 9511 PROC : db2sysc 0
INSTANCE: inst1 NODE : 000
EDUID : 9511 EDUNAME: db2logmgr (PITIN00I) 0
FUNCTION: DB2 UDB, data protection services, sqlpInitVendorDevice, probe:1030
MESSAGE : ZRC=0x86100025=-2045771739=SQLP_MEDIA_VENDOR_DEV_ERR
"A vendor device reported a media error."
DATA #1 : String, 29 bytes
Init failed! Vendor rc info:
DATA #2 : Vendor RC, PD_DB2_TYPE_VENDOR_RC, 4 bytes
Vendor RC=0x0000000B=11 -- see DB2 API Guide for meaning.
DATA #3 : Hexdump, 48 bytes
0x07000000637D6B90 : FFFF FE96 3330 3520 2D33 3632 0000 0000 ....305 -362....
0x07000000637D6BA0 : 0000 0000 0000 0000 0000 0000 0000 0000 ................
0x07000000637D6BB0 : 0000 0000 0000 0000 0000 0000 0000 0000 ................

2018-05-07-12.43.11.977271-420 I442088A429 LEVEL: Error
PID : 12582934 TID : 9511 PROC : db2sysc 0
INSTANCE: inst1 NODE : 000
EDUID : 9511 EDUNAME: db2logmgr (PITIN00I) 0
FUNCTION: DB2 UDB, data protection services, sqlpgArchiveLogVendor, probe:1820
RETCODE : ZRC=0x86100025=-2045771739=SQLP_MEDIA_VENDOR_DEV_ERR
"A vendor device reported a media error."


The Spectrum Protect server activity log shows:

ANS1579E GSKit function gsk_attribute_set_enum GSK_SSL_EXTN_EXTENDEDMASTERSECRET_CLIENT_ENABLE true failed with 701: GSK_ATTRIBUTE_INVALID_ID
05/07/18 08:56:07 ANS9020E A session could not be established with a TSM server or client agent. The return code is -362.

Cause

Starting with the Spectrum Protect Server and Backup-Archive Backup-Archive client version 7.18 and 8.1.2 and above, new security features require a GSKit version 8.0.50.78 and above. For older version of DB2, the bundled GSKit version is at a lower level which can cause the backup to fail.

Resolving The Problem

Upgrade DB2 which includes the GSKit version 8.0.50.78. For example : DB2 V10.5 FP9 or DB2 V11.1 FP3. If DB2 cannot be upgraded, after installling the GSKit version 8.0.50.78 separately, use the instructions at the following document to create symbolic links to use the higher version of GSkit for client operation:
https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.8/client/t_cfg_ssl_symb_lnk_gskit.html

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg22016297