IBM Support

Attempting to run a report on a BROS server results in Maximo login page appearing

Troubleshooting


Problem

Attempts to run a report using IBM maximo Asset management with a BROS server result in a Maximo login page appear, but even after logging in you get no report

Symptom

The mxe.report.birt.viewerurl property value is set to your BROS server.

Cause

This issue will occur when the mxe.report.birt.viewerurl property value ends in "/maximo"

Diagnosing The Problem

Check the value of the mxe.report.birt.viewerurl property.

Resolving The Problem

The value for this property can end after the host/port or it can end in "/maximo/report. The following are valid values for mxe.report.birt.viewerurl:

mybros.mydomain.com:9080
mybros.mydomain.com:9080/maximo/report

The following is invalid and will cause you to only receive the login page
mybros.mydomain.com:9080/maximo

(Note the server can be an IP address as well.)

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"BIRT","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg22014661