IBM Support

Localization/initialisation error seen when IBM Daeja ViewONE Virtual starts

Troubleshooting


Problem

When trying to view an image with the IBM Daeja ViewONE Virtual viewer in IBM Content Navigator a 'localization' error appears on the browser window. The viewer would fail to come up.

Symptom

Besides the 'localization' error seen on the console you may see these errors in the virtual.log:

ji.server.util.v: Server initialisation error

Unable to remove all files from
/opt/IBM/ECMClient/config/cache/vXKhbEcaJqxMn2NAzjzg18pWpARN2HwZHsrQ5XJi
Ho.navigator. Please ensure that the location specified by the 'cacheRoot' parameter is exclusively used by a single streamer.

Cause

The IBM/ECMClient/config/cache/ directory and its contents need to have RW permission for the account that runs the ICN instance, e.g. wasadmin. If someone starts the JVM using other accounts (e.g. root) the permissions may change.

Diagnosing The Problem

Check the permissions for all sub-directories and files under IBM/ECMClient/config/cache.

Resolving The Problem

Use the chown and/or chmod command to correct the permissions if necessary.

[{"Product":{"code":"SSTTN8","label":"IBM Daeja ViewONE Virtual"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Daeja ViewONE Virtual","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"5.0.1;5.0;4.1.5.1;4.1.5;4.1.4;4.1.3;4.1.2;4.1.1;4.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
28 January 2021

UID

swg22007145