IBM Support

Application Protection Requirements: Data Protection for VMware

Preventive Service Planning


Abstract

This document details the application protection supports for 64-bit applications for the Windows x64 platform inside VM guests in a VMware environment. The purpose of this technote is to describe component compatibility and list all possible combinations for backup and restore operations.

Content

Application protection provide a functionality to quiesce applications running inside VM guests. That is, the client freezes and thaws the VSS writers and, optionally, truncates the application logs. If a virtual machine is not protected by IBM Spectrum Protect application protection functionality, application protection is provided by VMware, and VMware freezes and thaws the VSS writers, but application logs are not truncated. Application logs truncation is a part of a sustainable backup strategy.

  • Prior to Data Protection for VMware 8.1.0.2, restore of applications had to be performed using the same or newer version of Data Protection for Mail/Databases than the version of the Data Protection for VMware used during the VM backup.

  • Beginning with Data Protection for VMware 8.1.0.2, it is possible to back up a VM containing application with a newer Data Protection for VMware version and restore with an earlier version of Data Protection for Mail/Databases.
     

This document is divided into linked sections for ease of navigation. You may use the links to jump to the section of the document that you want.

Software requirements
Applications supported by application protection
 

Detailed information about recovery from virtual machine snapshots is available at the following websites:


Software requirements

Application protection backup software requirements:

Application protection backup is enabled by following component:

  • IBM Spectrum Protect for Virtual Environments Data Protection for VMware Data Mover.
    The Data Mover supported operating systems are listed in Hardware and software requirements technotes. Those are listed in the " IBM Spectrum Protect for Virtual Environments - All Requirements Doc "

    Note:

    • Data mover is only supported on Windows with 64-bit guest operating systems.

    • Data Mover runs on a proxy machine.

To backup an application running on a VM guest:

  • The VM guest OS should be supported by injected VSS requester code which is part of the BA client.
    Note: the injected VSS requester code for creating VSS snapshots and truncating logs supports SQL 2008 and later as well as Exchange Server 2010 and later.

  • The Backup- Archive client supported operating systems are listed in Microsoft Windows Client Requirements technotes.
     

Application protection restore software requirements:

Application protection restore is enabled by following components of IBM Spectrum Protect for Virtual Environments Data Protection for VMware installed in the guest VM machine for database level restore:

  • Recovery Agent

  • Data Mover
    Note: Data Mover is used as Backup-Archive Client in this conjunction

Application protection requires at least one of the following separately licensed software programs in order to perform individual database or mailbox level restore operations:

  • For Microsoft Exchange Server:  IBM Spectrum Protect for Mail 7.1.x or 8.1.x

  • For Microsoft SQL Server: IBM Spectrum Protect for Databases 7.1.x or 8.1.x
     


Applications supported by application protection


Applications on VM guests supported by application protection backup
 

Table 1. Coverage matrix for applications on VM guests backed up with Data Protection for VMware Data Mover
Application (64-bit) Data Protection for VMware Data Mover 7.1.x Data Protection for VMware Data Mover 8.1.x
SQL 2008 (3)
SQL 2008 R2 (3)
SQL 2012
SQL 2014 (1)
SQL 2016
SQL 2017 (4)
Exchange 2010
Exchange 2013
Exchange 2016 (2)
Exchange 2019 (5)

Indicates that the application version is not supported by application protection.
Indicates that the application version is supported by application protection. Later maintenance and modification levels to the operating system version are also supported.

Notes:
(1) Version 7.1.3 and later
(2) Version 7.1.6 and later
(3) Version 8.1.0.2 and later
(4) Version 8.1.4 and later
(5) Version 8.1.7 and later
 


Applications on VM guests supported by application protection restore
 

Table 2. Coverage matrix for applications restored
with Data Protection for Microsoft SQL Server 7.1.x / Data Protection for Microsoft Exchange Server 7.1.x
and Data Protection for VMware (Data Mover and Recovery Agent) 7.1.x
Application (64-bit) Win 2008 R2 Win 2012 Win 2012 R2
SQL 2008 (E1) (E1) (E1)
SQL 2008 R2 (E1) (E1) (E1)
SQL 2012 (E1) (E1) (E1)
SQL 2014 (E1)(1) (E1) (E1)
SQL 2016 (E1)(2)
Exchange 2010 (E2) (E2)
Exchange 2013 (E2) (E2) (E2)
Exchange 2016 (E2)3 (E2)(3)

Indicates that the application version is not supported by application protection.
Indicates that the application version is supported by application protection. Later maintenance and modification levels to the operating system version are also supported.

Editions:
(E1) Standard or Enterprise Editions
(E2) Standard. Business Intelligence, or Enterprise Editions

Notes:
(1) beginning with Data Protection for Microsoft SQL Server 7.1.3
(2) beginning with Data Protection for Microsoft SQL Server 7.1.6.1
(3) beginning with Data Protection for Microsoft Exchange Server 7.1.4.2

Table 3. Coverage matrix for applications which are restored
with Data Protection for Microsoft SQL Server 8.1.x / Data Protection for Microsoft Exchange Server 8.1.x
and Data Protection for VMware (Data Mover and Recovery Agent) 8.1.x
Application (64-bit) Win 2012 Win 2012 R2 Win 2016 Win 2019
SQL 2008
SQL 2008 R2
SQL 2012
SQL 2014 (E1) (E1)
SQL 2016 (E1) (E1)
SQL 2017 (E1) (E1)(1)
Exchange 2010
Exchange 2013 (E2) (E2)
Exchange 2016 (E2) (E2) (E2)
(2)

Indicates that the application version is not supported by application protection.
Indicates that the application version is supported by application protection. Later maintenance and modification levels to the operating system version are also supported.

Editions:
(E1) Standard or Enterprise Editions
(E2) Standard. Business Intelligence, or Enterprise Editions

Notes:
(1) Data Protection for Microsoft SQL Server 8.1.4 and later and Data Protection for VMware (Data Mover and Recovery Agent) 8.1.4 and later
(2) Data Protection for Microsoft Exchange Server 8.1.7 and later and Data Protection for VMware (Data Mover and Recovery Agent) 8.1.7 and later
 

Table 4. Coverage matrix for applications which are restored
with Data Protection for Microsoft SQL Server 7.1.x / Data Protection for Microsoft Exchange Server 7.1.x
and Data Protection for VMware (Data Mover and Recovery Agent) 8.1.x (beginning with 8.1.0.2)
Application (64-bit) Win 2012 Win 2012 R2
SQL 2008 (E1) (E1)
SQL 2008 R2 (E1) (E1)
SQL 2012 (E1) (E1)
SQL 2014 (E1) (E1)
SQL 2016 (E1)(1)
Exchange 2010 (E2)
Exchange 2013 (E2) (E2)
Exchange 2016 (E2) (E2)

Indicates that the application version is not supported by application protection.
Indicates that the application version is supported by application protection. Later maintenance and modification levels to the operating system version are also supported.

Editions:
(E1) Standard or Enterprise Editions
(E2) Standard. Business Intelligence, or Enterprise Editions

Notes:
(1) beginning with Data Protection for Microsoft SQL Server 7.1.6.1
 

Document information

More support for: IBM Spectrum Protect for Virtual Environments

Component: Data Protection for VMware

Software version: 7.1.6, 7.1.8, 8.1.0, 8.1.2, 8.1.4, 8.1.6, 8.1.7

Operating system(s): Windows

Reference #: 2005837

Modified date: 08 April 2019