IBM Support

Unable to open IBM InfoSphere Fast Track Client

Troubleshooting


Problem

Unable to open IBM InfoSphere Fast Track Client

Symptom

User that receives an error after the IBM Fast Track splash screen finishes loading (before
any login prompts). The error directs the user to check a log file in the Fast Track workspace.

Log file shows several errors about missing bundles/constraints. For example:

!ENTRY org.eclipse.equinox.ds 4 0 2017-02-06 08:54:56.154
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle
"org.eclipse.equinox.ds_1.2.0.v20100507 [700]" could not be resolved.
Reason: Missing Constraint: Import-Package:
org.eclipse.equinox.internal.util.event; version="1.0.0"
org.osgi.framework.BundleException: The bundle
"org.eclipse.core.runtime_3.6.0.v20100505 [702]" could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.core.jobs;
bundle-version="[3.2.0,4.0.0)"
java.lang.IllegalStateException: Unable to acquire application service.
Ensure that the org.eclipse.core.runtime bundle is resolved and started
(see config.ini).

Cause

Internal error, workspace temp files not cleaned up properly.

Resolving The Problem

Please try to delete/move the below folders and then try to start FastTrack.
<USERHOME>\fasttrack-configuration
<USERHOME>\fasttrack-workspace_*

For example:
C:\Users\Administrator\fasttrack-configuration
C:\Users\Administrator\fasttrack-workspace_11.5

[{"Product":{"code":"SSX3EG","label":"InfoSphere FastTrack"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.3;9.1","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21998486