IBM Support

Hardware and Software Requirements: Version 8.1.0 Data Protection for Oracle

Preventive Service Planning


Abstract

This document details the Hardware & Software requirements for Data Protection for Oracle 8.1.0.

Content


IBM Spectrum Protect for Databases: Data Protection for Oracle 8.1.0 supports valid Oracle environments that meet all requirements defined by that product, and also meet the specific requirements listed below.

This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.

Minimum hardware requirements


Minimum software and operating system requirements
Operating systems by platform


Applications by platform


Additional Operating Environments

Additional installation prerequisites


Minimum hardware requirements

The following information describes the minimum hardware and disk space requirements when using Data Protection for Oracle.


AIX

The following hardware is supported for the AIX platform:

  • IBM system p
  • IBM system i
  • Compatible hardware supported by the operating system and Oracle


The following disk space is required for the AIX platform:

  • A minimum of 75MB of disk space, and optionally:
  • At least 12MB of disk space for each Language Pack to be installed (there are 9 available).


HP Itanium

The following hardware is supported for the HP Itanium platform:

  • 64-bit HP Integrity Server (Itanium), or newer
  • Compatible hardware supported by the operating system and Oracle


The following disk space is required for the HP Itanium platform:

  • A minimum of 25MB of disk space, and optionally:
  • At least 11MB of disk space for each Language Pack to be installed (there are 9 available).


TIP: Some of the prerequisites defined in this document may require a system restart. To avoid a system restart, ensure that all of the minimum software requirements prerequisites detailed in the Additional Installation Prerequisites section of this document are installed before starting the Data Protection for Oracle installation process.


Linux on x86_64

The following hardware is supported for the Linux x86_64 platform:

  • 64-bit x86 based PC architecture hardware (such as Pentium)
  • 64-bit AMD64/EM64T architecture hardware
  • Compatible hardware supported by the operating system and Oracle


The following disk space is required for the Linux x86_64 platform:

  • A minimum of 20MB of disk space, and optionally:
  • At least 10MB of disk space for each Language Pack to be installed (there are 9 available).


TIP: Some of the prerequisites defined in this document may require a system restart. To avoid a system restart, ensure that all of the minimum software requirements prerequisites detailed in the Additional Installation Prerequisites section of this document are installed before starting the Data Protection for Oracle installation process.


Linux on System z

The following hardware is supported for the Linux on System z platform:

  • Any System z machine that is supported by the operating system and Oracle


The following disk space is required for the Linux on System z platform:

  • A minimum of 20MB of disk space, and optionally:
  • At least 13MB of disk space for each Language Pack to be installed (there are 9 available).


TIP: Some of the prerequisites defined in this document may require a system restart. To avoid a system restart, ensure that all of the minimum software requirements prerequisites detailed in the Additional Installation Prerequisites section of this document are installed before starting the Data Protection for Oracle installation process.


Solaris SPARC

The following hardware is supported for the Solaris SPARC platform:

  • Sun-4 SPARC, or newer hardware
  • Compatible hardware supported by the operating system and Oracle


The following disk space is required for the Solaris SPARC platform:

  • A minimum of 20MB of disk space, and optionally:
  • At least 10MB of disk space for each Language Pack to be installed (there are 9 available).


Solaris x86_64

The following hardware is supported for the Solaris x86_64 platform:

  • Systems based on x86-64 processor architecture such as Intel 64 or AMD64
  • Compatible hardware supported by the operating system and Oracle


The following disk space is required for the Solaris x86_64 platform:

  • A minimum of 20MB of disk space, and optionally:
  • At least 10MB of disk space for each Language Pack to be installed (there are 9 available).


Windows x64

The following hardware is supported for the Windows x64 platform:

  • Compatible hardware supported by the operating system and Oracle


The following disk space is required for the Windows x64 platform:

  • A minimum of 80MB of disk space, and optionally:
  • At least 25MB disk space for prerequisites included in the installation package (which are installed automatically if they are not already installed on the system).
  • At least 5MB of disk space for each Language Pack to be installed (there are 9 available).


TIP: The installation package includes the above referenced prerequisites which will be installed automatically if not already installed onto the system. Installation of the these prerequisite may require a system restart. To avoid a system restart, ensure that all of the minimum software requirements prerequisites detailed in the Additional installation prerequisites section of this document are installed before starting the Data Protection for Oracle installation process.

============================================================================

Minimum software and operating system requirements

The following information describes the minimum software and operating system requirements when using Data Protection for Oracle.


Operating systems

The following operating systems are supported for the 64-bit AIX platform:

  • 64-bit AIX 7.1 and later TL levels and fix packs
  • 64-bit AIX 7.2 and later TL levels and fix packs


The following operating systems are supported for the 64-bit HP Itanium platform:

  • 64-bit HP-UX 11iv3, and later mod levels and fix packs


The following operating systems are supported for the 64-bit Linux x86_64 platform:

  • 64-bit Red Hat Enterprise Linux (RHEL) 6.0, and later mod levels and fix packs
  • 64-bit Red Hat Enterprise Linux (RHEL) 7.0, and later mod levels and fix packs
  • 64-bit SUSE Enterprise Linux (SLES) 11.0, and later mod levels and fix packs
  • 64-bit SUSE Enterprise Linux (SLES) 12.0, and later mod levels and fix packs

The following operating systems are supported for the 64-bit Linux on System z platform:

  • 64-bit Red Hat Enterprise Linux (RHEL) 5.0, and later mod levels and fix packs
  • 64-bit Red Hat Enterprise Linux (RHEL) 6 Update 2, and later mod levels and fix packs
  • 64-bit SUSE Enterprise Linux (SLES) 11.0, and later mod levels and fix packs
  • 64-bit SUSE Enterprise Linux (SLES) 12.0, and later mod levels and fix packs


The following operating systems are supported for the 64-bit Solaris SPARC platform:

  • 64-bit Solaris 10, and later mod levels and fix packs
  • 64-bit Solaris 11, and later mod levels and fix packs


The following operating systems are supported for the 64-bit Solaris x86_64 platform:

  • 64-bit Solaris 10, and later mod levels and fix packs
  • 64-bit Solaris 11, and later mod levels and fix packs


The following operating systems are supported for the 64-bit Windows x64 platform:

  • 64-bit Windows Server 2012, or later Service Pack levels: Essential x64, Standard x64, or Datacenter x64 editions
  • 64-bit Windows Server 2012 R2, or later Service Pack levels: Essential x64, Standard x64, or Datacenter x64 editions
  • 64-bit Windows Server 2016, or later Service Pack levels: Standard x64, or Datacenter x64 editions


============================================================================

Applications by platform


The following application levels are supported for the 64-bit AIX platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)
  • 64-bit Oracle 19c: Standard or Enterprise Server, and later maintenance levels of 19c (starting with version 8.1.0.2 of Data Protection for Oracle on AIX 7.2)


The following application levels are supported for the 64-bit HP Itanium platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)
  • 64-bit Oracle 19c: Standard or Enterprise Server, and later maintenance levels of 19c (starting with version 8.1.0.2 of Data Protection for Oracle on HP-UX IA64 11 v3)


The following application levels are supported for the 64-bit Linux x86_64 platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)
  • 64-bit Oracle 19c: Standard or Enterprise Server, and later maintenance levels of 19c (starting with version 8.1.0.2 of Data Protection for Oracle)


The following application levels are supported for the 64-bit Linux on System z platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)


The following application levels are supported for the 64-bit Solaris SPARC platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)
  • 64-bit Oracle 19c: Standard or Enterprise Server, and later maintenance levels of 19c (starting with version 8.1.0.2 of Data Protection for Oracle on Solaris 11 SPARC)

The following application levels are supported for the 64-bit Solaris x86_64 platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)


The following application levels are supported for the 64-bit Windows x64 platform:

  • 64-bit Oracle 11gR2: Standard or Enterprise Server, and later maintenance levels of 11gR2
  • 64-bit Oracle 12c: Standard or Enterprise Server, and later maintenance levels of 12c
  • 64-bit Oracle 12cR2: Standard or Enterprise Server, and later maintenance levels of 12cR2
  • 64-bit Oracle 18c: Standard or Enterprise Server, and later maintenance levels of 18c (starting with version 8.1.0.2 of Data Protection for Oracle)


============================================================================

Additional Operating Environments

The following additional operating environments are supported:

  • Oracle Real Application Clusters as supported with the level of Oracle used in your environment
  • Solaris 10 and 11 global zones as supported by the Oracle database used in your environment
  • Solaris 10 and 11 non-global (local) zones as supported by the Oracle database used in your environment


============================================================================

Additional installation prerequisites


For the Linux x86_64 platform, Linux on Z, Solaris SPARC and Solaris x86_64 platforms:

The following prerequisites are required by the product installer:

  • Java JRE 8 and later 8.x levels


------------------------------------


Windows x64 platform

The following prerequisites are also required, and are installed automatically by Data Protection for Oracle 8.1.0, if not already present on your machine.


64-bit Microsoft Visual C++ 2012 Redistributable Package

Available in the following subdirectory of the installation image (DVD or downloaded image):
.....\ISSetupPrerequisites\ "{3A3AF437-A9CD-472f-9BC9-8EEDD7505A02} "\vcredist_x64.exe


TIP: The installation package includes the above prerequisites which will be installed automatically if not already installed onto the system. Installation of these prerequisites may require a system restart. To avoid a system restart, ensure that these prerequisites are installed before starting the Data Protection for Oracle installation process.

============================================================================

Additional requirements for the use of IBM Spectrum Protect Central Scheduling

On all 64-bit platforms except for Solaris SPARC and HPUX:

  • 64-bit IBM Spectrum Protect Backup-Archive Client 8.1.0 or later update levels, releases, and versions.
  • For Solaris SPARC use the latest 7.1.x 64-bit IBM Spectrum Protect Backup-Archive Client supported with Solaris SPARC, which as of this writing is 7.1.6.
  • For HPUX use the latest 7.1.x 64-bit IBM Spectrum Protect Backup-Archive Client supported with HPUX, which as of this writing is 7.1.6.


============================================================================

Other Additional requirements


On all 64-bit platforms:

  • 64-bit IBM Spectrum Protect API 8.1.0 or later update levels, releases, and versions


Note: The 64-bit IBM Spectrum Protect API Version 8.1.0 is included and automatically installed with Data Protection for Oracle on 64-bit platforms.


All platforms:

  • Any Tivoli Storage Manager or IBM Spectrum Protect Server currently in support which is supported by the version of the IBM Spectrum Protect API Client, or IBM Spectrum Protect Backup-Archive Client, used in the environment


TIP: IBM Spectrum Protect Client/API and Server compatibility information is located in the IBM Tivoli Storage Manager Server/Client Compatibility and Upgrade Considerations tech note located here: http://www.ibm.com/support/docview.wss?uid=swg21053218


All platforms except Windows and AIX:

  • IBM or Oracle Java 8, and later mod levels and fix packs


============================================================================

Virtualization support

Information regarding the virtualization environments supported by IBM Spectrum Protect for Databases: Data Protection for Oracle is documented here:
http://www.ibm.com/support/docview.wss?&uid=swg21239546

============================================================================

Where to download IBM Spectrum Protect for Databases 8.1.0

The IBM Spectrum Protect for Databases download document provides information about how and where to obtain the IBM Spectrum Protect for Databases 7.1.3 packages. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24042929


TIP: Data Protection for Oracle 8.1.0 is a component of IBM Spectrum Protect for Databases 8.1.0.

============================================================================

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect for Databases and its components

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect for Databases, and its components, are located in the "All Requirements Doc" located at:
http://www.ibm.com/support/docview.wss?uid=swg21218747

============================================================================

Document information

More support for: IBM Spectrum Protect for Databases

Component: Data Protection for Oracle

Software version: 8.1.0

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 1992569

Modified date: 05 June 2019