IBM Support

Hardware and Software Requirements: Version 8.1.0 IBM Spectrum Protect™ Snapshot for SQL Server & 8.1.0 Data Protection for Microsoft SQL Server

Preventive Service Planning


Abstract


This document details the Hardware & Software requirements for IBM Spectrum Protect™ Snapshot for Microsoft SQL Server 8.1.0 and Data Protection for Microsoft SQL Server 8.1.0.

Content

The following components share the same hardware and software requirements. The components are:

  • Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 --> which is part of the IBM Spectrum Protect Snapshot 8.1.0 product.
  • Data Protection for Microsoft SQL Server 8.1.0 --> which is part of the IBM Spectrum Protect™ for Databases 8.1.0 product.


This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.


This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document.

Minimum hardware requirements
x64 Hardware
x64 Disk space
Metadata space requirements (IBM Spectrum Protect Snapshot for Microsoft SQL Server only)

Minimum software and operating system requirements
Operating systems
x64 Operating Systems
Operating Systems Supported by the MMC Remote Management Capabilities
Applications Supported
x64 Applications

Additional Microsoft prerequisites
64-bit Data Protection for Microsoft SQL Server 8.1.0

Additional components required
IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 component requirements
Data Protection for Microsoft SQL 8.1.0 component requirements

Additional requirements for storage of backups in an IBM Spectrum Protect or Tivoli Storage Manager Server

Virtualization support

Where to download IBM Spectrum Protect Snapshot 8.1.0

Links to the Hardware & Software requirements for the other components that are a part of IBM Spectrum Protect Snapshot 8.1.0

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect Snapshot and its components

Links to the Known Issues and Limitations associated with IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.x and Data Protection for Microsoft SQL Server 8.1.x

Where to download IBM Spectrum Protect for Databases 8.1.0

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect for Databases and its components


Minimum hardware requirements

The following information describes the minimum hardware and disk space requirements when using IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 or Data Protection for Microsoft SQL Server 8.1.0.

x64 Hardware

The following hardware is supported for the x64 platform:
  • Compatible hardware supported by the operating system and the Microsoft SQL Server


x64 Disk Space

The following disk space is required for the x64 platform:
  • A minimum of 208 MB of disk space for the product and language packs to be installed.
  • At least 2.1 GB disk space for "Additional Microsoft prerequisites" which will be installed automatically if they are not already installed on the system when starting the Data Protection for Microsoft SQL Server or Spectrum Protect Snapshot for Microsoft SQL Server component installation.


TIP: Some of the prerequisites defined in this document may require a system restart. To avoid a system restart, ensure that all of the minimum software requirement prerequisites detailed in the " Additional Microsoft prerequisites" section of this document are installed before starting the IBM Spectrum Protect Snapshot for Microsoft SQL Server or Data Protection for Microsoft SQL Server installation process.

============================================================================

Metadata space requirements (IBM Spectrum Protect Snapshot for Microsoft SQL Server only)


In addition to the space that is required for the global product installation, IBM Spectrum Protect Snapshot uses disk space to hold vital product data that is used to track and manage snapshots. By default, the metadata is stored in the 'vss_staging' subdirectory of the IBM Spectrum Protect Snapshot VSS Requestor component's installation directory.


TIP: The IBM Spectrum Protect Snapshot VSS Requestor component is also known as the IBM Spectrum Protect Backup-Archive Client.

The amount of space required is directly proportional to the number of snapshots that you maintain on the system. Ensure that there is at least 1 megabyte of available free disk space to hold the metadata for each snapshot that you plan to keep on the system.

============================================================================

Minimum software and operating system requirements

The following information describes the minimum operating system and software requirements when using IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 or Data Protection for Microsoft SQL Server 8.1.0.

Operating Systems


x64 Operating Systems

The following operating systems are supported for the x64 platform:
  • 64-bit Windows Server 2012, and later maintenance levels: Essentials, Standard or Datacenter editions
  • 64-bit Windows Server 2012 R2, and later maintenance levels: Essentials, Standard or Data Center editions

  • 64-bit Windows Storage Server 2012, and later maintenance levels: Workgroup or Standard editions.
  • 64-bit Windows Storage Server 2012 R2, and later maintenance levels: Workgroup or Standard editions.
  • 64-bit Windows Server 2016, and later maintenance levels: Essentials, Standard or Datacenter editions

Note: Windows Storage Server 2012 and 2012 R2 are only supported for functionality that is also available and supported by the IBM Spectrum Protect Snapshot for Microsoft SQL Server or Data Protection for Microsoft SQL Server components on Windows Server 2012 and 2012 R2 Editions.

The following additional operating systems are supported for the x64 platform but only with the Remote Management capabilities of the MMC GUI interface:
  • 64-bit Windows 8.1 and later Service Pack maintenance levels: Professional or Enterprise editions
  • 64-bit Windows 10 and later Service Pack maintenance levels: Professional or Enterprise editions

Note: Remote management capabilities of the MMC GUI interface are supported in an x64
based (64-bit) platform only.

============================================================================


Applications Supported

x64 Applications

The following application levels are supported for the x64 platform:
  • Microsoft SQL Server 2014, and later maintenance levels: Standard. Business Intelligence, or Enterprise Editions
  • Microsoft SQL Server 2016, and later maintenance levels: Standard. Business Intelligence, or Enterprise Editions


============================================================================

Additional Microsoft prerequisites

The following prerequisites from Microsoft are required and must be installed prior to using IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 or Data Protection for Microsoft SQL Server 8.1.0:
  • Windows Powershell 3 or Windows Powershell 4
  • Windows PowerShell 5 when used with Windows 10
  • Windows Management Framework 3 or Windows Management Framework 4
  • Windows Management Framework 5 when used with Windows 10


The following prerequisites from Microsoft are required, and are installed automatically by IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 or Data Protection for Microsoft SQL Server 8.1.0, if not already present on your machine.


TIP: Installation of these prerequisites may require a system restart. To avoid a system restart, ensure that these prerequisites are installed before starting the IBM Spectrum Protect Snapshot for Microsoft SQL Server or Data Protection for Microsoft SQL Server installation process.


Note: These prerequisites are not automatically installed when you create your own silent installation package to install via msiexec. In that scenario, you must manually ensure that the prerequisites are installed.

---------------------------------------



64-bit Data Protection for Microsoft SQL Server 8.1.0


Note: Please also review the information documented in the preceding section: Additional Microsoft prerequisites



32-bit Microsoft Visual C++ 2012 Redistributable Package

Available in the following subdirectory of the installation image (DVD or downloaded image):
TIVFCM_WIN\fcm\x64\mmc\8100\enu\ISSetupPrerequisites\{BF2F04CD-3D1F-444e-8960-D08EBD285C3F}


64-bit Microsoft Visual C++ 2012 Redistributable Package

Available in the following subdirectory of the installation image (DVD or downloaded image):
...ISSetupPrerequisites\{3A3AF437-A9CD-472F-9BC9-8EDD7505A02}\vcredist_x64.exe

Microsoft .NET Framework 4.5

Available in the following subdirectory of the installation image (DVD or downloaded image):
.....ISSetupPrerequisites\{72D7E3D1-C9DF-4FA6-9F9B-4E5117AB2919}\dotNetFx45_Full_x86_x64.exe

Microsoft SQL Server 2012 System CLR Types
Available in the following subdirectory of the installation image (DVD or downloaded image):
fcm\x64\sql\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2012 System CLR Types 11.0.2100.60 (x64)\SQLSysClrTypes.msi
fcm\x64\sql\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2012 System CLR Types 11.0.2100.60 (x86)\SQLSysClrTypes.msi

Note: This item is a prerequisite to using the ReportViewer 2012 Redistributable


MICROSOFT® REPORT VIEWER 2012 RUNTIME
Available in the following subdirectory of the installation image (DVD or downloaded image):
fcm\x64\mmc\8100\enu\ISSetupPrerequisites\Microsoft ReportViewer 2012 11.1.3010.3\ReportViewer.msi



Microsoft SQL Server 2014 System CLR Types
Available in the following subdirectory of the installation image (DVD or downloaded image):
fcm\x64\mmc\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2014 System CLR Types 12.0.2000.8 (x64)\SQLSysClrTypes.msi
fcm\x64\mmc\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2014 System CLR Types 12.0.2000.8 (x86)\SQLSysClrTypes.msi

Microsoft SQL Server 2014 Management Objects
Available in the following subdirectory of the installation image (DVD or downloaded image):
fcm\x64\sql\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2014 Management Objects 12.0.2000.8 (x64)\SharedManagementObjects.msi
fcm\x64\sql\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2014 Management Objects 12.0.2000.8 (x86)\SharedManagementObjects.msi

Windows PowerShell Extensions for SQL Server 2014
Available in the following subdirectory of the installation image (DVD or downloaded image):
\fcm\x64\sql\8100\enu\ISSetupPrerequisites\Windows PowerShell Extensions for SQL Server 2014 12.0.2000.8 (x64)\PowerShellTools.msi
\fcm\x64\sql\8100\enu\ISSetupPrerequisites\Windows PowerShell Extensions for SQL Server 2014 12.0.2000.8 (x86)\PowerShellTools.msi

Microsoft SQL Server 2016 System CLR Types

Available in the following subdirectory of the installation image (DVD or downloaded image):
fcm\x64\mmc\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2016 System CLR Types 13.0.1601.5 (x64)\SQLSysClrTypes.msi
fcm\x64\mmc\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2016 System CLR Types 13.0.1601.5 (x86)\SQLSysClrTypes.msi


Microsoft SQL Server 2016 Management Objects
Available in the following subdirectory of the installation image (DVD or downloaded image):
fcm\x64\sql\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2016 Management Objects 13.0.1601.5 (x64)\SharedManagementObjects.msi
fcm\x64\sql\8100\enu\ISSetupPrerequisites\Microsoft SQL Server 2016 Management Objects 13.0.1601.5 (x86)\SharedManagementObjects.msi

Windows PowerShell Extensions for SQL Server 2016
Available in the following subdirectory of the installation image (DVD or downloaded image):
\fcm\x64\sql\8100\enu\ISSetupPrerequisites\Windows PowerShell Extensions for SQL Server 2016 13.0.1601.5 (x64)\PowerShellTools.msi
\fcm\x64\sql\8100\enu\ISSetupPrerequisites\Windows PowerShell Extensions for SQL Server 2016 13.0.1601.5 (x86)\PowerShellTools.msi
============================================================================

Additional components required


IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 requires the following components:
  • IBM Spectrum Protect Snapshot MMC Snapin and Base System Services 8.1.0

Note: This is a component included in the IBM Spectrum Protect Snapshot on Windows 8.1.0 package.

  • IBM Spectrum Protect Snapshot VSS Requestor 8.1.0 (only required for VSS backups for SQL)

Note: This is a component included in the IBM Spectrum Protect Snapshot on Windows 8.1.0 package. It is also known as the IBM Spectrum Protect Backup-Archive Client 8.1.0

============================================================================


Data Protection for Microsoft SQL Server 8.1.0 requires the following component:
  • IBM Spectrum Protect Backup-Archive Client 8.1.0 and later 8.1.x maintenance levels, new releases, and new versions

TIP: It is a requirement of the IBM Spectrum Protect Backup-Archive Client and the IBM Spectrum Protect API client that they remain in sync to the Version.Release.Modification level when used on the same Windows system.

============================================================================

Additional requirements for storage of backups in an IBM Spectrum Protect or Tivoli Storage Manager Server
  • The IBM Spectrum Protect API Client 8.1.0, and later 8.1.x maintenance levels, new releases, and new versions

Note: The IBM Spectrum Protect API Version 8.1.0 is included and automatically installed with Data Protection for Microsoft SQL Server 8.1.0.

Note: The IBM Spectrum Protect API Version 8.1.0 is included and automatically installed with IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0.

TIP: It is a requirement of the IBM Spectrum Protect Backup-Archive Client and the IBM Spectrum Protect API client that they remain in sync to the Version.Release.Modification level when used on the same Windows system

  • Any Tivoli Storage Manager or IBM Spectrum Protect Server currently in support which is supported by the version of the IBM Spectrum Protect API Client, or IBM Spectrum Protect Backup-Archive Client, used in the environment.


TIP: IBM Spectrum Protect Client/API and Server compatibility information is located in the IBM Tivoli Storage Manager Server/Client Compatibility and Upgrade Considerations tech note located here: http://www.ibm.com/support/docview.wss?uid=swg21053218

============================================================================

Virtualization support

Information regarding the virtualization environments supported by IBM Spectrum Protect Snapshot is documented here: http://www.ibm.com/support/docview.wss?uid=swg21433737

Information regarding the virtualization environments supported by IBM Spectrum Protect for Databases: Data Protection for Microsoft SQL Server is documented here:
http://www.ibm.com/support/docview.wss?&uid=swg21239546

============================================================================


Where to download IBM Spectrum Protect Snapshot 8.1.0

The IBM Spectrum Protect Snapshot 8.1.0 download document provides information about how and where to obtain the IBM Spectrum Protect Snapshot for Windows 8.1.0 packages. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24042724

TIP: The IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.0 component is located in the IBM Spectrum Protect Snapshot 8.1.0 for Windows download image.

============================================================================

Links to the Hardware & Software requirements for the other components that are a part of IBM Spectrum Protect Snapshot 8.1.0

Links to the Hardware & Software requirements for the other components that are part of IBM Spectrum Protect Snapshot 8.1.0 are located at: http://www.ibm.com/support/docview.wss?uid=swg21991823

============================================================================


Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect Snapshot and its components

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect Snapshot, and its components, are located in the "All Requirements Doc" located at: http://www.ibm.com/support/docview.wss?uid=swg21427692

============================================================================


Links to the Known Issues and Limitations associated with IBM Spectrum Protect Snapshot for Microsoft SQL Server 8.1.x and Data Protection for Microsoft SQL Server 8.1.x

The Known Issues & Limitations tech notes describe known issues and limitations in all 8.1.x levels of IBM Spectrum Protect Snapshot for Microsoft SQL Server and in all 8.1.x levels of IBM Spectrum Protect for Databases: Data Protection for Microsoft SQL Server.

This information is located at: http://www.ibm.com/support/docview.wss?uid=swg21992685

============================================================================

Where to download IBM Spectrum Protect for Databases 8.1.0

The IBM Spectrum Protect for Databases: Data Protection for Microsoft SQL Server download document provides information about how and where to obtain the IBM Spectrum Protect for Databases 8.1.0 packages. The information is located at: http://www.ibm.com/support/docview.wss?uid=swg24042929


TIP: The Data Protection for Microsoft SQL Server 8.1.0 component is located in IBM Spectrum Protect for Databases 8.1.0.

============================================================================

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect for Databases and its components

Links to the Hardware & Software requirements for other releases of IBM Spectrum Protect for Databases, and its components, are located in the "All Requirements Doc" located at: http://www.ibm.com/support/docview.wss?uid=swg21218747

============================================================================

Document information

More support for: IBM Spectrum Protect Snapshot
FlashCopy Manager for Microsoft SQL Server

Software version: 8.1.0

Operating system(s): Windows

Reference #: 1992314

Modified date: 26 July 2017