Troubleshooting
Problem
Use the wrong URL for the connection from Cognos for Microsoft Office and Cognos Analysis for Microsoft Excel to Cognos Analytics server.
Symptom
COI-ERR-2011 Unable to connect to the server.
Cause
Wrong URL for the connection
Environment
Cognos Analytics
Cognos for Microsoft Office
Planning Analytics for Excel (PAX) or Cognos Analysis for Microsoft Excel (Cafe)
Diagnosing The Problem
01. Click the plus sign (+) next to the server where you want to work with
When a connection error appears then the URL is wrong.
Resolving The Problem
01. In Cognos for Microsoft Office or Cognos Analysis for Microsoft Excel click Options
02. Add or change the URL to your Cognos Analytics Server into:
http://[server]:[port]/bi/v1/disp
(If using a Gateway, use http://[server]:[port]/[alias]/bi/v1/disp)
03. Test the connection and click save
04. Close the Option window
Test the connection:
01. Click the plus sign (+) next to the server where added or past the new URL
Note: an authentication window should appear or the content from Cognos with the folder and packages should appear. Then the connection works fine.
Was this topic helpful?
Document Information
Modified date:
11 November 2022
UID
swg21990659