Troubleshooting
Problem
DataStage Designer Client fails to connect to DataStage server with the following error message: An error occurred in the secure channel support [12157]
Cause
This error occurs when there is no common TLS/SSL protocol between the Information Server service tier, and the Designer client on Windows.
By default, modern installations of Windows support TLS 1.2 only.
In 2022, most Windows Update settings block TLS 1.0 connections.
Older versions of Information Server, such as 11.5, were set up with TLS 1.0 by default.
Environment
First, check to see whether you can access the WebSphere Application Server admin console.
Most browsers do not directly support TLS 1.0. In this situation, you might need to change the browser configuration.
For instance, in Firefox, you can:
- Start with
about:config
- Search for the
tls
settings - Change
security.tls.version.min
to 0.
These steps enable TLS 1.0 support for Firefox. You can change the
security.tls.version.min
setting back to the original value when you are done.If you are using a different browser like Chrome or Edge, check the browser documentation on how to enable TLS 1.0 connections.
Resolving The Problem
In the WebSphere Application Server admin console, enable TLS 1.2.
These steps are described in one of our technotes:
Once the service tier is updated for TLS 1.2, you can now use Designer and Director with the service tier of Information Server.
(Older protocols, such as TLS 1.0, SSL 3.0, and SSL 2.0 are considered insecure, and are no longer recommended for active Information Server installations that use SSL)
[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
29 November 2022
UID
swg21984671