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Why IBM TRIRIGA employee records are not bringing the list of licenses available on system?

Question & Answer


Question

Why IBM TRIRIGA employee records are not bringing the list of licenses available on system?

Cause

We are following these steps for associating licenses to a new IBM TRIRIGA employee record just created:

(a) IBM TRIRIGA Employee record is created;
(b) Go to Profile tab;
(c) Scroll down to License Details section;
(d) Find Licenses to be added [ISSUE: nothing listed];
(e) Open IBM TRIRIGA Admin Console -> License Manager -> [ISSUE: nothing listed];

We do see the license files available on our IBM TRIRIGA [tririga_root]\config\licenses folder.

Therefore, the IBM TRIRIGA "Home -> Tools -> System Setup -> System -> License" application is showing these files correctly.



How can I fix this issue?

Answer

Kindly follow these actions for trying to fix the missing license issue:

(A) Go to each one of your IBM TRIRIGA server install directories, and confirm if the license files are really available under [tririga_root]\config\licenses folder.

(B) Make sure you have recently downloaded the IBM TRIRIGA licenses from IBM Passport Advantadge portal, and make sure you are not using old license format file from the old versions. You must NOT have old and new license files in the same directory ([tririga_root]\config\licenses). If you have the old license file TRIRIGALICENSE.properties in place, download the new license files from IBM Passport Advantage portal, copy them to the [tririga_root]\config\licenses folder, remove the old file TRIRIGALICENSE.properties, and then restart the IBM TRIRIGA servers/JVMs.

The recent IBM TRIRIGA license files available on IBM TRIRIGA Passport Advantage portal have this formatting: LICENSE_IBM_TRIRIGA_[productname].properties. For more information, see IBM TRIRIGA Application Platform 3.2 and later

For more information on how to download software & files from IBM Passport Advantage portal, see: How to download software from Passport Advantage Online website


(C) Stop your IBM TRIRIGA servers (application, process, tool) / JVMs, stop your Application Server, restart your Application server and then restart your IBM TRIRIGA servers/JVMs. You may have some sort of inconsistency on Operating System memory or JVM memory area leading to this unexpected problem.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application builder","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
30 March 2022

UID

swg21981911