IBM Support

"Standard Error ... 0x80010105 ... RPC_E_SERVERFAULT ... XlWindowState RHS" immediately after clicking "Company - Data Entry - Reported Values"

Troubleshooting


Problem

User ensures that Microsoft Excel is closed. User launches the 'main' Controller client (CCR.EXE). User clicks 'Company - Data Entry - Reported Values'. User does not click on anything further (does not make any selections). Instead, the user simply waits. Initially, the cursor gives an 'hourglass/sandtimer/spinning-wheel' (waiting) symbol. Approximately 2 seconds, later, an error appears.

Symptom

Initially, for the first two seconds or so, the cursor changes to a 'waiting' symbol:

After 2 seconds, this Error appears:



Standard Error

Error Details
Source: Microsoft.Office.Interop.Excel
Description: The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))
at Microsoft.Office.Interop.Excel.ApplicationClass.set_WindowsState(XlWindowState RHS)
at Cognos.Controller.Forms.Common.fFrmFrangoFunc.GetExcelApplication(String sText...
<...>
==================================

If the end user ignores the error, then the 'Open' button is continually greyed out/inactive (it never becomes active)
  • Therefore it is impossible to click 'Open' to open the form in Excel:

Cause

There are several potential causes for the "(Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))" error.

  • For more examples, see separate IBM Technote #1574387.

This Technote specifically deals with the scenario where the client device has an incompatible Excel add-in installed.

Example:
In one real-life example, the customer had a third-party (Sun Systems) utility called 'Infor Q&A' installed.

Environment

Client device has incompatible third-party (non-IBM) Excel add-in installed/registered.

Example:

In one real-life example ('Infor Q&A'), the problem was only triggered when the client device had Excel 2013 installed on it. Everything worked OK when using Excel 2010 or 2016.

Diagnosing The Problem

After getting the error message, a new 'EXCEL.EXE' process appears in Task Manager, but is hidden to the user.

  • Therefore, over time, several 'hidden' (ghost) EXCEL.EXE processes will appear in Task Manager:

Resolving The Problem

Fix:
Disable the third-party (non-IBM) incompatible Excel add-in.

Steps:
In one real-life example, the solution was:
1. Launch Excel

2. Click "File - Options"

3. Click "Add-ins"

4. Change 'Manage' to 'COM add-ins'


5. Click 'Go...'

6. Untick the COM Add-In called 'Infor Query and Analysis Add-in'



7. Click OK and test.

Workaround:
There are several workarounds:
  • Method #1
Launch Excel separately (and leave it running in the background) before using the main client (CCR.EXE) menu item "Company - Data Entry - Reported Values".
  • Method #2
Open Data Entry forms from directly inside the Excel link menu item.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21981407