IBM Support

Announcement: End of Support for IBM WebSphere MQ V7.1, WebSphere MQ File Transfer Edition V7.0.4, V7.0.3 and V7.0.2, WebSphere MQ Advanced Message Security V7.0.1, WebSphere MQ Hypervisor Edition V7.0.1, and IBM MQ Light V1.0.x

News


Abstract

IBM has withdrawn support for WebSphere MQ V7.1, WebSphere MQ File Transfer Edition V7.0, and WebSphere MQ Advanced Message Security V7.0.1 on all platforms including z/OS; WebSphere MQ Hypervisor Edition V7.0.1, and IBM MQ Light V1.0.x on all platforms.

Content

WMQ V7.1 • WMQ FTE V7.0 • WMQ AMS V7.0.1 • WMQ HVE V7.0.1 • MQ Light V1.0.x

  1. What were the end of support dates for WebSphere MQ V7.1, WebSphere MQ File Transfer Edition V7.0.4, V7.0.3 and V7.0.2, WebSphere MQ Advanced Message Security V7.0.1, WebSphere MQ Hypervisor Edition V7.0.1, and IBM MQ Light V1.0.x?
  2. What replacement products are available?
  3. How do I check which version I am currently running?
  4. Is any information available to help me upgrade to a later version?
  5. How do I purchase a support extension for my current version?
  6. When a WebSphere MQ server product goes out of support, do the client and file transfer agent also go out of support?
  7. Are these products still supported when they are bundled with another IBM product?
  8. Is the WebSphere MQ V7.1 Resource Adapter supported in WebSphere Application Server?
  9. Is documentation still available for these products?
  10. How do I obtain installation images for these products if I still need them?
  11. Is there an IBM MQ V9.1 trial version available for download?


What were the end of support dates for WebSphere MQ V7.1, WebSphere MQ File Transfer Edition V7.0.4, V7.0.3 and V7.0.2, WebSphere MQ Advanced Message Security V7.0.1, WebSphere MQ Hypervisor Edition V7.0.1, and IBM MQ Light V1.0.x?

 
Product Version Release Date End of Support Platforms
WebSphere MQ V7.1.0 11 Nov 2011 30 Apr 2017 AIX, HP-UX (Itanium), IBM i, Linux (POWER), Linux (x86), Linux (x86-64), Linux (zSeries 64-bit), Solaris (SPARC), Solaris (x86-64), Windows (x86)
WebSphere MQ for z/OS V7.1.0 25 Nov 2011 06 Nov 2017 z/OS
WebSphere MQ Advanced for z/OS V7.1.0 12 Oct 2012 13 Dec 2017 z/OS
WebSphere MQ for z/OS Value Unit Edition V7.1.0 22 Nov 2013 11 Sep 2017 z/OS
WebSphere MQ File Transfer Edition V7.0.4 03 Jun 2011 30 Sep 2017 AIX, HP-UX (Itanium), HP-UX (PA-RISC), IBM i and i5/OS, Linux (POWER), Linux (x86), Linux (x86-64), Linux (zSeries 64-bit), Solaris (SPARC), Solaris (x86-64), Windows (x86)
WebSphere MQ File Transfer Edition for z/OS V7.0.4 10 Jun 2011 11 Sep 2017 z/OS
WebSphere MQ File Transfer Edition V7.0.3 19 Nov 2010 30 Sep 2016 AIX, HP-UX (Itanium), HP-UX (PA-RISC), IBM i and i5/OS, Linux (POWER), Linux (x86), Linux (x86-64), Linux (zSeries 64-bit), Solaris (SPARC), Solaris (x86-64), Windows (x86)
WebSphere MQ File Transfer Edition for z/OS V7.0.3 26 Nov 2010 11 Sep 2017 z/OS
WebSphere MQ File Transfer Edition V7.0.2 27 Nov 2009 30 Sep 2016 AIX, HP-UX (Itanium), HP-UX (PA-RISC), IBM i and i5/OS, Linux (POWER), Linux (x86), Linux (x86-64), Linux (zSeries 64-bit), Solaris (SPARC), Windows (x86)
WebSphere MQ File Transfer Edition for z/OS V7.0.2 04 Dec 2009 11 Sep 2017 z/OS
WebSphere MQ Advanced Message Security V7.0.1 08 Oct 2010 30 Sep 2017 AIX, HP-UX (Itanium), HP-UX (PA-RISC), Linux (POWER), Linux (x86), Linux (x86-64), Linux (zSeries 64-bit), Solaris (SPARC), Solaris (x86-64), Windows (x86)
WebSphere MQ Advanced Message Security for z/OS V7.0.1 08 Oct 2010 11 Sep 2017 z/OS
WebSphere MQ Hypervisor for AIX V7.0.1 18 Nov 2011 30 Apr 2017 AIX
WebSphere MQ Hypervisor Edition for Red Hat Enterprise Linux for x86 V7.0.1 17 Jun 2011 30 Apr 2017 Linux (x86)
IBM MQ Light V1.0.x 26 Sep 2014 30 Apr 2017 Linux (x86-64), macOS and OS X (x86-64), Windows (x86-64)
 

What replacement products are available?

 

Replacements for WebSphere MQ V7.1 include IBM MQ V9.1 and IBM MQ V9.0.  While IBM MQ V8.0 and IBM MQ Advanced V8.0 are also available, their end of support date is 30 April 2020.  IBM MQ 9.0 is the last version to support HP-UX on Itanium. Per a statement of direction in the IBM MQ 9.1.x announcement letters, IBM MQ 9.1 is the last version to support Oracle Solaris on SPARC and x86-64.

Replacements for WebSphere MQ for z/OS V7.1 and WebSphere MQ Value Unit Edition for z/OS V7.1 include IBM MQ for z/OS V9.1, IBM MQ for z/OS Value Unit Edition V9.1, IBM MQ Advanced for z/OS V9.1, IBM MQ Advanced for z/OS Value Unit Edition V9.1, IBM MQ for z/OS V9.0, IBM MQ for z/OS Value Unit Edition V9.0, and IBM MQ Advanced for z/OS V9.0.  While IBM MQ for z/OS V8.0, IBM MQ for z/OS Value Unit Edition V8.0, and IBM MQ Advanced for z/OS V8.0 are available, their end of support date is 30 April 2020.

Replacements for WebSphere MQ File Transfer Edition V7.0.4, V7.0.3 and V7.0.2 include IBM MQ V9.1 and IBM MQ V9.0 with advanced entitlement.  While IBM MQ Advanced V8.0 is also available, its end of support date is 30 April 2020.  The advanced entitlement provides access to several additional features, including the Managed File Transfer component which replaces the former File Transfer Edition product.  IBM MQ 9.0 is the last version to support HP-UX on Itanium. Per a statement of direction in the IBM MQ 9.1.x announcement letters, IBM MQ 9.1 is the last version to support Oracle Solaris on SPARC and x86-64.

Replacements for WebSphere MQ File Transfer Edition for z/OS V7.0.4, V7.0.3 and V7.0.2 include IBM MQ Advanced for z/OS V9.1, IBM MQ Advanced for z/OS Value Unit Edition V9.1, and IBM MQ Advanced for z/OS V9.0.  While IBM MQ Advanced for z/OS V8.0 and IBM MQ Managed File Transfer for z/OS V8.0 are also available, their end of support date is 30 April 2020.  The Advanced license allows the use of the Managed File Transfer component.

Replacements for WebSphere MQ Advanced Message Security for z/OS V7.0.1 include IBM MQ Advanced for z/OS V9.1, IBM MQ Advanced for z/OS Value Unit Edition V9.1, and IBM MQ Advanced for z/OS V9.0.  While IBM MQ Advanced for z/OS V8.0 and IBM MQ Advanced Message Security for z/OS V8.0 are also available, their end of support date is 30 April 2020.  The Advanced license allows the use of the Advanced Message Security component.

Replacements for WebSphere MQ Hypervisor for AIX V7.0.1 include IBM MQ V9.1 and IBM MQ V9.0.  While IBM MQ V8.0 and IBM MQ Advanced V8.0 are also available, their end of support date is 30 April 2020.

Replacements for WebSphere MQ Hypervisor for Red Hat Enterprise Linux for x86 V7.0.1 include IBM MQ V9.1 and IBM MQ V9.0.  While IBM MQ V8.0 and IBM MQ Advanced V8.0 are also available, their end of support date is 30 April 2020.

Replacements for IBM MQ Light V1.0.x include IBM MQ V9.1 and IBM MQ V9.0.  While IBM MQ V8.0 and IBM MQ Advanced V8.0 are also available, their end of support date is 30 April 2020. You must install IBM MQ V8.0.0.4 or later downloaded from Passport Advantage to get the new AMQP component which supports client applications using the MQ Light API. Applying fix pack 8.0.0.4 or later to an existing IBM MQ V8.0.0.3 or earlier installation will not add the new AMQP component. MQ Light V1.0.x for OS X and macOS has no replacement.

 

 

How do I check which version I am currently running?

 

Follow these general instructions or the IBM MQ Knowledge Center instructions to display your IBM MQ or WebSphere MQ version on all platforms except for z/OS with the command: dspmqver

On z/OS, look for message CSQY000I in the MSTR joblog to determine your version.

Follow the IBM MQ Knowledge Center instructions to display your Managed File Transfer or WebSphere MQ File Transfer Edition version with the command: fteDisplayVersion

If you are running WebSphere MQ Advanced Message Security, display the version with this command: dspmqsver




 

Is any information available to help me upgrade to a later version?

 

The IBM MQ Migration Guide is available to view online or download:

 

The IBM Knowledge Center also includes information to assist you in migrating to a supported version of IBM MQ:



 

How do I purchase a support extension for my current version?

 

Support extensions may be available for an additional fee. To purchase extended support for WebSphere MQ or any of the other products, please contact your local IBM sales representative.

US Customers should contact Customer Support Operations at 1-877-426-6006, option #2. If you provide your IBM customer number, they can quickly find your sales representative.

Customers in other geographies should refer to the IBM directory of worldwide support contacts to find sales contact numbers in your region:

 

 

When a WebSphere MQ server product goes out of support, do the client and file transfer agent also go out of support?

 

Yes. The WebSphere MQ V7.1 clients and WebSphere MQ File Transfer Edition V7.0 agents went out of support at the same time as the server.

 



 

Are these products still supported when they are bundled with another IBM product?

 

Yes, support is available for all bundled components until the IBM product that includes them is withdrawn from support. However, they are only supported when used by the bundling IBM product. Unrelated usage is not supported:

Is the WebSphere MQ V7.1 Resource Adapter supported in WebSphere Application Server?

 

Yes, the WebSphere MQ V7.1 Resource Adapter shipped with WebSphere Application Server V8.5.x is supported as long as that version of WebSphere Application Server remains in support, or longer if you purchase a WebSphere Application Server support extension.

However, if you manually install your own copy of the WebSphere MQ V7.1 Resource Adapter in WebSphere Application Server or any third-party Java EE server, it is not supported.

 

The IBM MQ V9.1, V9.0 and V8.0 Resource Adapters implement JMS 2.0 and cannot be installed in WebSphere Application Server V8.5.x, V8.0 and V7.0, which support JMS 1.1 only.  WebSphere Application Server V9.0 ships with the IBM MQ V9.0 Resource Adapter and includes full support for JMS 2.0. The version of MQ Resource Adapter you use must be supported by your Java EE application server but need not match the version of the queue managers to which you wish to connect.

 

Is documentation still available for these products?

 

Yes. Online documentation is available in the IBM Knowledge Center.



 

How do I obtain installation images for these products if I still need them?

 

Installation images for WebSphere MQ V7.1, WebSphere MQ File Transfer Edition V7.0.4, V7.0.3 and V7.0.2, WebSphere MQ Advanced Message Security V7.0.1, and WebSphere MQ Hypervisor Edition V7.0.1 are no longer available from Passport Advantage. Contact IBM if you have an urgent business need for these installation images. IBM MQ Light V1.0.x is no longer available from IBM developerWorks.

 




 

Is there an IBM MQ V9.1 trial version available for download?

 

You can obtain a full-featured trial version of IBM MQ V9.1 to evaluate for 90 days:



Cross reference information
Product Component Platform Version Edition
WebSphere MQ File Transfer Edition Install / Migration AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS 7.0.4, 7.0.3, 7.0.2
WebSphere MQ Install / Migration AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS 7.0.1 Advanced Message Security
IBM MQ Light Install / Migration Linux, Mac OS, Windows 1.0

Document information

More support for: WebSphere MQ

Component: Install / Migration

Software version: 7.1

Operating system(s): AIX, HP-UX, IBM i, Linux, Solaris, Windows, z/OS

Reference #: 1980668

Modified date: 09 July 2019