IBM Support

Install button for Data Studio is grayed out and cannot install even if the PC can connect to the internet

Question & Answer


Question

Why the Install button for Data Studio is grayed out and cannot install even if the PC can connect to the internet?

Cause

It is an known current DB2 limitation.

Answer

Here is an example, using a DB2 client. It is happens with any other listed DB2 product.
An example:
* Below steps would be expected to run at one machine which can connect to internet.
1. Goto latest fixpack download page:
DB2 Version 10.5 Fix Pack 6 for Linux, UNIX, and Windows
http://www-01.ibm.com/support/docview.wss?uid=swg24040522
-> Click "Windows 64bit" -> Click "IBM Data Server Client" -> Check the check box -> Click "Next" ->
2. Now, v10.5fp6_ntx64_client.exe is listed. -> Click the file name ->
Save it on your PC's temp space/folder.
* This step can verify the PC can connect to internet.
3. Click the downloaded file and unzip files in a temp space/folder.
4. Right click setup.exe and install it by Admin
5. DB2 setup launch pad is displayed -> Click "Install Data Studio Component"
6. In the right side window, "Install" button is grayed out even if the PC has an internet connection.
It says "No internet connection. Internet connection is required to install Data Studio." unexpectedly.

This is an known current DB2 limitation, the Install button is grayed out even if the PC can connect to the internet.
You may download and install in a separate way from one of below Related Information links as a workaround.

Note:
  This behavior might be changed without notice in the future. We can confirm whether this technote
is valid or not by following above example steps.
Please contact your Sales Rep to submit a potential design change towards a future release.
Or please open a ticket, Request For Enhancement at https://www.ibm.com/developerworks/rfe/

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Install\/Migrate\/Upgrade - Install\/Setup - GUI","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.7;10.1;10.5","Edition":"Advanced Enterprise Server;Advanced Workgroup Server;Enterprise Server;Workgroup Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21973517