IBM Support

Unable to navigate between tabs on IBM TRIRIGA Portfolio Data Manager (Application) and BIRT reports are not displaying any graph

Troubleshooting


Problem

After upgrading, it is not possible to see any graphs on previously working BIRT reports and when changing to any other tab of a IBM TRIRIGA Portfolio Data Manager (Application) record, the page will not change focus keeping the original tab.

Symptom

- Cannot navigate between tabs on IBM TRIRIGA Portfolio Data Manager records
- Cannot see any BIRT report graph information

Cause

IBM TRIRIGA TRIRIGAweb.properties file issue, with incorrect value format for FRONT_END_SERVER property (it does not have the FQDN for servername)

Resolving The Problem

For each one of your IBM TRIRIGA servers (JVMs) make sure the FRONT_END_SERVER property on the TRIRIGAweb.properties file will respect this input format: FRONT_END_SERVER=<Full Qualified Domain Name/FQDN + servername>:<port number>. Example: FRONT_END_SERVER=http://<MYSERVER>.<DOMAIN>.com:9080

When not entering the FQDN for the server name, application may not be able to route messages accordingly (cannot find correct path), so pages may present data rendering issues. This is a configuration issue.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application Platform","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21961806