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Cannot enable System Admin Mode in OpenPages because of a running process

Troubleshooting


Problem

An administrator in OpenPages cannot enable System Admin Mode because a process is running and needs to completed.

Cause

A process is either in an error start or has not been marked as being 100% completed.

Diagnosing The Problem

Running the following SQL will identify any running processes or processes that have not been marked as being 100% complete:

select name,
process_id,
decode(status, -4, 'Update Error',
0, 'Pending',
4, 'Started',
8, 'Running',
12, 'Finished: Error',
13, 'Terminated: system',
14, 'Terminated: user',
16, 'Finished',
'Unknown status') Status,
percent_completed
from op_processes where percent_completed!=100;

Resolving The Problem

Running the following SQL should resolved the issue:

update op_processes set is_multi_instance=process_id,
is_finished=process_id, status=13, percent_completed=100 where
percent_completed!=100;
commit;

[{"Product":{"code":"SSFUEU","label":"IBM OpenPages with Watson"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"5.5;6.0;6.0.1;6.0.1.1;6.0.1.2;6.0.1.3;6.0.1.4;6.0.1.5;6.1;6.1.0.1;6.2;6.2.1;7.0;7.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21903035