Troubleshooting
Problem
User launches Excel. User receives an error message.
Symptom
The file format and extension of 'adxloader.Controller.ExcelLink.dll' don't match. The file could be corrupted or unsafe. Unless you trust its source, don't open it. Do you want to open it anyway?
[Yes] [No] [Help]
NOTE:
- If the user clicks "No" then Excel opens normally.
If the user clicks "Yes", then a strange 'spreadsheet' is displayed:
This program cannot be run is DOS mode.
Cause
There are several different possible causes for this message.
- TIP: For more examples, see separate IBM Technote #2012271.
This Technote specifically relates to the scenario where the cause is that the client device has Excel 2013 64-bit installed, but you are trying to use Controller 10.2.1.
- Controller 10.2.1 does not support 64-bit versions of Excel.
More Information:
Strictly speaking, this problem/error is triggered by the following 'Add-in' file being ticked/enabled in Excel:
However, if you untick that box (which solves the error message) then (after using the 'main' Controller program CCR.EXE, for example when using Data Entry) the problem will return soon afterwards.
Environment
Client device using Excel 2013 64-bit.
Diagnosing The Problem
Inside Excel, click "File - Account". Then click on the button "About Excel".
- The version (32 or 64 bit) is displayed at the top:
Resolving The Problem
Fix:
Upgrade to Controller 10.3.0 (or later), which support 64-bit editions of some Excel versions.
Workaround:
Uninstall Microsoft Office 2013 64-bit from the client device, and then install Microsoft Office 2013 32-bit.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21883532