IBM Support

Error during TRIRIGA installation on Windows 2012 R2

Troubleshooting


Problem

Cannot install TRIRIGA 3.4.1 due to the following error message: Flexeraawy$aaa: Windows DLL failed to load

Symptom

Flexeraawy$aaa: Windows DLL failed to load
at Flexeraawy.af(Unknown Source)
at Flexeraawy.aa(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.init(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown
Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)

Cause

The TRIRIGA Installer was built using Flexera InstallAnywhere 2012. InstallAnywhere 2012 does not support Windows Server 2012 R2.

Resolving The Problem

It is necessary to run the installer in Windows 7 mode.
Right click on the installer, select Properties, click on the Compatibility tab, Click the box for Compatibility mode and and select to run in Windows 7.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"Version Independent","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
15 August 2018

UID

swg21883206