IBM Support

"SSL Error 61: You have not chosen to trust "DigiCert ..."" when launching Controller on Cloud, caused by old Citrix client

Troubleshooting


Problem

User launches Controller-on-Cloud. User receives an error.

Symptom

Windows PC:

Cannot connect to the Citrix XenApp server
SSL Error 61: You have not chosen to trust "DigiCert SHA2 Secure Server CA", the issuer of the server's security certificate.

Mac:

You have not chosen to trust "DigiCert SHA2 Secure Server CA", the issuer of the server's security certificate.
Contact your help desk for assistance.

Cause

There are several known causes of similar errors.

  • TIP: For more examples, see separate IBM Technote #0738725.

 

This Technote specifically relates to the scenario where the cause is that the user's client device is using an old (unsupported) Citrix client.

Resolving The Problem

Upgrade client device to the latest Citrix client (also known as 'Citrix Receiver' and 'Citrix ICA client').

 

TIP: At the time of writing, the current latest versions are:

  • Windows = Citrix Receiver 4.11
  • Mac = Citrix Receiver 12.9.1

 

Steps:

 

1. Browse to the Citrix client website

 

2. Choose your version (Windows or Mac)

 

 

3. Click on the relevant link, for example click "Download Receiver for Windows":


 

 

4. Run the downloaded file, and perform a default installation

 

5. Test.

Related information

THIRD PARTY - Citrix receiver download link
THIRD PARTY - CTX108800 Error: "SSL Error 61: You have
0738725 - ** Troubleshooting ** "You have not chosen to trust "DigiCert SHA2 Secure Server CA", the issuer of the server's security certificate" errors launching Controller on Cloud

Document information

More support for: Cognos Controller on Cloud

Component: Not Applicable

Software version: 10.2, 10.2.1

Operating system(s): Platform Independent

Reference #: 1700416

Modified date: 05 November 2018