Troubleshooting
Problem
Symptom
File Download
Do you want to save this file, or find a program online to open it?
Name: New Report.pdf
Type: Unknown File Type
From: <appserver>
Find Save Cancel
Cause
- Specifically, there is no PDF reader (PDF client) installed on the Cloud Citrix server. This limitation is caused by a third-party licensing issue.
Environment
Resolving The Problem
Fix:
Upgrade to Controller-on-Cloud version 10.4.1 (or later).
Method #1
If the user does not want to see the 'Do you want to save this file' message, then they can disable it by using the local preference 'StandardReportBackProc' (which stops the PDF rendition).
- TIP: See separate IBM Technote #1364719 for more details.
Method #2
If the end user wishes to read the report in a PDF file (for example inside Adobe Acrobat Reader) then they should save the PDF file locally (onto their desktop PC/laptop).
Steps:
1. When the message appears, click "Save"
2. Browse to your desktop/laptop PC's local hard drive
- TIP: You are looking for something similar to this:
You should recognise the name of your PC (in the example above, it is called 'VMCONT102').
- Ignore the other drive options that you may see.
3. The first time that you try this, you will then see a Citrix dialogue box similar to this:
- Tick "Do not ask me again for this site"
- Then click "Permit all access"
This is to enable the ability to save files (from the Cloud Citrix server) onto your local PC.
4. The file will now save onto your hard drive (in the place where you chose):
For example:
5. You can now double-click on that file, to open it inside your preferred PDF reader application (for example Adobe Reader):
Related Information
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Document Information
Modified date:
12 October 2021
UID
swg21699137