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Missing Portal integration components in Watson Content Analytics V3.5 fix packs

Question & Answer


Question

The embedded "PortletInstall.zip" is missing the "cluster_installPortlet" and the documentation for Portal integration in IBM Knowledge Center is not correct. Portal integration is having problems. Is there a fix for this?

Cause

The embedded installPortlet.sh/bat script within PortletInstall.zip in WCA 3.5 FP1 and FP2 is also defective. Please proceed with a manual install for a stand-alone or clustered system as described below.

Answer

Common error messages during unsuccessful Portal integration, due to a defective PortletInstall.zip, and LTPA SSO configuration will include, but is not limited to the following:

      "WSMSG07E: Missing WebSphere Portal Server root profile directory. Please specify a valid WebSphere Portal Server root profile directory with -WPSProfileDir"

      "Connection to the web client cannot be established by using the following URL: /ui"

      "Error 403: AuthorizationFailed"

      "FFQEP0002E: An error occurred when processing a remote API. The reason is : FFQQ0133E An error occurred while opening a connection to the servlet at host (host name) and port 8394"

      "An exception occurred when loading the predefined titles. Exception text = FFQQ0141E The search server at host <HOST NAME> and port <PORT #> could not process the request because the requested resource could not be found"

If you see any of the above errors, please open a PMR, and refer to this technote for optional added support. The portlet package will have to be manually installed. Please use the contents of PortletInstall.zip found in the "installables" folder within the WCA 3.5 FP2 installation directory. For Windows, the default location is C:\Program Files\IBM\es\bin\installables\PortletInstall.zip


Integrating WCA with WebSphere Portal system (WPS) for a stand-alone system (Manual install):

      1. Unzip PortletInstall.zip. We will use "commonui.ear" and "commonportlet.war" file later
      2. Start WebSphere_Portal instance if not running
      3. Open WAS administrative console for installed WPS. Typically it's hosted as "http://wps_host:10042/admin/"
      4. Open "WebSphere enterprise applications" page. Search installed "commonui" application. ("Show filter" is useful to find it). Please Note: If "commonui" is not found, follow steps 4.a and 4.b
        4.a Click "New Application" link under "Applications" section
        4.b Click "New Enterprise Application" and specify "commonui.ear" in the PortletInstall package
      5. Check the checkbox for "commonui" and click "Update" button. Proceed updating existing application with attached new "commonui.ear"
      6. After saving changes, then open WPS administrative console. Typically it's accessible after logging-in to "http://wps_host:10039/wps/portal" and then click "Administration" link in the toolbar.
      7. Open "Web modules" page under Portlet Management section. Search "commonportlet.war" file with Search box.
      8. Click "Update Web Module" button for the war file, specify new version of "commonportlet.war"

      After update, restart WebSphere_Portal instance.

      After updating modules, make sure following portlet properties are set correctly. You can check the properties at "Portlets" page. Search "portlet35" portlet at that page.

      ---
      adminRestHostName
      adminToken
      appName
      appType
      searchRestHostname



Integrating WCA with WebSphere Portal system (WPS) for a clustered system (Manual install):

    Please Note: The installation script (installPortlet.sh/bat) is not functioning correctly. Search portlet installation for a clustered environment, will have to be done manually.

      These instructions are written under the following conditions - Replace values with proper ones from your environments.

      WAS Dmgr node hostname: dmgrhost
      -> WAS administrative console URL: http ://dmgrhost:9060/ibm/console
      WAS Cluster name: PortalCluster

      WPS primary node: wps1host
      -> WPS portal URL: http ://wps1host:10039/wps/portal
      WPS secondary node: wps2host

      Abstract steps:
      1. Install commonui.ear into PortalCluster instance with WAS admin console
      2. Install commonporlet.war with WPS administrative console
      3. Restart PortalCluster instance to synchronize
      4. Set portlet properties to point WCA REST services
      5. Activate portlet war module
      6. Create a portlet page, and place "portlet35"

      Detailed steps:
      0. If you failed to install with "installPortlet.bat/sh" script previously, first uninstall installed portlet with "uninstallPortlet.sh/bat"
      1. Prepare "PortletInstall.zip" package of WCA 3.5 FP2, unzip it on some directory.
      2. Log in to WAS administrative console of dmgrhost, click "New Application" link under "Applications" section.
      3. Click "New Enterprise Application" and specify "commonui.ear" in the PortletInstall package.
      4. Proceed installation steps with default values. Don't forget to map the module to "PortalCluster" instance. If you want to use IHS, also map it to webserver1.
      5. After save changes, go to WPS administrative console of wps1host.
      6. Go to "Web Modules" page under "Portlet Management" section. Press "Install" button and specify "commonportlet.war" module in the PortletInstall package.
      7. Click "Next" to proceed steps.
      8. Go to WAS administrative console of dmgrhost, go to "WebSphere application server clusters" under "Clusters" under "Servers" section.
      9. Stop PortalCluster, and after it stopped, then restart PortalCluster.
      10. Then go back to WPS administrative console, access "Portlets" page. Search "portlet35" portlet. Click wrench icon to configure properties of it.
      11. Enter correct values to "adminRestHostName", "searchRestHostName" in order to point WCA server.
      12. After save changes, go to "Web Modules" page. Search "commonportlet.war". If it is in a stopped state, click "Activate" button for the module.
      13. Go to "Manage Pages" under "Portal User Interface" section.
      14. Create a page in order to deploy WCA portlet. For example, I created "Test1" page under "Content Root".
      15. Edit layout of the created page. Put "portlet35" portlet in it.

      If installation is successfully done, you will see WCA portlet working.



OPTIONAL: If configuring LTPA SSO between WPS and WCA please do the following:
      Assuming the same LDAP server is used for WPS's federated repository and WCA's login configuration.

      1. At WPS's WAS administrative console:
        a) Set LTPA cookie domain (example: I set "user1.ibm.com")
        b) Remember realm name (example: if Federated repository is used, it may be "defaultWIMFileBasedRealm")
        c) Export LTPA key to somewhere (example: I exported it as C:\work\wpsltpa.key)
      2. At WCA administrative console's login security screen
        a) Import LTPA key just exported
        b) Set LTPA cookie domain with same value
        c) Set "LDAP realm name" as same value in WPS's WAS administrative console ("defaultWIMFileBasedRealm")
      3.Restart WCA and WPS

      NOTE:
      There have been cases when importing the LTPA key into WCA from WAS causes errors even though that same key works in other systems. If you run into this problem, try the following:
          You need to have a "keystore" file on the WCA server. This is also considered as a container of keys. So you have to have this file first regardless of what it contains.

          To do that:
          1. Press the "Generate Key" button to create a new keystore. (See screenshot below)
          2. Then after the keystore file exists on WCA, you can import the keys from WAS as expected using the import keys button.

Related Information

[{"Product":{"code":"SS5RWK","label":"Content Analytics with Enterprise Search"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"3.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21697178