IBM Support

Security Bulletin: Multiple vulnerabilities in IBM Java SDK and IBM Java Runtime Technology Edition affect Rational Functional Tester (CVE-2014-3065, CVE-2014-3566, CVE-2014-6511)

Security Bulletin


Summary

There are multiple vulnerabilities in IBM SDK Java Technology Edition, Version 7 and IBM Runtime Environment Java Technology Edition, Version 7 that is used by IBM Rational Functional Tester. This also includes a fix for the Padding Oracle On Downgraded Legacy Encryption (POODLE) SSLv3 vulnerability (CVE-2014-3566). These were disclosed as part of the IBM Java SDK updates in October 2014.

Vulnerability Details

CVEID: CVE-2014-3065
Description: IBM Java SDK contains a vulnerability in which the default configuration for the shared classes feature potentially allows arbitrary code to be injected into the shared classes cache, which may subsequently be executed by other local users.

CVSS Base Score: 6
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/93629 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:L/AC:H/Au:S/C:C/I:C/A:C)


CVEID: CVE-2014-3566

Description: Product could allow a remote attacker to obtain sensitive information, caused by a design error when using the SSLv3 protocol. A remote user with the ability to conduct a man-in-the-middle attack could exploit this vulnerability via a POODLE (Padding Oracle On Downgraded Legacy Encryption) attack to decrypt SSL sessions and access the plaintext of encrypted connections.

CVSS Base Score: 4.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/97013 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:N/C:P/I:N/A:N)


CVEID: CVE-2014-6511

Description: An unspecified vulnerability in Oracle Java SE related to the 2D component could allow a remote attacker to obtain sensitive information.

CVSS Base Score: 5
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/97140 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:L/Au:N/C:P/I:N/A:N)

Affected Products and Versions

Rational Functional Tester version 8.0 and later.

Remediation/Fixes

Vendor Fixes:

Product Version APAR Remediation/First fix
RFT 8.6.0 - 8.6.0.x None Download the IBM SDK, Java Technology Edition, Version 7 Service Refresh 8 iFix from the Fix Central.
RFT 8.5.1 - 8.5.1.x None Download the IBM SDK, Java Technology Edition, Version 7 Service Refresh 8 iFix from the Fix Central.
RFT 8.5.0 - 8.5.0.x None Download the IBM SDK, Java Technology Edition, Version 7 Service Refresh 8 iFix from the Fix Central.
RFT 8.3.0 - 8.3.0.x None Download the IBM SDK, Java Technology Edition, Version 7 Service Refresh 8 iFix from the Fix Central.
RFT 8.2.0 - 8.2.x - 8.2.2.x None Download the IBM SDK, Java Technology Edition, Version 6 Service Refresh 17 iFix from the Fix Central.
RFT 8.1.0 - 8.1.x - 8.1.x.x None Download the IBM SDK, Java Technology Edition, Version 6 Service Refresh 17 iFix from the Fix Central.
RFT 8.0.0 - 8.0.x - 8.0.x.x None Download the IBM SDK, Java Technology Edition, Version 6 Service Refresh 17 iFix from the Fix Central.

Note: If you are unable to upgrade, contact IBM Support.

Workarounds and Mitigations

IBM recommends that you review your entire environment to identify areas that enable the SSLv3 protocol and take appropriate mitigation and remediation actions. The most immediate mitigation action that can be taken is disabling SSLv3. You should verify disabling SSLv3 does not cause any compatibility issues.


Until the fixes are applied, ensure that RFT is not accessible from the Internet.

Get Notified about Future Security Bulletins

References

Complete CVSS v2 Guide
On-line Calculator v2

Related information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

Acknowledgement

None

Change History

Published 2015/03/23

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document information

More support for: Rational Functional Tester
General Information

Software version: 8.2, 8.2.0.1, 8.2.0.2, 8.2.1, 8.2.1.1, 8.2.2, 8.2.2.1, 8.3, 8.3.0.1, 8.3.0.2, 8.5, 8.5.0.1, 8.5.1, 8.5.1.1, 8.5.1.2, 8.5.1.3, 8.6, 8.6.0.1

Operating system(s): Linux, Windows

Reference #: 1693297

Modified date: 23 March 2015