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What could explain an ARS1127E error in Content Manager OnDemand for i server level 8.5 or above, when archiving German data?

Question & Answer


Question

I'm seeing a new error now on V7.1 server level 9.0.0.1 of Content Manager OnDemand for i when archiving an SCS report that has always archived successfully in the past. I came from server level 8.4.1.7 on R6.1. The spooled file I'm archiving has German data, although the instance is U.S. English. The indexing process works fine and completes successfully but the load fails with the following errors: ARS4315I Processing file >/QIBM/USERDATA/ONDEMAND/QUSROND/TMP/SP_QPRT198_RDARSMRGD_QPGMR_846699_000002_QUERY_1140504_130800< ARS4334I Load Version <9.0.0.3>  Operating System <7.1>  OS Userid   Install Location ARS4335I Server Version <9.0.0.3>  Operating System <7.1>  Database <07010> ARS4302I 05/07/14 12:32:25 -- Indexing started, --UNKNOWN-- bytes to process ARS4308I 05/07/14 12:32:27 Indexing completed ARS4312I 05/07/14 12:32:27 -- Loading started, 7186787 bytes to process ARS1127E Row 118:  The string "GROSS*  BJÖRN*   " has a length of 17 and the field has a maximum length of 16 ARS1144I OnDemand Load Id = >5033-2-0-2FAA-20140430000000-20140430000000-5034< ARS1133I The last row successfully loaded was 117 ARS1146I Loaded 117 rows into the database ARS4311E 05/07/14 12:32:29 Loading failed ARS4318E Processing failed for file >/QIBM/USERDATA/ONDEMAND/QUSROND/TMP/SP_QPRT198_RDARSMRGD_QPGMR_846699_000002_QUERY_1140504_130800< ARS4320I 05/07/14 12:32:29 -- Unloading started ARS1184I OnDemand UnLoad Successful - LoadId(5033-2-0-2FAA-20140430000000-20140430000000-5034) Rows Deleted(117) ARS4321I 05/07/14 12:32:30 -- Unloading of data was successful               

Cause

There was a change in server level 8.5 to use ICU's upper casing.  This caused a change that affects German and specifically the German character 'ß'.  After 8.5, it upper cases that character to 'SS' so the string 'GROß*  BJÖRN* ' turns into 'GROSS*  BJÖRN*'  which expands the field. 

Answer

There are many ways this can be dealt with:
 
1. Change the String case for the field to be "Mixed" in the application group definition on the "Field Information" tab.
2. Change the String maximum length for the field to allow for this length expansion.
3. Change the String maximum length for the field and make it variable rather than fixed length.
 
The three options above require a new application group to be created.
 
4. Looking at the data, most names are shorter than the maximum length, so you could change the application definition to remove trailing blanks.
 
Or
 
You can add this line to the ars.cfg file for the server

ARS_USE_OLD_STYLE_CASE=1
 
This will force the server to use the old style upper casing which will also fix the problem. After adding this line to the ARS.CFG, the instance must be ended and restarted to make the change take effect.
 

If this information does not address your question, contact IBM software support for further assistance.


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Document Information

Modified date:
17 June 2018

UID

swg21673461