Question & Answer
Question
I'm seeing a new error now on V7.1 server level 9.0.0.1 of Content Manager OnDemand for i when archiving an SCS report that has always archived successfully in the past. I came from server level 8.4.1.7 on R6.1. The spooled file I'm archiving has German data, although the instance is U.S. English. The indexing process works fine and completes successfully but the load fails with the following errors:
ARS4315I Processing file >/QIBM/USERDATA/ONDEMAND/QUSROND/TMP/SP_QPRT198_RDARSMRGD_QPGMR_846699_000002_QUERY_1140504_130800<
ARS4334I Load Version <9.0.0.3> Operating System
Cause
There was a change in server level 8.5 to use ICU's upper casing. This caused a change that affects German and specifically the German character 'ß'. After 8.5, it upper cases that character to 'SS' so the string 'GROß* BJÖRN* ' turns into 'GROSS* BJÖRN*' which expands the field.
Answer
There are many ways this can be dealt with:
1. Change the String case for the field to be "Mixed" in the application group definition on the "Field Information" tab.
2. Change the String maximum length for the field to allow for this length expansion.
3. Change the String maximum length for the field and make it variable rather than fixed length.
The three options above require a new application group to be created.
4. Looking at the data, most names are shorter than the maximum length, so you could change the application definition to remove trailing blanks.
Or
You can add this line to the ars.cfg file for the server
ARS_USE_OLD_STYLE_CASE=1
This will force the server to use the old style upper casing which will also fix the problem. After adding this line to the ARS.CFG, the instance must be ended and restarted to make the change take effect.
If this information does not address your question, contact IBM software support for further assistance.
Stay Informed by Receiving Product and Lifecycle Notifications:
Click here
Related Information
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21673461