IBM Support

IBM Spectrum Protect™ for Virtual Environments: Data Protection for VMware data mover compatibility guide with VMware's Virtual Disk Development Kit

Troubleshooting


Problem

The Data Protection for VMware data mover utilizes VMware's Virtual Disk Development Kit (VDDK) API's to open, close, read and write virtual disk data (VMDKs). The tables below correlate the data mover versions with the VDDK versions and the supported data mover operating systems. Before you deploy a data mover, consult the tables below to determine which VDDK version it works with and which operating system it can be installed on. Installing the data mover on unsupported or untested operating system might work, but no support can be provided. Also use caution when upgrading a data mover to a newer version. In some cases VMware has dropped support for a operating system moving from one VDDK release to the next release. Lastly, also notice that the vCenter Server and ESXi host versions that are supported by each VDDK version are provided. Starting with VDDK 5.5 VMware issued a new support policy, see the table below.

Cause

None

Environment

IBM Spectrum Protect™ data mover for virtual environments

Diagnosing The Problem

See the tables in "Resolving the problem" section for a mapping between the data mover version and VMware's VDDK version and supported data mover operating systems.

Resolving The Problem

This document is intended to provide useful details regarding supported vSphere and operating system versions for VMware VDDK SDK. The tables below list the operating systems that are required to be used on the server where you install the data mover and the vCenter Server/ESXi versions. The tables also provide links to the most recent VMware VDDK release notes.

Attention:  The IBM Spectrum Protect™ for Virtual Environments hardware and software requirements documents are the official source for information on supported versions and supersede the supported vSphere and OS versions listed in VDDK release notes. Use the this Hardware and Software Requirements technote as the definitive guide when determining hardware and software requirements for Data Protection for VMware. Links to these documents can be found in the "IBM Spectrum Protect™ for Virtual Environments - All Requirements Doc"  http://www.ibm.com/support/docview.wss?uid=swg21505139

Tip: Beginning with Version 7.1.3, IBM Tivoli Storage Manager for Virtual Environments is now IBM Spectrum Protect for Virtual Environments. Some applications such as the software fulfillment systems and IBM License Metric Tool use the new product name. However, the software and its product documentation continue to use the Tivoli Storage Manager product name. To learn more about the rebranding transition, see http://www.ibm.com/support/docview.wss?uid=swg21963634.

Attention: ESXi 5.1 hosts must be at Update 3 or newer patch or update level. ESXi 5.5 hosts must be at Patch 4 or newer patch or update level. These prerequisite levels address a critical VMware Changed Block Tracking (CBT) integrity issue described in VMware KB http://kb.vmware.com/kb/2090639

Attention: VDDK 6.0.1 limitation using SAN in the VMware's Release Notes:
https://www.vmware.com/support/developer/vddk/vddk-601-releasenotes.html

Attention:  VDDK 6.7.0 EP1 Update 1 includes the hot patch which corrects the known issue "NBD transport in VDDK 6.7 is slow when running against vSphere 6.5" listed in the VDDK 6.7.0 EP1 release notes.


"Backup and restore using SAN transport fails with VDDK 6.0.1 for VMs residing on ESXi 5.5 or earlier. When VDDK 6.0.1 connects to an ESXi 5.5.x host using SAN transport, and tries to retrieve the virtual machine MoRef from the snapshot managed object, the operation fails with the vmodl.fault.InvalidRequest error. This backward compatibility failure is due to changes in the getVM method between vSphere 5.5, 6.0, and 6.0.1. The work around is to use non-SAN transport when connecting to ESXi 5.5 and earlier hosts. A fix has been identified and will appear in a future release." See IBM APAR IT12942. (This is fixed in VDDK 6.0.2 and above.)



IBM Spectrum Protect Data Mover 8.1.7

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 8.1.7 based on VDDK 6.7.1 "Virtual Disk Development Kit (VDDK) 6.7.1 released with vSphere 6.7 Update 1 is a bug-fix update. This VDDK release is backward compatible with vSphere 6.0, vSphere 6.5, and vSphere 6.7.  ESXi hosts and especially pre-6.7 vCenter Server should be upgraded in conjunction with VDDK libraries." Windows Server 2012, 2012 R2 and 2016
Red Hat Enterprise Linux RHEL 6.7, 6.8, 6.9, 7.2 and 7.3
CentOS 7.4
SUSE Linux Enterprise Server SLES 11 SP4, 12 SP1 and 15
VDDK 6.7.1 Release Notes



IBM Spectrum Protect Data Mover 8.1.6

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 8.1.6 based on VDDK 6.7.0.EP1 Update 1 "Virtual Disk Development Kit (VDDK) 6.7.0 EP1 Update 1 released with vSphere 6.7.0 is a bug-fix update. This VDDK release is backward compatible with vSphere 6.0, vSphere 6.5, vSAN 6.6, vSAN 6.6.1, and vSphere 6.7.  ESXi hosts and especially pre-6.7 vCenter Server should be upgraded in conjunction with VDDK libraries." Windows Server 2012, 2012 R2 and 2016
Red Hat Enterprise Linux RHEL 6.7, 6.8, 7.2 and 7.3
SUSE Linux Enterprise Server SLES 11 SP4 and 12 SP1
VDDK 6.7.0 EP1 Update 1 Release Notes



IBM Spectrum Protect Data Mover 8.1.4

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 8.1.4 based on VDDK 6.5.2 "Virtual Disk Development Kit (VDDK) 6.5.2 released with vSphere 6.5.2 is a bug-fix update and has the same compatibility as version 6.5" Windows Server 2012, 2012 R2 and 2016
Windows 10
Red Hat Enterprise Linux RHEL 6.7, 6.8, 7.2 and 7.3
SUSE Linux Enterprise Server SLES 11 SP4 and 12 SP1



IBM Spectrum Protect Data Mover 8.1.2/8.1.0.2

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 8.1.2/8.1.0.2 based on VDDK 6.0.3 "Virtual Disk Development Kit (VDDK) 6.0.3 released with vSphere 6.0 U3 is a bug-fix update and has the same compatibility as version 6.0" Windows Server 2012 and 2012 R2
Red Hat Enterprise Linux RHEL 6.6 & 7.0
SUSE Linux Enterprise Server SLES 11.3 & 12



IBM Spectrum Protect Data Mover 8.1.0

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 8.1 based on VDDK 6.0.2 "Virtual Disk Development Kit (VDDK) 6.0.2 released with vSphere 6.0 U2 is a bug-fix update and has the same compatibility as version 6.0" Windows Server 2012 and 2012 R2
Red Hat Enterprise Linux RHEL 6.6 & 7.0
SUSE Linux Enterprise Server SLES 11.3 & 12



IBM Spectrum Protect Data Mover 7.1.8.4

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.8.4 based on VDDK 6.7.0.EP1 Update 1 "Virtual Disk Development Kit (VDDK) 6.7.0 EP1 Update 1 released with vSphere 6.7.0 is a bug-fix update."  The 7.1.8.4 Data Move supports vSphere 6.0 and 6.5. Windows Server 2008 R2, 2012, 2012 R2 and 2016
Linux RHEL 6.7, 6.8, 7.2 and 7.3
SUSE Linux Enterprise Server SLES 11 SP4 and 12 SP1
VDDK 6.7.0 EP1 Update 1 Release Notes



IBM Spectrum Protect Data Mover 7.1.8.2

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.8.2 based on VDDK 6.5.2 EP1 "Virtual Disk Development Kit (VDDK) 6.5.2 EP1 released with vSphere 6.5.2 EP1 is a bug-fix update and has the same compatibility as version 6.5" Windows Server 2008 R2
Windows Server 2012 and 2012 R2
Windows Server 2016
Red Hat Enterprise Linux RHEL 6.7, 6.8, 7.2 & 7.3
SUSE Linux Enterprise ServerSLES 11 SP4 and 12 SP1



IBM Spectrum Protect Data Mover 7.1.8

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.8 based on VDDK 6.5.1 "Virtual Disk Development Kit (VDDK) 6.5.1 released with vSphere 6.5 U1 is a bug-fix update and has the same compatibility as version 6.5" Windows Server 2008 R2
Windows Server 2012 and 2012 R2
Windows Server 2016
Red Hat Enterprise Linux RHEL 6.7, 6.8, 7.2 & 7.3
SUSE Linux Enterprise ServerSLES 11 SP4 and 12 SP1



IBM Spectrum Protect Data Mover 7.1.6.5

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.6.5 based on VDDK 6.0.3 "Virtual Disk Development Kit (VDDK) 6.0.3 released with vSphere 6.0 U3 is a bug-fix update and has the same compatibility as version 6.0" Windows Server 2008 R2
Windows Server 2012 and 2012 R2
Red Hat Enterprise Linux RHEL 6.6 & 7.0
SUSE Linux Enterprise Server SLES 11.3 & 12



IBM Spectrum Protect Data Mover 7.1.6

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.6 based on VDDK 6.0.2 "Virtual Disk Development Kit (VDDK) 6.0.2 released with vSphere 6.0 U2 is a bug-fix update and has the same compatibility as version 6.0" Windows Server 2008 R2
Windows Server 2012 and 2012 R2
Red Hat Enterprise Linux RHEL 6.6 & 7.0
SUSE Linux Enterprise Server SLES 11.3 & 12



IBM Spectrum Protect Data Mover 7.1.4/7.1.3.2

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.4/7.1.3.2 based on VDDK 6.0.1 "Virtual Disk Development Kit (VDDK) 6.0.1 released with vSphere 6.0 U1 is a bug-fix update and has the same compatibility as version 6.0" Windows Server 2008 R2
Windows Server 2012 and 2012 R2
Red Hat Enterprise Linux RHEL 6.6, and 7.0
SUSE Linux Enterprise Server SLES 11.3 & 12



IBM Spectrum Protect Data Mover 7.1.3/7.1.2

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.3/7.1.2 based on VDDK 6.0 "VDDK 6.0 adds support for vSphere 6.0 (vCenter 6.0 and ESXi 6.0), and was tested for backwards compatibility with vSphere 5.5 and 5.1" Windows Server 2008 R2
Windows Server 2012 and 2012 R2
Red Hat Enterprise Linux RHEL 6.6, and 7.0
SUSE Linux Enterprise Server SLES 11.3 & 12



Tivoli Storage Manager Data Mover 7.1.1.3

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.1.3 based on VDDK 5.5.3 "The VMware policy concerning backward and forward compatibility is for VDDK to support N-2 and N+1 releases. In other words, VDDK 5.5 and all of its update releases support vSphere 5.0, 5.1, 5.5 and vSphere next (except new features)".

Note: Tivoli Storage Manager does not support vSphere 5.0
Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 5.9, 6.2, and 6.3
SUSE Linux Enterprise Server SLES 11.2



Tivoli Storage Manager Data Mover 7.1.1

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.1 based on VDDK 5.5.2 "The VMware policy concerning backward and forward compatibility is for VDDK to support N-2 and N+1 releases. In other words, VDDK 5.5 and all of its update releases support vSphere 5.0, 5.1, 5.5 and vSphere next (except new features)".

Note: Tivoli Storage Manager does not support vSphere 5.0
Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 5.9, 6.2, and 6.3
SUSE Linux Enterprise Server SLES 11.2



Tivoli Storage Manager Data Mover 7.1.0.3

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.0.3 based on VDDK 5.5.1 "The VMware policy concerning backward and forward compatibility is for VDDK to support N-2 and N+1 releases. In other words, VDDK 5.5 and all of its update releases support vSphere 5.0, 5.1, 5.5 and vSphere next (except new features)".

Note: Tivoli Storage Manager does not support vSphere 5.0
Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 5.9, 6.2, and 6.3
SUSE Linux Enterprise Server SLES 11.2



Tivoli Storage Manager Data Mover 7.1.0.2/7.1.0

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 7.1.0/7.1.0.2 based on VDDK 5.5 "The VMware policy concerning backward and forward compatibility is for VDDK to support N-2 and N+1 releases. In other words, VDDK 5.5 and all of its update releases support vSphere 5.0, 5.1, 5.5 and vSphere next (except new features)".

Note: Tivoli Storage Manager does not support vSphere 5.0
Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 5.9, 6.2, and 6.3
SUSE Linux Enterprise Server SLES 11.2



Tivoli Storage Manager Data Mover 6.4.3.2

Release vCenter/ESXi Support Proxy OS (data mover)
Data Mover 6.4.3.2 based on VDDK 5.5.5 "The VMware policy concerning backward and forward compatibility is for VDDK to support N-2 and N+1 releases. In other words, VDDK 5.5 and all of its update releases support vSphere 5.0, 5.1, 5.5 and vSphere next (except new features)".

Note: Tivoli Storage Manager does not support vSphere 5.0
Important: Only 64 bit operating systems are supported with VDDK 5.5.x.

Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 5.9, 6.2, and 6.3
SUSE Linux Enterprise Server SLES 11.2


Note: Older VMware support policy is in effect from here down.



Tivoli Storage Manager Data Mover 6.4.3/6.4.2.1

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.4.3 & 6.4.2.1 based on VDDK 5.1.3 vCenter & ESXi 5.1 U3 are required due to Change Block Tracking defect. Older versions are not recommended. ESXi 5.1 U3
ESXi 5.1 U2
ESXi 5.1 U1
ESXi 5.1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
Windows Server 2008
Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 6.1 and 6.2 (ext4 file system)
SUSE Linux Enterprise Server SLES 11 SP2 (ext3 file system)
vCenter Server 5.1 U2
vCenter Server 5.1 U1
ESXi 5.1 U2
ESXi 5.1 U1
ESXi 5.1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
vCenter Server 5.1b ESXi 5.1 U1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
vCenter Server 5.0 U2 ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
Unmanaged hosts ESXi 5.1 U2
ESXi 5.1 U1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4



Tivoli Storage Manager Data Mover 6.4.2

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.4.2 based on VDDK 5.1.2 vCenter & ESXi 5.1 U3 are required due to Change Block Tracking defect. Older versions are not recommended. ESXi 5.1 U2
ESXi 5.1 U1
ESXi 5.1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
Windows Server 2008
Windows Server 2008 R2
Windows Server 2012
Red Hat Enterprise Linux RHEL 6.1 and 6.2 (ext4 file system)
SUSE Linux Enterprise Server SLES 11 SP2 (ext3 file system)
vCenter Server 5.1 U2
vCenter Server 5.1 U1
ESXi 5.1 U2
ESXi 5.1 U1
ESXi 5.1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
vCenter Server 5.1b ESXi 5.1 U1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
vCenter Server 5.0 U2 ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
Unmanaged hosts ESXi 5.1 U2
ESXi 5.1 U1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4



Tivoli Storage Manager Data Mover 6.4.1

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.4.1 based on VDDK 5.1.1 vCenter Server 5.1 U1 ESXi 5.1 U1
ESXi 5.1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
Windows Server 2008
Windows Server 2008 R2
Red Hat Enterprise Linux RHEL 6.1 and 6.2 (ext4 file system)
SUSE Linux Enterprise Server SLES 11 SP2 (ext3 file system)
vCenter Server 5.1b ESXi 5.1 U1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
vCenter Server 5.0 U2 ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4
Unmanaged hosts ESXi 5.1 U1
ESXi 5.0 U2
ESX/ESXi 4.1 U3
ESX/ESXi 4.0 U4



Tivoli Storage Manager Data Mover 6.4.0

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.4.0 based on VDDK 5.0.1 vCenter Server 5.0 ESXi 5.0
ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
Windows Server 2008
Windows Server 2008 R2
Windows 7
Red Hat Enterprise Linux (RHEL) 5.3, 5.4, and 5.5
SUSE Linux Enterprise Server (SLES) 10 and 11
vCenter Server 4.1 ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
vCenter Server 4.0 ESX/ESXi 4.0
ESX/ESXi 3.5
Unmanaged hosts ESXi 5.0
ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5



Tivoli Storage Manager Data Mover 6.3.3/6.3.2.2/6.3.2/6.3.1

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.3.3/ 6.3.2/6.3.1 based on VDDK 5.0.1 & Tivoli Storage Manager 6.3.2.2 is based on VDDK 5.0.4 vCenter Server 5.0 ESXi 5.0
ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
Windows XP SP3
Windows Server 2003 R2
Windows Server 2008
Windows Server 2008 R2
Windows 7
Red Hat Enterprise Linux (RHEL) 5.3, 5.4, and 5.5
SUSE Linux Enterprise Server (SLES) 10 and 11
vCenter Server 4.1 ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
vCenter Server 4.0 ESX/ESXi 4.0
ESX/ESXi 3.5
Unmanaged hosts ESXi 5.0
ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5



Tivoli Storage Manager Data Mover 6.3.0

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.3.0 based on VDDK 5.0.0 vCenter Server 5.0 ESXi 5.0
ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
Windows XP SP3
Windows Server 2003 R2
Windows Server 2008
Windows Server 2008 R2
Windows 7
Red Hat Enterprise Linux (RHEL) 5.3, 5.4, and 5.5
SUSE Linux Enterprise Server (SLES) 10 and 11
vCenter Server 4.1 ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
vCenter Server 4.0 ESX/ESXi 4.0
ESX/ESXi 3.5
Unmanaged hosts ESXi 5.0
ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5



Tivoli Storage Manager Data Mover 6.2.5/6.2.4/6.2.3/6.2.2

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.2.5/ 6.2.4/6.2.3/6.2.2 based on VDDK 1.2.1 vCenter Server 4.1 ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
Windows XP SP3
Windows Server 2003 R2
Windows Server 2008
Windows Server 2008 R2
Windows 7
Red Hat Enterprise Linux (RHEL) 5
SUSE Linux Enterprise Server (SLES) 10
vCenter Server 4.0 ESX/ESXi 4.0
ESX/ESXi 3.5
Unmanaged hosts ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5



Tivoli Storage Manager Data Mover 6.2.1/6.2.0

Release vCenter/ESXi Support Managing hosts of version Proxy OS (data mover)
Data Mover 6.2.1/6.2.0 based on VDDK 1.1.1 vCenter Server 4.1 ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5
Windows Server 2003 SP 2
Windows Server 2008 SP 1
Windows XP SP 2
Red Hat Enterprise Linux (RHEL) 5
SUSE Linux Enterprise Server (SLES) 10
vCenter Server 4.0 ESX/ESXi 4.0
ESX/ESXi 3.5
Unmanaged hosts ESX/ESXi 4.1
ESX/ESXi 4.0
ESX/ESXi 3.5

Related information

All Requirements Doc
SP Featured doc

Historical Number

1.0v

Document information

More support for: IBM Spectrum Protect for Virtual Environments

Component: Data Protection for VMware

Software version: All Versions

Operating system(s): Linux, Windows

Software edition: All Editions

Reference #: 1672351

Modified date: 14 March 2019