Troubleshooting
Problem
When you run the bootstrapProcessServerData.sh command, you get Ant Task and bootstrap errors in the wsadmin.traceout file.
Symptom
You might see the following messages:
[3/24/14 16:57:55:754 EDT] 00000001 AntTasksHelpe I cellUserName:
wasadmin
[3/24/14 16:57:55:767 EDT] 00000001 AntTasksHelpe I UserId could not be
retrieved, Either DeAdmin role is not set or Cell Admin role is not set
[3/24/14 16:57:55:767 EDT] 00000001 AntTasksHelpe I UserIds:
[3/24/14 16:57:55:768 EDT] 00000001 AntTasksHelpe I UserName: bpmadmin
[3/24/14 16:57:55:769 EDT] 00000001 BootstrapHelp I File
/opt/websphere85/appserver/BPM/Lombardi/imports/system-toolkit.twx
failed.....
[3/24/14 16:57:55:770 EDT] 00000001 BootstrapHelp I Index: 0, Size: 0
[3/24/14 16:57:55:771 EDT] 00000001 BootstrapHelp E
java.lang.IndexOutOfBoundsException:
Index: 0, Size: 0
Cause
The databases were not created correctly.
Diagnosing The Problem
Check the LSW_USR_XREF table to view the users. Based on the error messages in the Symptom section, the user named bpmadmin is missing. Also the tw* users should have been deleted. The following code shows the users:
oradba@dfrd10>select * from AIM_PROCCESS_PS85.LSW_USR_XREF;
USER_ID USER_NAME FULL_NAME PROVIDER
---------- ----------------------------------------
--------------------------------------------------
--------------------------------------------------
1 wasadmin wasadmin
2 tw_author tw_author
3 tw_user tw_user
4 tw_webservice tw_webservice
5 tw_portal_admin tw_portal_admin
6 tw_runtime_server tw_runtime_server
7 bpm_author bpm_author
Resolving The Problem
Recreate the databases and check the LSW_USR_XREF table to make sure that the appropriate users exist. For information on creating users for Oracle databases, see Installing and configuring IBM Business Process Manager Advanced with an Oracle database server.
Product Synonym
BPM
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Document Information
Modified date:
15 June 2018
UID
swg21669424