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A "FFDC: java.io.FileNotFoundException server-core.xml" exception occurs for IBM Business Process Manager (BPM) and the system cannot find the specified file

Troubleshooting


Problem

For IBM Business Process Manager V8.5, an FFDC file is generated on the IBM Business Process Manager application target cluster. The FFDC file states that the system cannot find the server-core.xml file.

Symptom

A FFDC file is generated and the FileNotFoundException exception for the server-core.xml file is logged in the SystemOut.log file of the application target cluster. You might see the following messages:

java.io.FileNotFoundException: C:\Program Files\IBM\WebSphere\ESB\profiles\Dmgr01\config\cells\bonbonCell01\nodes\
bonbonCellManager01\servers\dmgr\server-core.xml (The system cannot find
the file specified.)
   at java.io.FileInputStream.<init>(FileInputStream.java:124)
   at
org.eclipse.emf.ecore.resource.impl.URIConverterImpl.createFileInputStre
am(URIConverterImpl.java:469)
   at
org.eclipse.emf.ecore.resource.impl.URIConverterImpl.createInputStream(U
RIConverterImpl.java:431)
   at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:
897)
   at
org.eclipse.wst.common.internal.emf.resource.CompatibilityXMIResourceImp
l.load(CompatibilityXMIResourceImpl.java:259)
   at
com.ibm.websphere.resource.WASResourceImpl.load(WASResourceImpl.java:286)

...

Note: The path to the server-core.xml file depends on the profile name and location. Thus, the text might differ from the previous messages. This error message does not have any impact on the system. You can safely ignore it.

Cause

A possible reason for this behavior is the Service Component Architecture (SCA) feature is not available after the creation of a deployment environment. The following points are an example scenario:

  • A deployment manager profile and a node profile are generated. However, no other configuration changes were applied.
  • An Advanced Deployment Environment for IBM Business Process Manager is being configured. This configuration also includes the SCA capability.
  • At this point of time, the SCA capability must be available. However, it is not available until you restart the servers.
Therefore, the FileNotFoundException error might be logged together with a generation of a related FFDC file because the SCA capability is not yet available.

Diagnosing The Problem

An error is seen in the SystemOut.log file of the application target cluster.

Resolving The Problem

You can ignore the FFDC file as it does not have any impact.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Service Component Architecture (SCA)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5.0.1;8.5","Edition":"Not Applicable","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21662337