IBM Support

ODBC - Login failed for user

Troubleshooting


Problem

When trying to create an odbc connection in architect or running a TI Process, getting the below error.

Symptom

7152 [e] ERROR 2013-12-30 19:03:04.966 TM1.SQLAPI 28000
[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user
'domain\servername'.
7152 [e] ERROR 2013-12-30 19:03:04.966 TM1.SQLAPI E16) Cannot
connect to ODBC data source "name" 28000[Microsoft][ODBC SQL Server
Driver][SQL Server]Login failed for user 'domain\servername'..

Cause

The tm1server was running as local system account and not as a named account.

Resolving The Problem

Go to your services and change your tm1server from local system account to a named account (logon as ) and restart your tm1server.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.0;10.1.1;10.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21661092