Troubleshooting
Problem
Upgrade has been done or customer moves data to another machine. Users can't see the server in Architect/Perspectives.
Symptom
Service will not start - it appears to start and then comes right back down - this is why users aren't seeing it.
There will be an error similar to this in the tm1server.log:
2196 [] FATAL 2013-10-28 17:52:04.187 TM1.Transaction
TM1TransactionLog::ProcessTransactionLog: Bad transaction log record,
line number 1.
2196 [] FATAL 2013-10-28 17:52:04.187 TM1.Server Server
terminated
Cause
The TM1 service may not have been shut down completely prior to copying the model, so that the Save Data did not commit the data in the transaction log, hence leaving it non-empty.
Resolving The Problem
Delete/rename the tm1s.log. If it is empty or only has a few things in it, this is no issue.
If there is a lot of data that needs to be recovered, it can be brought in via a TI process. Or possibly just by re-running existing processes that import data from another source.
If this happens repeatedly, consider the following:
http://support.microsoft.com/kb/Q146092
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Document Information
Modified date:
15 June 2018
UID
swg21654717