IBM Support

Hardware and Software Requirements: Version 4.1.0 FlashCopy® Manager - All Unix Components

Preventive Service Planning


Abstract

This document details the hardware and software requirements for all of the IBM Tivoli Storage FlashCopy® Manager V4.1 components that run on AIX, Linux, HP-UX, and Solaris.

Content

The following Tivoli Storage FlashCopy Manager components share the same core hardware and software requirements. Therefore, the requirements for all of the following components are grouped together in a single requirements document. The components are:

  • FlashCopy Manager for DB2
  • FlashCopy Manager for Oracle
  • FlashCopy Manager for Oracle (with SAP® environments)
  • FlashCopy Manager for Custom Applications

Links to the Hardware & Software requirements for the other components that are a part of IBM Tivoli Storage FlashCopy Manager V4.1.0, are located at the following URL:
http://www.ibm.com/support/docview.wss?uid=swg21654207

Links to the hardware and software requirements for other releases of IBM Tivoli Storage FlashCopy® Manager, and its components, are located in the "All Requirements Document" located at the following URL:
http://www.ibm.com/support/docview.wss?uid=swg21427692


The IBM Tivoli Storage FlashCopy Manager V4.1.0 download document provides information about how and where to obtain the FlashCopy Manager V4.1.0 packages. The information is located here: http://www.ibm.com/support/docview.wss?uid=swg24035385

Information regarding virtualization technologies supported by IBM Tivoli Storage Manager FlashCopy Manager is available in the FlashCopy Manager Virtualization Support tech note located at the following at the following URL:
http://www.ibm.com/support/docview.wss?uid=swg21433737


This document is divided into linked sections for ease of navigation. You may use the links below to jump to the desired section of the document:


Requirements Common to All Components Additional Requirements Specific to FlashCopy Manager for DB2
Additional Requirements Specific to FlashCopy Manager for Oracle
Additional Requirements Specific to FlashCopy Manager for Oracle (with SAP® environments)
Additional Requirements Specific to FlashCopy Manager for Custom Applications


Note: For requirements marked with two asterisks (**) special attention needs to be paid to limitations documented at: http://www.ibm.com/support/docview.wss?&uid=swg21650880

Requirements Common to All Components

The following sections provide a quick overview of the basic requirements for FlashCopy® Manager.



Requirements Common to All Components on the AIX Platform

Hardware:

  • Compatible System p® server hardware supported by the operating system and the application
  • At least 1 GB of disk space (additional temporary space required during installation)
  • At least 1 GB of additional disk space for each database instance protected by FlashCopy Manager

Software:
  • One of these operating system options, as supported by the application:
  • 64-bit AIX 6.1, and later 6.1.x levels
  • 64-bit AIX 7.1, and later 7.1.x levels
  • Filesystems Supported: JFS, JFS2
  • The gzip utility must be installed on the system and must be available in the PATH environment variable.

Additional Operating Environments Supported:
  • High Availability Cluster Multiprocessing (HACMP™) and PowerHA®


Requirements Common to All Components on the Linux x64 Platform

Hardware:

  • Intel EM64T, AMD Opteron, or higher machine supported by the operating system and the application
  • At least 400 MB of disk space (additional temporary space required during installation)
  • At least 400 MB of additional disk space for each database instance protected by FlashCopy Manager

Software:
  • One of these operating system options, as supported by the application:
    • 64-bit SUSE Linux Enterprise Server (SLES) 11, and later 11.x levels
    • 64-bit Red Hat Enterprise Linux (RHEL) 5.1 up to 5.8
    • 64-bit Red Hat Enterprise Linux (RHEL) 6.1, 6.2, 6.3, 6.4, and 6.5
  • **Supported Logical Volume Manager: LVM2
  • Filesystems supported: ext2, ext3, ext4


Requirements Common to All Components on the HP-UX Platform

Hardware:
  • Intel Itanium based (IA-64) server hardware supported by the operating system and the application
  • At least 1.6 GB of disk space (additional temporary space required during installation)
  • At least 1.6 GB of additional disk space for each database instance protected by FlashCopy Manager

Software:
  • HP-UX 11i v3, as supported by the application
  • Supported Logical Volume Manager: HP-UX LVM
  • Supported filesystem: Veritas File System (VxFS) v5.0, and later 5.x levels


Requirements Common to All Components on the Solaris SPARC Platform

Hardware:
  • Compatible SPARC server hardware supported by the operating system and the application
  • At least 800 MB of disk space (additional temporary space required during installation)
  • At least 800 MB of additional disk space for each database instance protected by FlashCopy Manager

Software:
  • 64-bit Solaris 10 Update 4, and later 10.x levels, as supported by the application
  • FlashCopy Manager needs to run in the global zone.
  • **Veritas Volume Manager (VxVM) version 5.0, and later 5.x levels
  • Filesystems Supported: UFS, Veritas File System (VxFS) v5.0, and later 5.x levels


Requirements Common to All Components: External Disk Storage Options

IBM Storwize® V7000 v1 Disk System
IBM Storwize® V7000 Version 6.4
IBM Storwize® V7000 Version 7.1
IBM Storwize® V7000 Version 7.2
IBM Storwize® V7000 Version 7.3

IBM Storwize® v3700 Version 6.4
IBM Storwize® v3700 Version 7.1
IBM Storwize® v3700 Version 7.2
IBM Storwize® v3700 Version 7.3

IBM Storwize® v5000 Version 7.1
IBM Storwize® v5000 Version 7.2
IBM Storwize® v5000 Version 7.3

IBM Storwize® V7000 Unified v1.3 Disk System (block level support only)
IBM Storwize® V7000 Unified v1.4 Disk System (block level support only)
IBM Storwize® V7000 Unified v1.5 Disk System (block level support only)

IBM Flex System™ v7000 Version 6.4
IBM Flex System™ v7000 Version 7.1
IBM Flex System™ v7000 Version 7.2

IBM FlashSystem™ V840


IBM System Storage SAN Volume Controller (SVC) hardware with one of the following SVC levels:

  • IBM System Storage SAN Volume Controller v6.1.0, and later 6.1.x levels
  • IBM System Storage SAN Volume Controller v6.2.0, and later 6.2.x levels
  • IBM System Storage SAN Volume Controller v6.3.0, and later 6.3.x levels
  • IBM System Storage SAN Volume Controller v6.4.0, and later 6.4.x levels
  • IBM System Storage SAN Volume Controller v7.1.0, and later 7.1.x levels
  • IBM System Storage SAN Volume Controller v7.2.0, and later 7.2.x levels
  • IBM System Storage SAN Volume Controller v7.3.0, and later 7.3.x levels


IBM XIV® Storage System Hardware:
  • IBM XIV® 2nd Generation Storage System v10.0.0.b, and later 10.x levels
  • IBM XIV® 3rd Generation Storage System 11.x levels

IBM XIV® Storage System Software:
  • IBM XIV® Management Tools 3.x for all IBM XIV® Generations
  • IBM XIV® Management Tools 4.2 and later 4.2.x levels for all IBM XIV® Generations
    or
  • XIV® CLI 2.3.1 and later 2.x and 3.x levels for IBM XIV® 2nd Generation
  • XIV® CLI 3.0.1 and later 3.x levels for IBM XIV® 3nd Generation
  • XIV® CLI 4.2 and later 4.2.x levels for IBM XIV® 3nd Generation


IBM System Storage DS8000 hardware:
  • IBM System Storage DS8000™ (DS8100, DS8300, DS8700, DS8800 or DS8870) with DS8000 Release Version 3.1 or later versions. Earlier versions might be supported by certain microcode level updates. Please refer to the Pre-installation Checklist for details.

IBM System Storage N Series and NetApp hardware:
  • IBM System Storage N Series or NetApp data storage systems
  • Supported Data ONTAP versions:
    • 7.3, or later 7.3.x levels
    • 8.1, or later 8.1.x levels
  • Volumes must be attached via SAN, iSCSI or NFS.


Requirements Common to All Components for Off-loaded Backups to Tivoli Storage Manager

  • Any Tivoli Storage Manager (TSM) Server version currently in support by TSM
  • Any version of the TSM Storage Agent, currently in support by TSM, is required for LAN-free restore operations. The TSM Storage Agent is a component of the IBM Tivoli Storage Manager for Storage Area Networks product.
  • Data Protection for Oracle 6.3.x levels, or later releases and versions is required when performing Off-loaded Backups using the FlashCopy Manager for Oracle component. Data Protection for Oracle is a component of the IBM Tivoli Storage Manager for Databases product.
  • IBM Tivoli Storage Manager for Enterprise Resource Planning (ERP) V6.3, and later 6.3.x levels, releases, and versions is:
    • required when performing Off-loaded Backups in SAP® with Oracle environments.
    • required when performing Off-loaded Backups in SAP® with Oracle environments using Oracle RMAN.
    • optional when performing Off-loaded Backups in SAP® with DB2 environments.
      Note: For off-loaded backup of DB2 pureScale database, TSM for ERP is not supported.
  • IBM Tivoli Storage Manager Backup-Archive Client V6.3.x, and later 6.3.x levels, releases, and versions is required when performing Off-loaded Backups using the FlashCopy Manager for Custom Applications.
  • Any Tivoli Storage Manager API supported by Data Protection for Oracle and / or Tivoli Storage Manager for Enterprise Resource Planning and / or DB2 native TSM agent as applicable to your environment.


Overview of Storage Architecture Support for Tivoli Storage FlashCopy Manager

For more information regarding storage architecture support for the Tivoli Storage FlashCopy Manager product as it relates to platform and restore functionality, please refer to the following document:
http://www.ibm.com/support/docview.wss?uid=swg21455924

Additional Requirements Specific to FlashCopy Manager for DB2


Database Options:

  • 64-bit DB2 Enterprise Server Edition V9.7 (Solaris, HP-UX: Fix Pack 2) and later 9.7.x Fix Packs
  • 64-bit DB2 Enterprise Server Edition V10.1 Fix Pack 2 and later 10.1.x Fix Packs
  • 64-bit DB2 Enterprise Server Edition V10.5 and later 10.5.x Fix Packs
    Note: For support of DB2 pureScale, DB2 10.5 fixpack 4 is required.
  • SAP® environments must meet all requirements specified by SAP®.

Additional Requirements Specific to FlashCopy Manager for Oracle

Database Options:

  • 64-bit Oracle Database Standard Edition 11gR1, 11gR2
  • 64-bit Oracle Database Enterprise Edition 11gR1, 11gR2
  • **64-bit Oracle Real Application Clusters (RAC) option
  • **Supported database storage: File systems supported by FlashCopy® Manager, or Oracle ASM

Additional Requirements Specific to FlashCopy Manager for Oracle (with SAP® environments)

Supported environments must meet all requirements specified by SAP®.

Database Options:

  • 64-bit Oracle Enterprise Edition 11gR2 at a level certified by the respective SAP® release

SAP ® Environment Requirements:
  • SAP BR*Tools 7.10 patch level 14, and later patch levels
  • SAP BR*Tools 7.20 (patch level 6, and later patch levels are recommended)
  • SAP BR*Tools 7.40

Note: FlashCopy Manager interfaces with the SAP BR*Tools through the backint interface (BC-BRI volume based)

Additional Requirements Specific to FlashCopy Manager for Custom Applications

Application options:

  • Any application running in an environment supported by FlashCopy Manager



Pre-installation Checklist

Before starting the installation of IBM Tivoli Storage FlashCopy® Manager for Unix®, please review the pre-installation checklist and make sure all requirements specific to your environment are met.
FC_Manager_V4100_Preinstall_Checklist_rev09.pdfFC_Manager_V4100_Preinstall_Checklist_rev09.pdf


Installation Planning Worksheet

For a list of considerations and decisions to be taken before installing IBM Tivoli Storage FlashCopy® Manager for Unix®, please refer to the attached Installation Planning Sheet.

FC_Manager_V4100_Installation_Planning_Sheet.pdfFC_Manager_V4100_Installation_Planning_Sheet.pdf

Document information

More support for: Tivoli Storage FlashCopy Manager

Software version: 4.1

Operating system(s): AIX, HP-UX, Linux, Solaris

Reference #: 1650875

Modified date: 06 October 2016