IBM Support

A blank document or error "Could not init document. Parameters were null" is displayed in the Content Manager OnDemand Line Data Viewer Applet

Troubleshooting


Problem

Viewing a line data document in the IBM® Content Manager OnDemand Line Data Viewer Applet displays either a blank document or an error "Could not init document. Parameters were null".

Symptom

The Java console displays either similar error:



    No document data was received from server.
    Document has no pages!
    java.lang.reflect.InvocationTargetException
    at java.awt.EventQueue.invokeAndWait(Unknown Source)
    at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
    at com.ibm.edms.od.ODLineDataViewer$InitializeDataThread.run(ODLineDataViewer.java:350)
    Caused by: java.lang.NullPointerException
    at com.ibm.edms.od.LDVViewer.getCurrentPageNumber(LDVViewer.java:522)
    at com.ibm.edms.od.ODLineDataViewer$InitializeDataThread$2.run(ODLineDataViewer.java:355)
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)

or:
    No document data was received from server.
    Exception thrown while retrieving document: java.lang.Exception: Could not init document. Parameters were null.
    java.lang.Exception: Could not init document. Parameters were null.
    at com.ibm.edms.od.LDVLineDataDoc.initDocument(LDVLineDataDoc.java:187)
    at com.ibm.edms.od.ODLineDataViewer.init(ODLineDataViewer.java:119)
    at com.sun.deploy.uitoolkit.impl.awt.AWTAppletAdapter.init(Unknown Source)

The applet displays either of the following:


or:

Cause

No document data was received from your Content Manager OnDemand Web Enablement Kit (ODWEK) application. The most common cause when using WebSphere® Application Server is that the HTTPOnly session cookies setting is enabled.

Resolving The Problem

If running WebSphere Application Server, ensure HTTPOnly session cookies are disabled. To disable this setting:

  1. Log in to the WebSphere Application Server administrative console.
  2. Navigate to Servers > Server Types > Websphere Application servers and select the server where your ODWEK application is deployed.
  3. Select Session Management > Enable cookies and then clear the Set session cookies to HTTPOnly to help prevent cross-site scripting attacks option.
  4. Save the changes to the master configuration.
  5. Also ensure HTTPOnly is disabled at the application level under Applications > WebSphere enterprise applications > your_app_name > Session management > Enable cookies.
  6. Restart the web application server for your changes to take effect.

If HTTPOnly is disabled and the problem still persists, investigate the applet callback functionality in your ODWEK application.

[{"Product":{"code":"SSEPCD","label":"Content Manager OnDemand for Multiplatforms"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF025","label":"Platform Independent"},{"code":"PF033","label":"Windows"}],"Version":"9.0;8.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSQHWE","label":"Content Manager OnDemand for z\/OS"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF035","label":"z\/OS"},{"code":"","label":"OS\/390"}],"Version":"9.0;8.5","Edition":"All Editions","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSB2EG","label":"Content Manager OnDemand for i"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"5.4;6.1;7.1","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21645825