IBM Support

Intermittent "DPR-ERR-2107 ... DPR-ERR-2082" errors when using Controller triggered by the BI timeout setting "Inactivity timeout in seconds"

Troubleshooting


Problem

User launches Controller. After a while, an error appears. The error can appear whilst trying to use any functionality, so it will appear to occur at random. If the user simply logs off from Controller, and then re-launches the Controller client and re-tries, then the function works OK.

Symptom

German Example:


Log On IBM Cognos Controller
IBM Cognos software
DPR-ERR-2107
X Das Cache-Cookie fur die Benutzerrunktionen kann nicht decoriert werden.

Details
DPR-ERR-2082 Ein Fehler ist aufgetreten. Bitte.....
[OK]

Cause

There are several possible causes for this error.

  • TIP: For more examples, see separate IBM Technote #1652476.


This Technote specifically relates to the (most likely) scenario where the cause is a limitation in the Cognos BI (reporting/authentication) components that are shipped with Controller 10.1.1. This limitation is triggered when either of the following occurs:

  • (1) The user's Controller session has exceeded the BI timeout setting "Inactivity timeout in seconds".
  • or (2) The IIS timeout setting 'Idle Time-out (minutes)'' exceeds value of the BI timeout setting ("Inactivity timeout in seconds")

Resolving The Problem

Fix:
Upgrade to a future version of Controller, which is bundled with later Cognos BI components (which do not suffer from this limitation).

Workaround:
Perform both of the following:

  • Increase the value of "Inactivity timeout in seconds" from the default (3600 seconds = 60 minutes) to a value larger than the amount of time that the user will spend in their Controller session (for example 36000 = 10 hours).
  • Increase the value of 'Idle Time-out (minutes)' to match the value of "Inactivity timeout in seconds".


Steps:
The exact steps will vary depending on the operating system (for example Windows 2008 or 2012) of the application server.

  • Therefore, some of the following steps may look slightly different on your system.


1. Obtain a short period of downtime (no users on the system)
2. Logon to the 'Report Server' as a Windows administrator

  • TIP: Typically, most customers only have one server, so therefore the 'report server' will also be the Controller application server itself


3. From the Start Menu, launch "Cognos Configuration"
4. Open the section "Local Configuration - Security - Authentication"
5. Modify the setting "Inactivity timeout in seconds" from the current (default 3600) to something higher (e.g. 10 hours = 36000).
6. Click "Save"
7. Click the 'Restart' icon (which restarts the Cognos BI service).


Afterwards:
8. Launch 'Internet Information Services (IIS) Manager'
9. Browse to and open the section 'Application Pools'

10. The next step depends on what operating system you are using, and if you are using the default settings.

  • The following instructions assume that you have the default application pool names.
  • Therefore, you may need to modify these instructions if you have any non-default application pools created.


Windows 2008

  • Right-click on 'DefaultAppPool' and choose 'Advanced Settings':

  • Under 'Process Model', change the setting for 'Idle Time-out (minutes)' from the default (20) to a much larger value (for example 600 minutes, which is 10 hours).
  • Repeat these steps for any other non-default application pools (for example custom ones that you have created perviously) that are hosting any 'applications'


Windows 2012

  • Right-click on '.NET v2.0' and choose 'Advanced Settings':

  • Under 'Process Model', change the setting for 'Idle Time-out (minutes)' from the default (20) to a much larger value (for example 600 minutes, which is 10 hours).
  • Repeat these steps for the application pool called 'DefaultAppPool'
  • Also, if you have any other non-default application pools (for example custom ones that you have created perviously that are hosting any 'applications') then repeat the steps for those custom application pools
  • For example, in the following screen there are 4 separate application pools that are in use
  • The 3 whose name begin with 'ibmcognos' are custom-created application pools:



NOTE: In some environments, it is necessary to *also* alter the 'Application Pool Defaults' settings.

  • Specifically, right-click on the white/blank background and choose 'Set Application Pool Defaults...':
  • Change the value of 'Idle Time-out' from the current (20)...


...to something much larger (for example 600) and save the changes.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
19 October 2018

UID

swg21643735