IBM Support

How to configure client device to use two completely separate Controller 10.1.1 environments (for example separate 'production' and 'test' application servers)

Technote (troubleshooting)


Problem(Abstract)

Allowing users, such as all Controller super users, the ability to launch Controller on two separate Application Servers, for example Production and Test.

Symptom

NOTE: This Technote does not refer to the concept of having multiple databases (for example "production" and "test") on the same application server.

  • In other words, it does not refer to the concept of end users choosing their database (from a list) when they launch the client:

Instead, this Technote specifically relates to the scenario where the customer has at least two separate Controller application servers - each one runs Controller server components separately/independently of each other.

Cause

IMPORTANT: By design it is only possible to install one version of the Controller client (onto the end user's client device).

  • Therefore, it is only possible for this solution to work if all the separate environments ('production' and 'test' etc.) are based on *exactly* the same version of Controller (for example 10.1.2159).

Environment

The following steps are based on Controller 10.1, however they should work (with perhaps only minor alterations) for all Controller versions.

  • In addition, these instructions should work both on 'local' client installs (Controller client installed on end user's desktop PCs/laptops) and also on Citrix/Terminal Servers.

Resolving the problem

The exact solution depends on which of the three Controller client MSI files you used to install the client.

  • TIP: For a description of each of these MSI files, see separate IBM Technote #1371088.

(1) "ControllerClient.MSI" & "ClientAdmin.MSI".
These are often referred to as the ' web clients'.

Perform the following steps on the client device (for example end user's PC or Citrix/Terminal Server):
    1. Create a shortcut (for example on the end user's Windows 'desktop) to the 'production' server's ccr.exe URL, for example:
    • http://prodserver/ibmcognos/controllerbin/ccr.exe
    2. Create a shortcut (for example on the end user's Windows 'desktop) to the 'test' server's ccr.exe URL, for example:
    • http://testserver/ibmcognos/controllerbin/ccr.exe
    3. Inform the end user that:
    • They can use one OR the other shortcuts at any one time.
    • Do not attempt to run both Controller shortcuts simultaneously, since this will cause errors/unexpected problems
    • Always remember to fully close the Controller client *and* Microsoft Excel before switching to a different environment (for example when changing from 'production' to 'test' environments)
    • Make sure that they do not get confused between which environment they are in. It is easy to perform work in the 'wrong' environment by accident!

(2) "CCRLocalClient.MSI"
This is often referred to as the ' local client'.
  • It is the most popular client for most customers from Controller 10.1 onwards.

Perform the following steps on the client device (for example end user's PC or Citrix/Terminal Server):
    1. Make sure that each of the separate environments ('production' and 'test' etc.) are based on *exactly* the same version of Controller (for example 10.1.2159)
    • TIP: Click "Help - System Info" inside Controller to check the exact version of Controller.

    2. Install the local client and configure it to point to one of the environments (for example "production")
    3. Launch Windows Explorer, and browse to the folder where the client was installed (by default this is: C:\Program Files (x86)\IBM\IBM Cognos Controller)
    4. Copy the entire folder to a new location, and call it a sensible name
    • For example, the new 'copy' of the folder could be called: "C:\Program Files (x86)\IBM\IBM Cognos Controller TEST ENVIRONMENT"
    5. Open the ccr.exe.config file inside that *new* folder
    • For example, open the following file inside NOTEPAD.EXE: "C:\Program Files (x86)\IBM\IBM Cognos Controller TEST ENVIRONMENT\ccr.exe.config"
    6. Locate the section that looks similar to:
      <add key="CASUrl" value="C:\Program Files (x86)\IBM\ IBM Cognos Controller\"/>
      <add key="WSSUrl" value="http:// prodserver/ibmcognos/controllerserver"/>
      <add key="HelpUrl" value="http:// prodserver/ibmcognos/controllerhelp"/>

    7. Modify it so it looks similar to:
      <add key="CASUrl" value="C:\Program Files (x86)\IBM\ IBM Cognos Controller TEST ENVIRONMENT \"/>
      <add key="WSSUrl" value="http:// testserver/ibmcognos/controllerserver"/>
      <add key="HelpUrl" value="http:// testserver/ibmcognos/controllerhelp"/>

    8. Save changes
    9. Create two shortcuts (for example on the Windows desktop) for the end user:
    • Controller Production - which points to: C:\Program Files (x86)\IBM\IBM Cognos Controller\ccr.exe
    • Controller Test - which points to: C:\Program Files (x86)\IBM\IBM Cognos Controller TEST ENVIRONMENT\ccr.exe

    10. Inform the end user that:
    • They can use one OR the other clients at any one time.
    • Do not attempt to run both Controller clients simultaneously, since this will cause errors/unexpected problems
    • Always remember to fully close the Controller client *and* Microsoft Excel before switching to a different environment (for example when changing from 'production' to 'test' environments)
    • Make sure that they do not get confused between which environment they are in. It is easy to perform work in the 'wrong' environment by accident!

Related information

1371088 - What is the difference between the different

Document information

More support for: Cognos Controller
Controller

Software version: 10.1, 10.1.1

Operating system(s): Windows

Reference #: 1640592

Modified date: 18 July 2013