IBM Support

"This program cannot display the webpage" or "Navigation to the webpage was canceled" when click "Help"

Troubleshooting


Problem

User launches the Controller client. Inside Controller, user clicks "Help - Contents". User receives error.

Symptom

Navigation to the webpage was canceled

What you can try:

Refresh the page.


Then:

This program cannot display the webpage

Most likely causes:

* You are not connected to the Internet

* The website is encountering problems.

* There might be a typing error in the address.


Cause

Incorrect IIS (web server) configuration on the Controller application server.

For example, in one real-life customer example, the folder "C:\Program Files (x86)\ibm\cognos\c10\webcontent" incorrectly contained an IIS configuration file ("web.config") whose contents were to create a redirect (to /ibmcognos/controllerbin/ccr.exe).

  • In turn, the cause for this was that the redirect was intended to be created for the virtual directory 'controller', but accidentally created on the wrong virtual directory ("controllerhelp").

Resolving The Problem

Ensure that:


    1. The relevant location (e.g. "C:\Program Files (x86)\ibm\cognos\c10\webcontent") does *not* contain a file "Web.Config"
      • If it does, then rename this file to "web.config.bad" and re-try.
    2. The virtual directory "controllerhelp" is correctly configured to connect to the correct location (e.g. "C:\Program Files (x86)\ibm\cognos\c10\webcontent")

Steps:
1. As a precaution, create a backup (e.g. virtual snapshot) of the Controller application server
2. Logon to the Controller application server as a Windows administrator
3. Browse to the relevant folder
  • TIP: By default, this is C:\Program Files (x86)\ibm\cognos\c10\webcontent

4. If there is a file called "web.config" (inside this folder), then delete it (or rename it to "web.config.bad")

5. Launch IIS Manager
6. Locate the virtual directory 'controllerhelp'


7. Right-click on it, and choose 'Manage Virtual Directory - Advanced Settings'
8. Check that it looks correct:


9. Make changes/correct as necessary
10. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21631978